Daemon Power

The NetBSD Packages Collection: chat/farstream

Brief description of the package:
Audio/video communications framework

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://www.freedesktop.org/wiki/Software/Farstream/.

Please note that this package has a gnu-lgpl-v2.1 license.

The package is located in the "chat/farstream" directory. The current source version of the package is "farstream-0.2.8nb2". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for chat/farstream :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: glib2>=2.16.0 perl>=5.0 cwrappers>=20150314 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 glib2>=2.4.0 gst-plugins1-base>=1.4 orc>=0.4.6 gstreamer1>=1.10.0 gobject-introspection>=0.6.14nb1 py27-cElementTree-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 py27-expat-[0-9]* glib2>=2.50.0 libffi>=3.0.0 glib2>=2.34.0 gobject-introspection>=1.34.0 gstreamer1>=1.0.0 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 gst-plugins1-base>=1.0.0 gstreamer1>=1.4 gupnp-igd>=0.2.1 gupnp>=0.20.3 glib2>=2.39.90 libsoup>=2.48.0 glib-networking-[0-9]* glib2>=2.46.0 libproxy>=0.3.1 libproxy>=0.2.3 gnutls>=3.0 lzo>=2.01 autogen>=5.12nb5 bash-[0-9]* guile20>=2.0 gmp>=4.2.1 libltdl>=2.4.2 libunistring>=0.9.3 boehm-gc>=7.4.2nb1 libatomic_ops>=7.4.0<2000 boehm-gc>=7.4 gmp>=5.0.1 libltdl>=2.2.6 libunistring>=0.9.4 guile20>=2.0.12nb1 libcfg+>=0.6.2nb1 libtasn1>=4.9 libtasn1>=0.2.7 nettle>=3.1 gmp>=5.0 nettle>=2.4 libcfg+>=0.6.2nb3 libtasn1>=0.3.0 nettle>=3.1.1 gnutls>=3.3.0 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libproxy>=0.4.11 gnutls>=3.5.4 libgcrypt>=1.6.0 glib2>=2.38.0 gobject-introspection>=0.9.5 libsoup>=2.50.0 gssdp>=0.14.15 vala>=0.32 glib2>=2.32.0 libsoup>=2.54.1nb1 gssdp>=0.12.2.1 gssdp>=1.0.0nb1 glib2>=2.14.0 gupnp>=1.0.0nb1 gtk-doc>=1.18 docbook-xml>=4.4nb1 docbook-xsl>=1.68.1 docbook-xml>=4.2 pkgconf-[0-9]* libxslt>=1.1.8 libxml2>=2.6.27 docbook-xml-[0-9]* docbook-xsl-[0-9]* rarian>=0.6.0 getopt-[0-9]* libxslt>=1.1.28nb2 itstool-[0-9]* py27-libxml2-[0-9]* libxml2>=2.9.4nb2 py27-expat>=0 gnome-doc-utils>=0.8.0 py27-libxml2>=2.6.16 py27-libxslt>=1.1.12 py27-libxml2>=2.6.8 libxslt>=1.1.29 docbook-xml>=4.5 libxml2>=2.6.12 libnice>=0.1.0 gupnp-igd>=0.2.3nb8 libnice>=0.0.9 libnice>=0.1.13nb4 .

This package requires the following package(s) to run: glib2>=2.16.0 perl>=5.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 glib2>=2.4.0 gst-plugins1-base>=1.4 orc>=0.4.6 gstreamer1>=1.10.0 gobject-introspection>=0.6.14nb1 py27-cElementTree-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 python27>=2.7.1nb2 py27-expat-[0-9]* glib2>=2.50.0 libffi>=3.0.0 glib2>=2.34.0 gobject-introspection>=1.34.0 gstreamer1>=1.0.0 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 gst-plugins1-base>=1.0.0 gstreamer1>=1.4 gupnp-igd>=0.2.1 gupnp>=0.20.3 glib2>=2.39.90 libsoup>=2.48.0 glib-networking-[0-9]* glib2>=2.46.0 libproxy>=0.3.1 libproxy>=0.2.3 gnutls>=3.0 lzo>=2.01 autogen>=5.12nb5 bash-[0-9]* guile20>=2.0 gmp>=4.2.1 libltdl>=2.4.2 libunistring>=0.9.3 boehm-gc>=7.4.2nb1 libatomic_ops>=7.4.0<2000 boehm-gc>=7.4 readline>=2.2 gmp>=5.0.1 libltdl>=2.2.6 libunistring>=0.9.4 readline>=6.0 guile20>=2.0.12nb1 libcfg+>=0.6.2nb1 libtasn1>=4.9 libtasn1>=0.2.7 nettle>=3.1 gmp>=5.0 nettle>=2.4 libcfg+>=0.6.2nb3 libtasn1>=0.3.0 nettle>=3.1.1 gnutls>=3.3.0 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libproxy>=0.4.11 gnutls>=3.5.4 libgcrypt>=1.6.0 glib2>=2.38.0 libsoup>=2.50.0 gssdp>=0.14.15 vala>=0.32 glib2>=2.32.0 libsoup>=2.54.1nb1 gssdp>=0.12.2.1 gssdp>=1.0.0nb1 glib2>=2.14.0 gupnp>=1.0.0nb1 libnice>=0.1.0 gupnp-igd>=0.2.3nb8 libnice>=0.0.9 libnice>=0.1.13nb4 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
earm:farstream-0.2.7.tgz(NetBSD 7.0)
earm:farstream-0.2.7.tgz(NetBSD 7.0)
earmv6hf:farstream-0.2.7.tgz(NetBSD 7.0)
earmv7hf:farstream-0.2.7.tgz(NetBSD 7.0)
earmv7hfeb:farstream-0.2.7.tgz(NetBSD 7.0)
i386:farstream-0.2.7.tgz(NetBSD 6.0)
i386:farstream-0.2.8nb1.tgz(NetBSD 6.0)
i386:farstream-0.2.8nb1.tgz(NetBSD 6.0)
i386:farstream-0.2.8nb2.tgz(NetBSD 7.0)
i386:farstream-0.2.7.tgz(NetBSD 7.0.0_PATCH)
i386:farstream-0.2.8nb1.tgz(NetBSD 7.0)
i386:farstream-0.2.8nb1.tgz(NetBSD 7.0)
powerpc:farstream-0.2.8nb1.tgz(NetBSD 6.0)
powerpc:farstream-0.2.7.tgz(NetBSD 6.0)
powerpc:farstream-0.2.8nb1.tgz(NetBSD 6.0)
powerpc:farstream-0.2.8nb2.tgz(NetBSD 6.1)
powerpc:farstream-0.2.7.tgz(NetBSD 7.0)
sparc64:farstream-0.2.7.tgz(NetBSD 7.0)
sparc64:farstream-0.2.8nb2.tgz(NetBSD 7.1_RC1)
x86_64:farstream-0.2.7.tgz(NetBSD 6.0)
x86_64:farstream-0.2.8nb1.tgz(NetBSD 6.0)
x86_64:farstream-0.2.8nb1.tgz(NetBSD 6.0)
x86_64:farstream-0.2.8nb2.tgz(NetBSD 6.1)
x86_64:farstream-0.2.8nb1.tgz(NetBSD 6.1)
x86_64:farstream-0.2.8nb1.tgz(NetBSD 6.1)
x86_64:farstream-0.2.8nb2.tgz(NetBSD 7.0)
x86_64:farstream-0.2.7.tgz(NetBSD 7.0.0_PATCH)
x86_64:farstream-0.2.8nb1.tgz(NetBSD 7.0)
x86_64:farstream-0.2.8nb1.tgz(NetBSD 7.0)
x86_64:farstream-0.2.8nb2.tgz(NetBSD 7.0.1_PATCH)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]