chat/gajim-plugin-omemo - The NetBSD Packages Collection

OMEMO encryption support for Gajim

OMEMO is an XMPP Extension Protocol (XEP) for secure multi-client
end-to-end encryption. It is an open standard based on a Double Ratchet
and PEP which can be freely used and implemented by anyone. The protocol
has been audited by a third party.

This package contains the OMEMO plugin for Gajim.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

chat/gajim chat/py-axolotl graphics/py-qrcode lang/python38 lang/python38

Available binary packages

aarch64:gajim-plugin-omemo-2.6.28.tgz(NetBSD 9.0)
aarch64:gajim-plugin-omemo-2.6.28.tgz(NetBSD 9.0)
aarch64:gajim-plugin-omemo-2.6.28nb1.tgz(NetBSD 9.0)
earmv6hf:gajim-plugin-omemo-2.6.28nb1.tgz(NetBSD 9.0)
earmv6hf:gajim-plugin-omemo-2.6.28.tgz(NetBSD 9.0)
earmv6hf:gajim-plugin-omemo-2.6.28nb1.tgz(NetBSD 9.0)
earmv7hf:gajim-plugin-omemo-2.6.28nb1.tgz(NetBSD 8.0)
earmv7hf:gajim-plugin-omemo-2.6.28.tgz(NetBSD 8.0)
earmv7hf:gajim-plugin-omemo-2.6.28.tgz(NetBSD 8.0)
earmv7hf:gajim-plugin-omemo-2.6.28nb1.tgz(NetBSD 9.0)
earmv7hf:gajim-plugin-omemo-2.6.28.tgz(NetBSD 9.0)
earmv7hf:gajim-plugin-omemo-2.6.28.tgz(NetBSD 9.0)
earmv7hf:gajim-plugin-omemo-2.6.28.tgz(NetBSD 9.0)
earmv7hf:gajim-plugin-omemo-2.6.28nb1.tgz(NetBSD 9.0)
i386:gajim-plugin-omemo-2.6.28.tgz(NetBSD 8.0)
i386:gajim-plugin-omemo-2.6.28.tgz(NetBSD 8.0)
i386:gajim-plugin-omemo-2.6.28nb1.tgz(NetBSD 8.0)
i386:gajim-plugin-omemo-2.6.28.tgz(NetBSD 9.0)
i386:gajim-plugin-omemo-2.6.28.tgz(NetBSD 9.0)
i386:gajim-plugin-omemo-2.6.28nb1.tgz(NetBSD 9.0)
mips64eb:gajim-plugin-omemo-2.6.28.tgz(NetBSD 9.0)
powerpc:gajim-plugin-omemo-2.6.28.tgz(NetBSD 8.0)
powerpc:gajim-plugin-omemo-2.6.28nb1.tgz(NetBSD 8.0)
powerpc:gajim-plugin-omemo-2.6.28nb1.tgz(NetBSD 9.0)
powerpc:gajim-plugin-omemo-2.6.28.tgz(NetBSD 9.0)
sparc64:gajim-plugin-omemo-2.6.28nb1.tgz(NetBSD 9.0)
sparc64:gajim-plugin-omemo-2.6.28.tgz(NetBSD 9.0)
x86_64:gajim-plugin-omemo-2.6.28.tgz(NetBSD 9.0)
x86_64:gajim-plugin-omemo-2.6.28nb1.tgz(NetBSD 9.0)
x86_64:gajim-plugin-omemo-2.6.28nb1.tgz(NetBSD 9.0)
x86_64:gajim-plugin-omemo-2.6.28.tgz(NetBSD 9.0)
x86_64:gajim-plugin-omemo-2.6.28.tgz(NetBSD 8.0)
x86_64:gajim-plugin-omemo-2.6.28.tgz(NetBSD 8.0)
x86_64:gajim-plugin-omemo-2.6.28nb1.tgz(NetBSD 8.0)
x86_64:gajim-plugin-omemo-2.6.28.tgz(NetBSD 9.0)
x86_64:gajim-plugin-omemo-2.6.28.tgz(NetBSD 9.0)
x86_64:gajim-plugin-omemo-2.6.28nb1.tgz(NetBSD 9.0)
x86_64:gajim-plugin-omemo-2.6.28nb1.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]