Daemon Power

The NetBSD Packages Collection: chat/libpurple

Brief description of the package:
Multi-protocol Instant Messaging client backend

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://www.pidgin.im/.

Please note that this package has a gnu-gpl-v2 license.

The package is located in the "chat/libpurple" directory. The current source version of the package is "libpurple-2.12.0nb1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for chat/libpurple :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: GConf>=2.8.0.1 glib2>=2.28 perl>=5.0 cwrappers>=20150314 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 glib2>=2.4.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 readline>=2.2 readline>=6.0 ORBit2>=2.12.0 glib2>=2.8.0 libIDL>=0.8.3nb1 glib2>=2.34.0 libIDL>=0.8.14nb4 dbus>=0.91 xmlto-[0-9]* getopt-[0-9]* docbook-xsl>=1.67.0nb1 docbook-xml>=4.2 xmlcatmgr>=2.0beta1 libxml2>=2.6.2 bash-[0-9]* libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 libxml2>=2.8.0nb2 docbook-xml-[0-9]* docbook-xsl-[0-9]* libxslt>=1.1.28nb2 x11-links>=1.04 osabi-NetBSD-7.0.1 dbus-glib>=0.61 glib2>=2.32 dbus>=1.8 python27>=2.7.1nb2 ORBit2>=2.14.19nb4 dbus-glib>=0.74 dbus-glib>=0.100nb1 nss>=3.14.0 sqlite3>=3.8.4.2 sqlite3>=3.0.8 nspr>=4.13.1 nspr>=4.9.3.2 sqlite3>=3.18.0nb1 py27-dbus>=0.23.4 py27-expat-[0-9]* dbus>=1.6 dbus-python-common>=1.1.1 dbus>=1.0 farstream>=0.2.7 glib2>=2.16.0 gst-plugins1-base>=1.4 orc>=0.4.6 gstreamer1>=1.10.0 gobject-introspection>=0.6.14nb1 py27-cElementTree-[0-9]* glib2>=2.50.0 libffi>=3.0.0 gobject-introspection>=1.34.0 gstreamer1>=1.0.0 gst-plugins1-base>=1.0.0 gstreamer1>=1.4 gupnp-igd>=0.2.1 gupnp>=0.20.3 glib2>=2.39.90 libsoup>=2.48.0 glib-networking-[0-9]* glib2>=2.46.0 libproxy>=0.3.1 libproxy>=0.2.3 gnutls>=3.0 lzo>=2.01 autogen>=5.12nb5 guile20>=2.0 gmp>=4.2.1 libltdl>=2.4.2 libunistring>=0.9.3 boehm-gc>=7.4.2nb1 libatomic_ops>=7.4.0<2000 boehm-gc>=7.4 gmp>=5.0.1 libltdl>=2.2.6 libunistring>=0.9.4 guile20>=2.0.12nb1 libcfg+>=0.6.2nb1 libtasn1>=4.9 libtasn1>=0.2.7 nettle>=3.1 gmp>=5.0 nettle>=2.4 libcfg+>=0.6.2nb3 libtasn1>=0.3.0 nettle>=3.1.1 gnutls>=3.3.0 libproxy>=0.4.11 gnutls>=3.5.4 glib2>=2.38.0 gobject-introspection>=0.9.5 libsoup>=2.50.0 gssdp>=0.14.15 vala>=0.36 glib2>=2.32.0 libsoup>=2.54.1nb3 gssdp>=0.12.2.1 gssdp>=1.0.0nb2 glib2>=2.14.0 gupnp>=1.0.0nb2 gtk-doc>=1.18 docbook-xml>=4.4nb1 docbook-xsl>=1.68.1 pkgconf-[0-9]* rarian>=0.6.0 itstool-[0-9]* py27-libxml2-[0-9]* libxml2>=2.9.4nb3 py27-expat>=0 gnome-doc-utils>=0.8.0 py27-libxml2>=2.6.16 py27-libxslt>=1.1.12 py27-libxml2>=2.6.8 py27-libxml2>=2.6.27 libxslt>=1.1.29nb1 docbook-xml>=4.5 libxml2>=2.6.12 libnice>=0.1.0 glib2>=2.44.0 gupnp-igd>=0.2.3nb9 libnice>=0.0.9 libnice>=0.1.14nb1 libidn>=0.4.6 GConf>=2.32.4nb5 py27-dbus>=1.1.1nb1 libidn>=1.20nb1 .

This package requires the following package(s) to run: GConf>=2.8.0.1 glib2>=2.28 perl>=5.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 glib2>=2.4.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 ORBit2>=2.12.0 glib2>=2.8.0 libIDL>=0.8.3nb1 glib2>=2.34.0 libIDL>=0.8.14nb4 dbus>=0.91 dbus-glib>=0.61 glib2>=2.32 dbus>=1.8 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 python27>=2.7.1nb2 ORBit2>=2.14.19nb4 dbus-glib>=0.74 dbus-glib>=0.100nb1 libxml2>=2.8.0nb2 nss>=3.14.0 sqlite3>=3.8.4.2 sqlite3>=3.0.8 nspr>=4.13.1 nspr>=4.9.3.2 sqlite3>=3.18.0nb1 py27-dbus>=0.23.4 py27-expat-[0-9]* dbus>=1.6 farstream>=0.2.7 glib2>=2.16.0 gst-plugins1-base>=1.4 orc>=0.4.6 gstreamer1>=1.10.0 gobject-introspection>=0.6.14nb1 py27-cElementTree-[0-9]* glib2>=2.50.0 libffi>=3.0.0 gobject-introspection>=1.34.0 gstreamer1>=1.0.0 gst-plugins1-base>=1.0.0 gstreamer1>=1.4 gupnp-igd>=0.2.1 gupnp>=0.20.3 glib2>=2.39.90 libsoup>=2.48.0 glib-networking-[0-9]* glib2>=2.46.0 libproxy>=0.3.1 libproxy>=0.2.3 gnutls>=3.0 lzo>=2.01 autogen>=5.12nb5 bash-[0-9]* guile20>=2.0 gmp>=4.2.1 libltdl>=2.4.2 libunistring>=0.9.3 boehm-gc>=7.4.2nb1 libatomic_ops>=7.4.0<2000 boehm-gc>=7.4 readline>=2.2 gmp>=5.0.1 libltdl>=2.2.6 libunistring>=0.9.4 readline>=6.0 guile20>=2.0.12nb1 libcfg+>=0.6.2nb1 libtasn1>=4.9 libtasn1>=0.2.7 nettle>=3.1 gmp>=5.0 nettle>=2.4 libcfg+>=0.6.2nb3 libtasn1>=0.3.0 nettle>=3.1.1 gnutls>=3.3.0 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libproxy>=0.4.11 gnutls>=3.5.4 libgcrypt>=1.6.0 glib2>=2.38.0 libsoup>=2.50.0 gssdp>=0.14.15 vala>=0.36 glib2>=2.32.0 libsoup>=2.54.1nb3 gssdp>=0.12.2.1 gssdp>=1.0.0nb2 glib2>=2.14.0 gupnp>=1.0.0nb2 libnice>=0.1.0 glib2>=2.44.0 gupnp-igd>=0.2.3nb9 libnice>=0.0.9 libnice>=0.1.14nb1 libidn>=0.4.6 GConf>=2.32.4nb5 py27-dbus>=1.1.1nb1 libidn>=1.20nb1 .

This package supports the following build-time options:

avahi
Enable DNS service discovery and multicast DNS support.
dbus
Enable dbus (desktop bus) support.
debug
Enable debugging facilities in the package.
farstream
Enable farstream support.
gnome
Enable GNOME support.
gnutls
Enable GNU TLS support.
gstreamer
Enable gstreamer support.
perl
Enable Perl support.
sasl
Enable SASL support.
tcl
Enable Tcl scripting support.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
earm:libpurple-2.10.11nb3.tgz(NetBSD 7.0)
earm:libpurple-2.10.11nb2.tgz(NetBSD 7.0)
earm:libpurple-2.10.11nb3.tgz(NetBSD 7.0)
earm:libpurple-2.10.11nb3.tgz(NetBSD 7.0)
earmv6hf:libpurple-2.10.11.tgz(NetBSD 7.0)
earmv6hf:libpurple-2.10.11nb3.tgz(NetBSD 7.0)
earmv6hf:libpurple-2.10.11nb3.tgz(NetBSD 7.0)
earmv7hf:libpurple-2.10.11nb3.tgz(NetBSD 7.0)
earmv7hf:libpurple-2.10.11nb3.tgz(NetBSD 7.0)
earmv7hf:libpurple-2.10.11nb3.tgz(NetBSD 7.99.21)
i386:libpurple-2.12.0nb1.tgz(NetBSD 6.0)
i386:libpurple-2.10.12nb5.tgz(NetBSD 6.0)
i386:libpurple-2.12.0.tgz(NetBSD 6.0)
i386:libpurple-2.12.0nb1.tgz(NetBSD 7.0)
i386:libpurple-2.10.12nb5.tgz(NetBSD 7.0)
i386:libpurple-2.10.12nb5.tgz(NetBSD 7.0)
i386:libpurple-2.12.0.tgz(NetBSD 7.0)
powerpc:libpurple-2.10.12nb2.tgz(NetBSD 6.0)
powerpc:libpurple-2.12.0.tgz(NetBSD 6.1)
powerpc:libpurple-2.12.0nb1.tgz(NetBSD 6.1)
powerpc:libpurple-2.10.12nb5.tgz(NetBSD 6.1)
powerpc:libpurple-2.10.11nb3.tgz(NetBSD 7.0)
powerpc:libpurple-2.10.11nb3.tgz(NetBSD 7.0)
powerpc:libpurple-2.12.0.tgz(NetBSD 7.1)
powerpc:libpurple-2.12.0nb1.tgz(NetBSD 8.0)
sparc64:libpurple-2.10.9nb1.tgz(NetBSD 6.1_STABLE)
sparc64:libpurple-2.10.11nb2.tgz(NetBSD 7.0)
sparc64:libpurple-2.10.11nb3.tgz(NetBSD 7.0)
sparc64:libpurple-2.10.12nb5.tgz(NetBSD 7.1_RC1)
sparc64:libpurple-2.10.11nb2.tgz(NetBSD 7.0)
x86_64:libpurple-2.12.0nb1.tgz(NetBSD 6.0)
x86_64:libpurple-2.10.12nb5.tgz(NetBSD 6.0)
x86_64:libpurple-2.12.0.tgz(NetBSD 6.0)
x86_64:libpurple-2.12.0nb1.tgz(NetBSD 6.1)
x86_64:libpurple-2.10.12nb5.tgz(NetBSD 6.1)
x86_64:libpurple-2.10.12nb5.tgz(NetBSD 6.1)
x86_64:libpurple-2.12.0.tgz(NetBSD 6.1)
x86_64:libpurple-2.12.0nb1.tgz(NetBSD 7.0)
x86_64:libpurple-2.10.12nb5.tgz(NetBSD 7.0)
x86_64:libpurple-2.10.12nb5.tgz(NetBSD 7.0)
x86_64:libpurple-2.12.0.tgz(NetBSD 7.0)
x86_64:libpurple-2.12.0nb1.tgz(NetBSD 7.0.1_PATCH)
x86_64:libpurple-2.12.0nb1.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]