chat/profanity - The NetBSD Packages Collection

Console based XMPP client inspired by irssi

Profanity is a simple lightweight console based XMPP chat client.
Its emphasis is on having a simple and configurable command driven UI.

Build dependencies

pkgtools/cwrappers devel/glib2-tools devel/libtool-base devel/autoconf devel/pkgconf

Runtime dependencies

security/gnupg2 chat/libmesode chat/libotr chat/libsignal-protocol-c devel/glib2 devel/libuuid devel/readline security/gpgme textproc/libxml2 lang/python38 lang/python38 www/curl chat/libotr devel/glib2 devel/readline security/gpgme textproc/libxml2 www/curl

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfprofanity-0.9.5nb2.tgz
NetBSD 8.0earmv7hfprofanity-0.9.5nb4.tgz
NetBSD 8.0i386profanity-0.9.5.tgz
NetBSD 8.0i386profanity-0.9.5nb2.tgz
NetBSD 8.0i386profanity-0.9.5nb4.tgz
NetBSD 8.0powerpcprofanity-0.9.5nb2.tgz
NetBSD 8.0powerpcprofanity-0.9.5nb2.tgz
NetBSD 8.0x86_64profanity-0.9.5.tgz
NetBSD 8.0x86_64profanity-0.9.5nb2.tgz
NetBSD 9.0aarch64profanity-0.9.5nb4.tgz
NetBSD 9.0aarch64profanity-0.9.5.tgz
NetBSD 9.0aarch64profanity-0.9.5nb2.tgz
NetBSD 9.0alphaprofanity-0.9.5.tgz
NetBSD 9.0alphaprofanity-0.9.5nb2.tgz
NetBSD 9.0earmv6hfprofanity-0.9.5nb4.tgz
NetBSD 9.0earmv6hfprofanity-0.9.5.tgz
NetBSD 9.0earmv6hfprofanity-0.9.5nb2.tgz
NetBSD 9.0earmv6hfprofanity-0.9.5nb2.tgz
NetBSD 9.0earmv7hfprofanity-0.9.5nb4.tgz
NetBSD 9.0earmv7hfprofanity-0.9.5.tgz
NetBSD 9.0earmv7hfprofanity-0.9.5nb2.tgz
NetBSD 9.0earmv7hfprofanity-0.9.5nb2.tgz
NetBSD 9.0i386profanity-0.9.5.tgz
NetBSD 9.0i386profanity-0.9.5nb2.tgz
NetBSD 9.0i386profanity-0.9.5nb4.tgz
NetBSD 9.0mips64ebprofanity-0.9.5.tgz
NetBSD 9.0mips64ebprofanity-0.9.5nb2.tgz
NetBSD 9.0powerpcprofanity-0.9.5nb2.tgz
NetBSD 9.0powerpcprofanity-0.9.5.tgz
NetBSD 9.0sparc64profanity-0.9.5.tgz
NetBSD 9.0sparc64profanity-0.9.5nb2.tgz
NetBSD 9.0sparcprofanity-0.9.5nb2.tgz
NetBSD 9.0x86_64profanity-0.9.5nb1.tgz
NetBSD 9.0x86_64profanity-0.9.5nb2.tgz
NetBSD 9.0x86_64profanity-0.9.5nb4.tgz
NetBSD 9.0x86_64profanity-0.9.5.tgz
NetBSD 9.0x86_64profanity-0.9.5nb2.tgz
NetBSD 9.0x86_64profanity-0.9.5nb4.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

gtk2
Enable support for GTK2.
libnotify
Enable libnotify support.
xscrnsaver
Enable X11 Screen Saver support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.