Daemon Power

The NetBSD Packages Collection: converters/libe-book

Brief description of the package:
Library for importing non-HTML reflowable e-book formats

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://sourceforge.net/projects/libebook/.

Please note that this package has a mpl-2.0 license.

The package is located in the "converters/libe-book" directory. The current source version of the package is "libe-book-0.1.3nb7". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for converters/libe-book :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: libwpd>=0.9.5 librevenge>=0.0.1 boost-libs-1.69.* icu>=3.4 python37>=3.7 libffi>=1.20 cwrappers>=20150314 libuuid>=2.18 libffi>=3.0.11 readline>=2.2 readline>=6.0 python37>=3.7.0 icu>=64.1 boost-jam-1.69.* cppunit>=1.10.2 boost-libs>=1.69.0 cppunit>=1.10.2nb5 boost-headers-1.69.* librevenge>=0.0.4nb8 liblangtag>=0.4.0 glib2>=2.4.0 pcre>=3.4nb1 pcre>=8.30nb1 py37-meson-[0-9]* ninja-build-[0-9]* re2c>=0.11.3 py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7.3 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 glib2>=2.34.0 libxml2>=2.8.0nb2 libwpd>=0.10.1nb8 .

This package requires the following package(s) to run: libwpd>=0.9.5 librevenge>=0.0.1 boost-libs-1.69.* icu>=3.4 python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.0.11 python37>=3.7.0 icu>=64.1 cppunit>=1.10.2 boost-libs>=1.69.0 cppunit>=1.10.2nb5 librevenge>=0.0.4nb8 liblangtag>=0.4.0 glib2>=2.4.0 pcre>=3.4nb1 pcre>=8.30nb1 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 glib2>=2.34.0 libxml2>=2.8.0nb2 libwpd>=0.10.1nb8 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
earm:libe-book-0.1.2nb4.tgz(NetBSD 7.0)
earmv6hf:libe-book-0.1.2nb4.tgz(NetBSD 7.0)
earmv6hf:libe-book-0.1.3nb6.tgz(NetBSD 8.0)
earmv6hf:libe-book-0.1.3nb6.tgz(NetBSD 8.0)
earmv7hf:libe-book-0.1.2nb4.tgz(NetBSD 7.0)
earmv7hf:libe-book-0.1.3nb6.tgz(NetBSD 8.0)
earmv7hf:libe-book-0.1.3nb6.tgz(NetBSD 8.0)
earmv7hf:libe-book-0.1.3nb6.tgz(NetBSD 8.0)
earmv7hfeb:libe-book-0.1.2nb4.tgz(NetBSD 7.0)
earmv7hfeb:libe-book-0.1.2nb13.tgz(NetBSD 8.0)
i386:libe-book-0.1.3nb6.tgz(NetBSD 7.0)
i386:libe-book-0.1.3nb2.tgz(NetBSD 7.0)
i386:libe-book-0.1.3nb4.tgz(NetBSD 7.0)
i386:libe-book-0.1.3nb6.tgz(NetBSD 7.0)
i386:libe-book-0.1.3nb2.tgz(NetBSD 7.1)
i386:libe-book-0.1.3nb4.tgz(NetBSD 7.1)
i386:libe-book-0.1.3nb6.tgz(NetBSD 7.1)
i386:libe-book-0.1.3nb6.tgz(NetBSD 7.1)
i386:libe-book-0.1.3nb6.tgz(NetBSD 8.0)
i386:libe-book-0.1.3nb2.tgz(NetBSD 8.0)
i386:libe-book-0.1.3nb4.tgz(NetBSD 8.0)
i386:libe-book-0.1.3nb6.tgz(NetBSD 8.0)
mips64eb:libe-book-0.1.3nb6.tgz(NetBSD 8.0)
mips64eb:libe-book-0.1.3nb6.tgz(NetBSD 8.0)
powerpc:libe-book-0.1.3nb6.tgz(NetBSD 8.0)
sparc64:libe-book-0.1.2nb7.tgz(NetBSD 7.1_RC1)
sparc64:libe-book-0.1.3nb6.tgz(NetBSD 8.0)
x86_64:libe-book-0.1.3nb6.tgz(NetBSD 7.0)
x86_64:libe-book-0.1.3nb2.tgz(NetBSD 7.0)
x86_64:libe-book-0.1.3nb4.tgz(NetBSD 7.0)
x86_64:libe-book-0.1.3nb6.tgz(NetBSD 7.0)
x86_64:libe-book-0.1.3nb6.tgz(NetBSD 7.1)
x86_64:libe-book-0.1.3nb2.tgz(NetBSD 7.1)
x86_64:libe-book-0.1.3nb4.tgz(NetBSD 7.1)
x86_64:libe-book-0.1.3nb6.tgz(NetBSD 7.1)
x86_64:libe-book-0.1.3nb6.tgz(NetBSD 8.0)
x86_64:libe-book-0.1.3nb2.tgz(NetBSD 8.0)
x86_64:libe-book-0.1.3nb4.tgz(NetBSD 8.0)
x86_64:libe-book-0.1.3nb6.tgz(NetBSD 8.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]