Daemon Power

The NetBSD Packages Collection: converters/pdf2svg

Brief description of the package:
Small utility to convert PDF files to SVG files

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://www.cityinthesky.co.uk/opensource/pdf2svg/.

Please note that this package has a gnu-gpl-v2 license.

The package is located in the "converters/pdf2svg" directory. The current source version of the package is "pdf2svg-0.2.3nb21". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for converters/pdf2svg :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: poppler-glib>=0.5.1 openjpeg>=2.1.0 lcms2>=2.2 jpeg>=8nb1 cwrappers>=20150314 tiff>=3.6.1 jbigkit>=2.0 jpeg>=9 tiff>=4.0.3nb5 png>=1.2.4 png>=1.6.0nb1 poppler-0.79.0{,nb*} fontconfig>=2.11.91 libuuid>=2.18 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 fontconfig>=2.13.0 poppler>=0.5.1 python37>=3.7 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 python37>=3.7.0 glib2>=2.4.0 pcre>=3.4nb1 pcre>=8.30nb1 meson-[0-9]* ninja-build-[0-9]* re2c>=0.11.3 py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7.5 gobject-introspection>=0.6.14nb1 py37-cElementTree-[0-9]* glib2>=2.58.0 libffi>=3.0.0 glib2>=2.34.0 cairo>=1.0.0nb2 Xrender>=0.2 x11-links>=1.30 osabi-NetBSD-8.0_STABLE xorgproto>=2016.1 Xrender>=0.8.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.13 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 xcb-proto>=1.4 lzo>=2.01 pixman>=0.30.0 pixman>=0.25.2 Xrender>=0.9.0nb1 poppler>=0.79.0 glib2>=2.41.0 gobject-introspection>=1.34.0 cairo>=1.16.0 poppler-glib>=0.79.0 .

This package requires the following package(s) to run: poppler-glib>=0.5.1 openjpeg>=2.1.0 lcms2>=2.2 jpeg>=8nb1 tiff>=3.6.1 jbigkit>=2.0 jpeg>=9 tiff>=4.0.3nb5 png>=1.2.4 png>=1.6.0nb1 poppler-0.79.0{,nb*} fontconfig>=2.11.91 libuuid>=2.18 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 fontconfig>=2.13.0 poppler>=0.5.1 python37>=3.7 libffi>=1.20 libffi>=3.0.11 python37>=3.7.0 glib2>=2.4.0 pcre>=3.4nb1 pcre>=8.30nb1 gobject-introspection>=0.6.14nb1 py37-cElementTree-[0-9]* python37>=3.7.5 py37-expat-[0-9]* glib2>=2.58.0 libffi>=3.0.0 glib2>=2.34.0 cairo>=1.0.0nb2 Xrender>=0.2 Xrender>=0.8.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 lzo>=2.01 pixman>=0.30.0 pixman>=0.25.2 Xrender>=0.9.0nb1 poppler>=0.79.0 glib2>=2.41.0 gobject-introspection>=1.34.0 cairo>=1.16.0 poppler-glib>=0.79.0 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:pdf2svg-0.2.3nb19.tgz(NetBSD 8.0)
alpha:pdf2svg-0.2.3nb16.tgz(NetBSD 8.0)
alpha:pdf2svg-0.2.3nb20.tgz(NetBSD 8.0)
earm:pdf2svg-0.2.3nb20.tgz(NetBSD 8.0)
earmv6hf:pdf2svg-0.2.3nb20.tgz(NetBSD 8.0)
earmv6hf:pdf2svg-0.2.3nb19.tgz(NetBSD 8.0)
earmv7hf:pdf2svg-0.2.3nb19.tgz(NetBSD 8.0)
earmv7hf:pdf2svg-0.2.3nb20.tgz(NetBSD 8.0)
i386:pdf2svg-0.2.3nb20.tgz(NetBSD 7.0)
i386:pdf2svg-0.2.3nb11.tgz(NetBSD 7.0)
i386:pdf2svg-0.2.3nb13.tgz(NetBSD 7.0)
i386:pdf2svg-0.2.3nb16.tgz(NetBSD 7.0)
i386:pdf2svg-0.2.3nb19.tgz(NetBSD 7.0)
i386:pdf2svg-0.2.3nb20.tgz(NetBSD 7.1)
i386:pdf2svg-0.2.3nb11.tgz(NetBSD 7.1)
i386:pdf2svg-0.2.3nb13.tgz(NetBSD 7.1)
i386:pdf2svg-0.2.3nb16.tgz(NetBSD 7.1)
i386:pdf2svg-0.2.3nb19.tgz(NetBSD 7.1)
i386:pdf2svg-0.2.3nb20.tgz(NetBSD 8.0)
i386:pdf2svg-0.2.3nb11.tgz(NetBSD 8.0)
i386:pdf2svg-0.2.3nb13.tgz(NetBSD 8.0)
i386:pdf2svg-0.2.3nb16.tgz(NetBSD 8.0)
i386:pdf2svg-0.2.3nb19.tgz(NetBSD 8.0)
powerpc:pdf2svg-0.2.3nb16.tgz(NetBSD 8.0)
powerpc:pdf2svg-0.2.3nb20.tgz(NetBSD 9.0)
sparc64:pdf2svg-0.2.3nb20.tgz(NetBSD 8.0)
sparc64:pdf2svg-0.2.3nb19.tgz(NetBSD 8.0)
x86_64:pdf2svg-0.2.3nb20.tgz(NetBSD 7.0)
x86_64:pdf2svg-0.2.3nb11.tgz(NetBSD 7.0)
x86_64:pdf2svg-0.2.3nb13.tgz(NetBSD 7.0)
x86_64:pdf2svg-0.2.3nb16.tgz(NetBSD 7.0)
x86_64:pdf2svg-0.2.3nb19.tgz(NetBSD 7.0)
x86_64:pdf2svg-0.2.3nb20.tgz(NetBSD 7.1)
x86_64:pdf2svg-0.2.3nb11.tgz(NetBSD 7.1)
x86_64:pdf2svg-0.2.3nb13.tgz(NetBSD 7.1)
x86_64:pdf2svg-0.2.3nb16.tgz(NetBSD 7.1)
x86_64:pdf2svg-0.2.3nb19.tgz(NetBSD 7.1)
x86_64:pdf2svg-0.2.3nb20.tgz(NetBSD 8.0)
x86_64:pdf2svg-0.2.3nb11.tgz(NetBSD 8.0)
x86_64:pdf2svg-0.2.3nb13.tgz(NetBSD 8.0)
x86_64:pdf2svg-0.2.3nb16.tgz(NetBSD 8.0)
x86_64:pdf2svg-0.2.3nb19.tgz(NetBSD 8.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]