Daemon Power

The NetBSD Packages Collection: databases/php-pdo_mysql

Brief description of the package:
PHP extension for PHP Data Objects (MySQL)

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://www.php.net/.

The package is located in the "databases/php-pdo_mysql" directory. The current source version of the package is "php73-pdo_mysql-7.3.25". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for databases/php-pdo_mysql :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: php>=7.3.0<7.3.99 pcre2>=10.21 cwrappers>=20150314 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 readline>=2.2 pcre2>=10.30 libxml2>=2.9.10nb3 readline>=6.0 mysql-client>=5.7.12<5.8 perl>=5.0 lz4>=1.7.3<100 boost-libs-1.73.* icu>=3.4 icu>=68.1 boost-jam-1.73.* editline>=3.0.20130712nb1 libevent>=0.6 lz4>=1.7.3 libevent>=2.1.11nb1 boost-headers-1.73.* php73-pdo-7.* php>=7.3.24nb1 mysql-client>=5.7.28nb2 php73-pdo>=5.2.9 .

This package requires the following package(s) to run: php>=7.3.0<7.3.99 pcre2>=10.21 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 readline>=2.2 pcre2>=10.30 libxml2>=2.9.10nb3 readline>=6.0 mysql-client>=5.7.12<5.8 perl>=5.0 lz4>=1.7.3<100 boost-libs-1.73.* icu>=3.4 icu>=68.1 editline>=3.0.20130712nb1 libevent>=0.6 lz4>=1.7.3 libevent>=2.1.11nb1 php73-pdo-7.* php>=7.3.24nb1 mysql-client>=5.7.28nb2 php73-pdo>=5.2.9 .

This package supports the following build-time options:

mysqlnd
Support for MySQL Native Driver (mainly for php).

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
aarch64:php56-pdo_mysql-5.6.40.tgz(NetBSD 9.0)
aarch64:php72-pdo_mysql-7.2.34.tgz(NetBSD 9.0)
aarch64:php73-pdo_mysql-7.3.23.tgz(NetBSD 9.0)
aarch64:php74-pdo_mysql-7.4.11.tgz(NetBSD 9.0)
aarch64:php56-pdo_mysql-5.6.40.tgz(NetBSD 9.0)
aarch64:php72-pdo_mysql-7.2.31.tgz(NetBSD 9.0)
aarch64:php73-pdo_mysql-7.3.19.tgz(NetBSD 9.0)
aarch64:php74-pdo_mysql-7.4.7.tgz(NetBSD 9.0)
earmv6hf:php56-pdo_mysql-5.6.40.tgz(NetBSD 9.0)
earmv6hf:php72-pdo_mysql-7.2.33.tgz(NetBSD 9.0)
earmv6hf:php72-pdo_mysql-7.2.34.tgz(NetBSD 9.0)
earmv6hf:php73-pdo_mysql-7.3.22.tgz(NetBSD 9.0)
earmv6hf:php73-pdo_mysql-7.3.23.tgz(NetBSD 9.0)
earmv6hf:php74-pdo_mysql-7.4.10.tgz(NetBSD 9.0)
earmv6hf:php74-pdo_mysql-7.4.11.tgz(NetBSD 9.0)
earmv6hf:php56-pdo_mysql-5.6.40.tgz(NetBSD 9.0)
earmv6hf:php72-pdo_mysql-7.2.31.tgz(NetBSD 9.0)
earmv6hf:php73-pdo_mysql-7.3.19.tgz(NetBSD 9.0)
earmv6hf:php74-pdo_mysql-7.4.7.tgz(NetBSD 9.0)
earmv7hf:php56-pdo_mysql-5.6.40.tgz(NetBSD 8.0)
earmv7hf:php72-pdo_mysql-7.2.33.tgz(NetBSD 8.0)
earmv7hf:php73-pdo_mysql-7.3.21.tgz(NetBSD 8.0)
earmv7hf:php74-pdo_mysql-7.4.9.tgz(NetBSD 8.0)
earmv7hf:php56-pdo_mysql-5.6.40.tgz(NetBSD 8.0)
earmv7hf:php72-pdo_mysql-7.2.31.tgz(NetBSD 8.0)
earmv7hf:php73-pdo_mysql-7.3.18.tgz(NetBSD 8.0)
earmv7hf:php74-pdo_mysql-7.4.6.tgz(NetBSD 8.0)
earmv7hf:php56-pdo_mysql-5.6.40.tgz(NetBSD 8.0)
earmv7hf:php72-pdo_mysql-7.2.33.tgz(NetBSD 8.0)
earmv7hf:php73-pdo_mysql-7.3.22.tgz(NetBSD 8.0)
earmv7hf:php74-pdo_mysql-7.4.10.tgz(NetBSD 8.0)
earmv7hf:php56-pdo_mysql-5.6.40.tgz(NetBSD 9.0)
earmv7hf:php72-pdo_mysql-7.2.33.tgz(NetBSD 9.0)
earmv7hf:php73-pdo_mysql-7.3.21.tgz(NetBSD 9.0)
earmv7hf:php74-pdo_mysql-7.4.9.tgz(NetBSD 9.0)
earmv7hf:php56-pdo_mysql-5.6.40.tgz(NetBSD 9.0)
earmv7hf:php72-pdo_mysql-7.2.31.tgz(NetBSD 9.0)
earmv7hf:php73-pdo_mysql-7.3.18.tgz(NetBSD 9.0)
earmv7hf:php74-pdo_mysql-7.4.6.tgz(NetBSD 9.0)
earmv7hf:php56-pdo_mysql-5.6.40.tgz(NetBSD 9.0)
earmv7hf:php72-pdo_mysql-7.2.33.tgz(NetBSD 9.0)
earmv7hf:php73-pdo_mysql-7.3.22.tgz(NetBSD 9.0)
earmv7hf:php74-pdo_mysql-7.4.10.tgz(NetBSD 9.0)
i386:php56-pdo_mysql-5.6.40.tgz(NetBSD 8.0)
i386:php72-pdo_mysql-7.2.34.tgz(NetBSD 8.0)
i386:php73-pdo_mysql-7.3.23.tgz(NetBSD 8.0)
i386:php74-pdo_mysql-7.4.11.tgz(NetBSD 8.0)
i386:php56-pdo_mysql-5.6.40.tgz(NetBSD 8.0)
i386:php72-pdo_mysql-7.2.33.tgz(NetBSD 8.0)
i386:php73-pdo_mysql-7.3.21.tgz(NetBSD 8.0)
i386:php74-pdo_mysql-7.4.9.tgz(NetBSD 8.0)
i386:php56-pdo_mysql-5.6.40.tgz(NetBSD 9.0)
i386:php72-pdo_mysql-7.2.34.tgz(NetBSD 9.0)
i386:php73-pdo_mysql-7.3.23.tgz(NetBSD 9.0)
i386:php74-pdo_mysql-7.4.11.tgz(NetBSD 9.0)
i386:php56-pdo_mysql-5.6.40.tgz(NetBSD 9.0)
i386:php72-pdo_mysql-7.2.33.tgz(NetBSD 9.0)
i386:php73-pdo_mysql-7.3.21.tgz(NetBSD 9.0)
i386:php74-pdo_mysql-7.4.9.tgz(NetBSD 9.0)
mips64eb:php56-pdo_mysql-5.6.40.tgz(NetBSD 9.0)
mips64eb:php72-pdo_mysql-7.2.33.tgz(NetBSD 9.0)
mips64eb:php73-pdo_mysql-7.3.22.tgz(NetBSD 9.0)
mips64eb:php74-pdo_mysql-7.4.10.tgz(NetBSD 9.0)
sparc64:php56-pdo_mysql-5.6.40.tgz(NetBSD 9.0)
sparc64:php72-pdo_mysql-7.2.33.tgz(NetBSD 9.0)
sparc64:php72-pdo_mysql-7.2.34.tgz(NetBSD 9.0)
sparc64:php73-pdo_mysql-7.3.22.tgz(NetBSD 9.0)
sparc64:php73-pdo_mysql-7.3.23.tgz(NetBSD 9.0)
sparc64:php74-pdo_mysql-7.4.10.tgz(NetBSD 9.0)
sparc64:php74-pdo_mysql-7.4.11.tgz(NetBSD 9.0)
sparc64:php56-pdo_mysql-5.6.40.tgz(NetBSD 9.0)
sparc64:php72-pdo_mysql-7.2.31.tgz(NetBSD 9.0)
sparc64:php73-pdo_mysql-7.3.19.tgz(NetBSD 9.0)
sparc64:php74-pdo_mysql-7.4.7.tgz(NetBSD 9.0)
x86_64:php56-pdo_mysql-5.6.40.tgz(NetBSD 9.0)
x86_64:php72-pdo_mysql-7.2.34.tgz(NetBSD 9.0)
x86_64:php73-pdo_mysql-7.3.24.tgz(NetBSD 9.0)
x86_64:php74-pdo_mysql-7.4.12.tgz(NetBSD 9.0)
x86_64:php56-pdo_mysql-5.6.40.tgz(NetBSD 9.0)
x86_64:php72-pdo_mysql-7.2.33.tgz(NetBSD 9.0)
x86_64:php73-pdo_mysql-7.3.21.tgz(NetBSD 9.0)
x86_64:php74-pdo_mysql-7.4.9.tgz(NetBSD 9.0)
x86_64:php56-pdo_mysql-5.6.40.tgz(NetBSD 9.0)
x86_64:php72-pdo_mysql-7.2.33.tgz(NetBSD 9.0)
x86_64:php73-pdo_mysql-7.3.22.tgz(NetBSD 9.0)
x86_64:php74-pdo_mysql-7.4.10.tgz(NetBSD 9.0)
x86_64:php56-pdo_mysql-5.6.40.tgz(NetBSD 8.0)
x86_64:php72-pdo_mysql-7.2.34.tgz(NetBSD 8.0)
x86_64:php73-pdo_mysql-7.3.23.tgz(NetBSD 8.0)
x86_64:php74-pdo_mysql-7.4.11.tgz(NetBSD 8.0)
x86_64:php56-pdo_mysql-5.6.40.tgz(NetBSD 8.0)
x86_64:php72-pdo_mysql-7.2.33.tgz(NetBSD 8.0)
x86_64:php73-pdo_mysql-7.3.21.tgz(NetBSD 8.0)
x86_64:php74-pdo_mysql-7.4.9.tgz(NetBSD 8.0)
x86_64:php56-pdo_mysql-5.6.40.tgz(NetBSD 9.0)
x86_64:php72-pdo_mysql-7.2.34.tgz(NetBSD 9.0)
x86_64:php73-pdo_mysql-7.3.23.tgz(NetBSD 9.0)
x86_64:php74-pdo_mysql-7.4.11.tgz(NetBSD 9.0)
x86_64:php56-pdo_mysql-5.6.40.tgz(NetBSD 9.0)
x86_64:php72-pdo_mysql-7.2.33.tgz(NetBSD 9.0)
x86_64:php73-pdo_mysql-7.3.21.tgz(NetBSD 9.0)
x86_64:php74-pdo_mysql-7.4.9.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]