Daemon Power

The NetBSD Packages Collection: databases/ruby-arel-helpers

Brief description of the package:
Tools to help construct database queries

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://github.com/camertron/arel-helpers.

Please note that this package has a mit license.

The package is located in the "databases/ruby-arel-helpers" directory. The current source version of the package is "ruby26-arel-helpers-2.11.0nb1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for databases/ruby-arel-helpers :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ruby26-activerecord52>=5.2.4.4<5.3 ruby26-activesupport52>=5.2.4.4<5.2.5 ruby26-i18n>=0.7<2 ruby26-concurrent-ruby>=1.0<2 ruby26-base>=2.6.6 libyaml>=0.1.1 cwrappers>=20150314 libyaml>=0.1.4 ruby26-concurrent-ruby>=1.0.2 ruby26-tzinfo1>=1.1<2 ruby26-thread_safe>=0.1<1 ruby26-activemodel52>=5.2.4.4<5.2.5 ruby26-arel>=9.0 .

This package requires the following package(s) to run: ruby26-activerecord52>=5.2.4.4<5.3 ruby26-activesupport52>=5.2.4.4<5.2.5 ruby26-i18n>=0.7<2 ruby26-concurrent-ruby>=1.0<2 ruby26-base>=2.6.6 libyaml>=0.1.1 libyaml>=0.1.4 ruby26-concurrent-ruby>=1.0.2 ruby26-tzinfo1>=1.1<2 ruby26-thread_safe>=0.1<1 ruby26-activemodel52>=5.2.4.4<5.2.5 ruby26-arel>=9.0 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
aarch64:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
aarch64:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
aarch64:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
aarch64:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
aarch64:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
aarch64:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
alpha:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
alpha:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
earmv6hf:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
earmv6hf:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
earmv6hf:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
earmv6hf:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
earmv6hf:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
earmv6hf:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
earmv7hf:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
earmv7hf:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
earmv7hf:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
earmv7hf:ruby24-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
earmv7hf:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
earmv7hf:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
earmv7hf:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
earmv7hf:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
earmv7hf:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
earmv7hf:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
earmv7hf:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
earmv7hf:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
earmv7hf:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
earmv7hf:ruby24-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
earmv7hf:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
earmv7hf:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
earmv7hf:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
earmv7hf:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
earmv7hf:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
earmv7hf:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
i386:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
i386:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
i386:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
i386:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
i386:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
i386:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
i386:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
i386:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
i386:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
i386:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
i386:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
i386:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
powerpc:ruby24-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
powerpc:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
powerpc:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
powerpc:ruby24-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
powerpc:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
powerpc:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
powerpc:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
powerpc:ruby24-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
powerpc:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
powerpc:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
powerpc:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
sparc64:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
sparc64:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
sparc64:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
x86_64:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
x86_64:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
x86_64:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
x86_64:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
x86_64:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
x86_64:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
x86_64:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
x86_64:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
x86_64:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
x86_64:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
x86_64:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
x86_64:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 8.0)
x86_64:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
x86_64:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
x86_64:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
x86_64:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
x86_64:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
x86_64:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
x86_64:ruby25-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
x86_64:ruby26-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)
x86_64:ruby27-arel-helpers-2.11.0nb1.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]