Daemon Power

The NetBSD Packages Collection: databases/ruby-mysql2

Brief description of the package:
Simple, fast Mysql library for Ruby, binding to libmysql

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://github.com/brianmario/mysql2/.

Please note that this package has a mit license.

The package is located in the "databases/ruby-mysql2" directory. The current source version of the package is "ruby23-mysql2-0.4.9". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for databases/ruby-mysql2 :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ruby23-base>=2.3.5 libyaml>=0.1.1 cwrappers>=20150314 libyaml>=0.1.4 mysql-client>=5.5.10<5.6 perl>=5.0 mysql-client>=5.5.48nb1 .

This package requires the following package(s) to run: ruby23-base>=2.3.5 libyaml>=0.1.1 libyaml>=0.1.4 mysql-client>=5.5.10<5.6 perl>=5.0 mysql-client>=5.5.48nb1 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:ruby21-mysql2-0.4.3.tgz(NetBSD 7.0)
alpha:ruby22-mysql2-0.4.3.tgz(NetBSD 7.0)
alpha:ruby23-mysql2-0.4.3.tgz(NetBSD 7.0)
alpha:ruby193-mysql2-0.3.18.tgz(NetBSD 7.0)
alpha:ruby200-mysql2-0.3.18.tgz(NetBSD 7.0)
alpha:ruby21-mysql2-0.3.18.tgz(NetBSD 7.0)
alpha:ruby22-mysql2-0.3.18.tgz(NetBSD 7.0)
alpha:ruby200-mysql2-0.4.2.tgz(NetBSD 7.0)
alpha:ruby21-mysql2-0.4.2.tgz(NetBSD 7.0)
alpha:ruby22-mysql2-0.4.2.tgz(NetBSD 7.0)
alpha:ruby22-mysql2-0.4.6.tgz(NetBSD 8.0)
alpha:ruby23-mysql2-0.4.6.tgz(NetBSD 8.0)
alpha:ruby24-mysql2-0.4.6.tgz(NetBSD 8.0)
earm:ruby200-mysql2-0.4.2.tgz(NetBSD 7.0)
earm:ruby22-mysql2-0.4.2.tgz(NetBSD 7.0)
earm:ruby193-mysql2-0.3.18.tgz(NetBSD 7.0)
earm:ruby200-mysql2-0.3.18.tgz(NetBSD 7.0)
earm:ruby21-mysql2-0.3.18.tgz(NetBSD 7.0)
earmv6hf:ruby200-mysql2-0.4.2.tgz(NetBSD 7.0)
earmv6hf:ruby21-mysql2-0.4.2.tgz(NetBSD 7.0)
earmv6hf:ruby22-mysql2-0.4.2.tgz(NetBSD 7.0)
earmv7hf:ruby200-mysql2-0.4.2.tgz(NetBSD 7.0)
earmv7hf:ruby21-mysql2-0.4.2.tgz(NetBSD 7.0)
earmv7hf:ruby22-mysql2-0.4.2.tgz(NetBSD 7.0)
earmv7hf:ruby193-mysql2-0.4.1.tgz(NetBSD 7.99.21)
earmv7hf:ruby200-mysql2-0.4.1.tgz(NetBSD 7.99.21)
earmv7hf:ruby21-mysql2-0.4.1.tgz(NetBSD 7.99.21)
earmv7hf:ruby22-mysql2-0.4.1.tgz(NetBSD 7.99.21)
earmv7hf:ruby22-mysql2-0.4.6.tgz(NetBSD 8.0_BETA)
earmv7hf:ruby23-mysql2-0.4.6.tgz(NetBSD 8.0_BETA)
earmv7hfeb:ruby200-mysql2-0.4.2.tgz(NetBSD 7.0)
earmv7hfeb:ruby21-mysql2-0.4.2.tgz(NetBSD 7.0)
earmv7hfeb:ruby22-mysql2-0.4.2.tgz(NetBSD 7.0)
earmv7hfeb:ruby23-mysql2-0.4.2.tgz(NetBSD 7.0)
i386:ruby22-mysql2-0.4.9.tgz(NetBSD 6.0)
i386:ruby23-mysql2-0.4.9.tgz(NetBSD 6.0)
i386:ruby24-mysql2-0.4.9.tgz(NetBSD 6.0)
i386:ruby21-mysql2-0.4.4.tgz(NetBSD 6.0)
i386:ruby22-mysql2-0.4.4.tgz(NetBSD 6.0)
i386:ruby23-mysql2-0.4.4.tgz(NetBSD 6.0)
i386:ruby21-mysql2-0.4.5.tgz(NetBSD 6.0)
i386:ruby22-mysql2-0.4.5.tgz(NetBSD 6.0)
i386:ruby23-mysql2-0.4.5.tgz(NetBSD 6.0)
i386:ruby22-mysql2-0.4.6.tgz(NetBSD 6.0)
i386:ruby23-mysql2-0.4.6.tgz(NetBSD 6.0)
i386:ruby24-mysql2-0.4.6.tgz(NetBSD 6.0)
i386:ruby21-mysql2-0.4.4.tgz(NetBSD 7.0)
i386:ruby22-mysql2-0.4.4.tgz(NetBSD 7.0)
i386:ruby23-mysql2-0.4.4.tgz(NetBSD 7.0)
i386:ruby21-mysql2-0.4.5.tgz(NetBSD 7.0)
i386:ruby22-mysql2-0.4.5.tgz(NetBSD 7.0)
i386:ruby23-mysql2-0.4.5.tgz(NetBSD 7.0)
i386:ruby21-mysql2-0.4.5.tgz(NetBSD 7.0)
i386:ruby22-mysql2-0.4.5.tgz(NetBSD 7.0)
i386:ruby23-mysql2-0.4.5.tgz(NetBSD 7.0)
i386:ruby22-mysql2-0.4.6.tgz(NetBSD 7.0)
i386:ruby23-mysql2-0.4.6.tgz(NetBSD 7.0)
i386:ruby24-mysql2-0.4.6.tgz(NetBSD 7.0)
powerpc:ruby24-mysql2-0.4.6.tgz(NetBSD 6.1)
powerpc:ruby200-mysql2-0.4.2.tgz(NetBSD 7.0)
powerpc:ruby21-mysql2-0.4.2.tgz(NetBSD 7.0)
powerpc:ruby22-mysql2-0.4.2.tgz(NetBSD 7.0)
powerpc:ruby22-mysql2-0.4.6.tgz(NetBSD 7.1)
powerpc:ruby23-mysql2-0.4.6.tgz(NetBSD 7.1)
powerpc:ruby24-mysql2-0.4.6.tgz(NetBSD 7.1)
powerpc:ruby22-mysql2-0.4.9.tgz(NetBSD 7.1)
powerpc:ruby23-mysql2-0.4.9.tgz(NetBSD 7.1)
powerpc:ruby24-mysql2-0.4.9.tgz(NetBSD 7.1)
powerpc:ruby22-mysql2-0.4.6.tgz(NetBSD 8.0)
powerpc:ruby23-mysql2-0.4.6.tgz(NetBSD 8.0)
powerpc:ruby24-mysql2-0.4.6.tgz(NetBSD 8.0)
sparc64:ruby193-mysql2-0.3.18.tgz(NetBSD 7.0)
sparc64:ruby200-mysql2-0.3.18.tgz(NetBSD 7.0)
sparc64:ruby200-mysql2-0.4.2.tgz(NetBSD 7.0)
sparc64:ruby21-mysql2-0.3.18.tgz(NetBSD 7.0)
sparc64:ruby21-mysql2-0.4.2.tgz(NetBSD 7.0)
sparc64:ruby22-mysql2-0.3.18.tgz(NetBSD 7.0)
sparc64:ruby22-mysql2-0.4.2.tgz(NetBSD 7.0)
x86_64:ruby22-mysql2-0.4.9.tgz(NetBSD 6.0)
x86_64:ruby23-mysql2-0.4.9.tgz(NetBSD 6.0)
x86_64:ruby24-mysql2-0.4.9.tgz(NetBSD 6.0)
x86_64:ruby21-mysql2-0.4.4.tgz(NetBSD 6.0)
x86_64:ruby22-mysql2-0.4.4.tgz(NetBSD 6.0)
x86_64:ruby23-mysql2-0.4.4.tgz(NetBSD 6.0)
x86_64:ruby21-mysql2-0.4.5.tgz(NetBSD 6.0)
x86_64:ruby22-mysql2-0.4.5.tgz(NetBSD 6.0)
x86_64:ruby23-mysql2-0.4.5.tgz(NetBSD 6.0)
x86_64:ruby22-mysql2-0.4.6.tgz(NetBSD 6.0)
x86_64:ruby23-mysql2-0.4.6.tgz(NetBSD 6.0)
x86_64:ruby24-mysql2-0.4.6.tgz(NetBSD 6.0)
x86_64:ruby22-mysql2-0.4.9.tgz(NetBSD 6.1)
x86_64:ruby23-mysql2-0.4.9.tgz(NetBSD 6.1)
x86_64:ruby24-mysql2-0.4.9.tgz(NetBSD 6.1)
x86_64:ruby21-mysql2-0.4.4.tgz(NetBSD 6.1)
x86_64:ruby22-mysql2-0.4.4.tgz(NetBSD 6.1)
x86_64:ruby23-mysql2-0.4.4.tgz(NetBSD 6.1)
x86_64:ruby21-mysql2-0.4.5.tgz(NetBSD 6.1)
x86_64:ruby22-mysql2-0.4.5.tgz(NetBSD 6.1)
x86_64:ruby23-mysql2-0.4.5.tgz(NetBSD 6.1)
x86_64:ruby21-mysql2-0.4.5.tgz(NetBSD 6.1)
x86_64:ruby22-mysql2-0.4.5.tgz(NetBSD 6.1)
x86_64:ruby23-mysql2-0.4.5.tgz(NetBSD 6.1)
x86_64:ruby22-mysql2-0.4.6.tgz(NetBSD 6.1)
x86_64:ruby23-mysql2-0.4.6.tgz(NetBSD 6.1)
x86_64:ruby24-mysql2-0.4.6.tgz(NetBSD 6.1)
x86_64:ruby22-mysql2-0.4.9.tgz(NetBSD 7.0)
x86_64:ruby23-mysql2-0.4.9.tgz(NetBSD 7.0)
x86_64:ruby24-mysql2-0.4.9.tgz(NetBSD 7.0)
x86_64:ruby21-mysql2-0.4.4.tgz(NetBSD 7.0)
x86_64:ruby22-mysql2-0.4.4.tgz(NetBSD 7.0)
x86_64:ruby23-mysql2-0.4.4.tgz(NetBSD 7.0)
x86_64:ruby21-mysql2-0.4.5.tgz(NetBSD 7.0)
x86_64:ruby22-mysql2-0.4.5.tgz(NetBSD 7.0)
x86_64:ruby23-mysql2-0.4.5.tgz(NetBSD 7.0)
x86_64:ruby21-mysql2-0.4.5.tgz(NetBSD 7.0)
x86_64:ruby22-mysql2-0.4.5.tgz(NetBSD 7.0)
x86_64:ruby23-mysql2-0.4.5.tgz(NetBSD 7.0)
x86_64:ruby22-mysql2-0.4.6.tgz(NetBSD 7.0)
x86_64:ruby23-mysql2-0.4.6.tgz(NetBSD 7.0)
x86_64:ruby24-mysql2-0.4.6.tgz(NetBSD 7.0)
x86_64:ruby22-mysql2-0.4.6.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby23-mysql2-0.4.6.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby24-mysql2-0.4.6.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby22-mysql2-0.4.6.tgz(NetBSD 8.99.1)
x86_64:ruby23-mysql2-0.4.6.tgz(NetBSD 8.99.1)
x86_64:ruby24-mysql2-0.4.6.tgz(NetBSD 8.99.1)
x86_64:ruby22-mysql2-0.4.9.tgz(NetBSD 8.99.1)
x86_64:ruby23-mysql2-0.4.9.tgz(NetBSD 8.99.1)
x86_64:ruby24-mysql2-0.4.9.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]