Daemon Power

The NetBSD Packages Collection: devel/at-spi2-core

Brief description of the package:
Assistive Technology Service Provider Interface Core

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://www.linuxfoundation.org/collaborate/workgroups/accessibility/atk/at-spi/at-spi_on_d-bus.

Please note that this package has a gnu-lgpl-v2 license.

The package is located in the "devel/at-spi2-core" directory. The current source version of the package is "at-spi2-core-2.22.0". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for devel/at-spi2-core :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: glib2>=2.4.0 perl>=5.0 cwrappers>=20150314 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 gobject-introspection>=0.6.14nb1 py27-cElementTree-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 py27-expat-[0-9]* glib2>=2.50.0 libffi>=3.0.0 glib2>=2.34.0 dbus>=0.91 xmlto-[0-9]* getopt-[0-9]* docbook-xsl>=1.67.0nb1 docbook-xml>=4.2 xmlcatmgr>=2.0beta1 libxml2>=2.6.2 bash-[0-9]* libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 libxml2>=2.8.0nb2 docbook-xml-[0-9]* docbook-xsl-[0-9]* libxslt>=1.1.28nb2 x11-links>=1.04 osabi-NetBSD-7.0.1 libXtst>=1.0.1 inputproto>=1.4 recordproto>=1.13.99.1 recordproto>=1.13.1 xextproto>=7.0.99.3 xextproto>=7.0 gobject-introspection>=1.34.0 .

This package requires the following package(s) to run: glib2>=2.4.0 perl>=5.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 gobject-introspection>=0.6.14nb1 py27-cElementTree-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 python27>=2.7.1nb2 py27-expat-[0-9]* glib2>=2.50.0 libffi>=3.0.0 glib2>=2.34.0 dbus>=0.91 libXtst>=1.0.1 gobject-introspection>=1.34.0 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
arm:at-spi2-core-2.10.2.tgz(NetBSD 6.1_STABLE)
earm:at-spi2-core-2.16.0.tgz(NetBSD 7.0)
earm:at-spi2-core-2.14.1.tgz(NetBSD 7.0)
earm:at-spi2-core-2.16.0.tgz(NetBSD 7.0)
earm:at-spi2-core-2.16.0.tgz(NetBSD 7.0)
earm:at-spi2-core-2.16.0.tgz(NetBSD 7.0)
earmv6hf:at-spi2-core-2.14.1.tgz(NetBSD 7.0)
earmv6hf:at-spi2-core-2.16.0.tgz(NetBSD 7.0)
earmv6hf:at-spi2-core-2.16.0.tgz(NetBSD 7.0)
earmv7hf:at-spi2-core-2.16.0.tgz(NetBSD 7.0)
earmv7hf:at-spi2-core-2.16.0.tgz(NetBSD 7.0)
earmv7hf:at-spi2-core-2.16.0.tgz(NetBSD 7.99.21)
earmv7hfeb:at-spi2-core-2.16.0.tgz(NetBSD 7.0)
i386:at-spi2-core-2.10.2.tgz(MirBSD 10)
i386:at-spi2-core-2.22.0.tgz(NetBSD 6.0)
i386:at-spi2-core-2.16.0.tgz(NetBSD 6.0)
i386:at-spi2-core-2.20.2.tgz(NetBSD 6.0)
i386:at-spi2-core-2.20.2.tgz(NetBSD 6.0)
i386:at-spi2-core-2.22.0.tgz(NetBSD 6.0)
i386:at-spi2-core-2.22.0.tgz(NetBSD 6.1)
i386:at-spi2-core-2.20.2.tgz(NetBSD 6.1)
i386:at-spi2-core-2.20.2.tgz(NetBSD 6.1)
i386:at-spi2-core-2.22.0.tgz(NetBSD 6.1)
i386:at-spi2-core-2.22.0.tgz(NetBSD 7.0)
i386:at-spi2-core-2.16.0.tgz(NetBSD 7.0.0_PATCH)
i386:at-spi2-core-2.20.2.tgz(NetBSD 7.0)
i386:at-spi2-core-2.20.2.tgz(NetBSD 7.0)
i386:at-spi2-core-2.22.0.tgz(NetBSD 7.0)
m68k:at-spi2-core-2.16.0.tgz(NetBSD 7.0)
powerpc:at-spi2-core-2.20.2.tgz(NetBSD 6.0)
powerpc:at-spi2-core-2.16.0.tgz(NetBSD 6.0)
powerpc:at-spi2-core-2.20.2.tgz(NetBSD 6.0)
powerpc:at-spi2-core-2.22.0.tgz(NetBSD 6.1)
powerpc:at-spi2-core-2.16.0.tgz(NetBSD 7.0)
powerpc:at-spi2-core-2.16.0.tgz(NetBSD 7.0)
sparc64:at-spi2-core-2.10.2.tgz(NetBSD 6.1_STABLE)
sparc64:at-spi2-core-2.14.1.tgz(NetBSD 7.0)
sparc64:at-spi2-core-2.14.1.tgz(NetBSD 7.0)
sparc64:at-spi2-core-2.16.0.tgz(NetBSD 7.0)
sparc64:at-spi2-core-2.14.1.tgz(NetBSD 7.0)
sparc64:at-spi2-core-2.16.0.tgz(NetBSD 7.0)
sparc64:at-spi2-core-2.22.0.tgz(NetBSD 7.1_RC1)
sparc64:at-spi2-core-2.14.1.tgz(NetBSD 7.0)
sparc64:at-spi2-core-2.16.0.tgz(NetBSD 7.0)
sparc:at-spi2-core-2.12.0.tgz(NetBSD 6.0)
sparc:at-spi2-core-2.16.0.tgz(NetBSD 7.0)
sparc:at-spi2-core-2.20.2.tgz(NetBSD 7.0)
x86_64:at-spi2-core-2.22.0.tgz(NetBSD 6.0)
x86_64:at-spi2-core-2.16.0.tgz(NetBSD 6.0)
x86_64:at-spi2-core-2.20.2.tgz(NetBSD 6.0)
x86_64:at-spi2-core-2.20.2.tgz(NetBSD 6.0)
x86_64:at-spi2-core-2.22.0.tgz(NetBSD 6.0)
x86_64:at-spi2-core-2.22.0.tgz(NetBSD 6.1)
x86_64:at-spi2-core-2.20.2.tgz(NetBSD 6.1)
x86_64:at-spi2-core-2.20.2.tgz(NetBSD 6.1)
x86_64:at-spi2-core-2.22.0.tgz(NetBSD 6.1)
x86_64:at-spi2-core-2.22.0.tgz(NetBSD 7.0)
x86_64:at-spi2-core-2.16.0.tgz(NetBSD 7.0.0_PATCH)
x86_64:at-spi2-core-2.20.2.tgz(NetBSD 7.0)
x86_64:at-spi2-core-2.20.2.tgz(NetBSD 7.0)
x86_64:at-spi2-core-2.22.0.tgz(NetBSD 7.0)
x86_64:at-spi2-core-2.22.0.tgz(NetBSD 7.0.1_PATCH)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]