Daemon Power

The NetBSD Packages Collection: devel/ctemplate

Brief description of the package:
Simple but powerful template language for C++

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://github.com/OlafvdSpek/ctemplate.

Please note that this package has a modified-bsd license.

The package is located in the "devel/ctemplate" directory. The current source version of the package is "ctemplate-2.3nb2". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for devel/ctemplate :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 cwrappers>=20150314 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 .

This package requires the following package(s) to run: python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 python27>=2.7.1nb2 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:ctemplate-2.3nb1.tgz(NetBSD 7.0)
alpha:ctemplate-2.3nb1.tgz(NetBSD 7.0)
alpha:ctemplate-2.3nb1.tgz(NetBSD 7.0)
arm:ctemplate-2.2nb1.tgz(NetBSD 6.1_STABLE)
earm:ctemplate-2.3nb1.tgz(NetBSD 7.0)
earm:ctemplate-2.2nb2.tgz(NetBSD 7.0)
earm:ctemplate-2.3nb1.tgz(NetBSD 7.0)
earmv6hf:ctemplate-2.2nb2.tgz(NetBSD 7.0)
earmv6hf:ctemplate-2.3nb1.tgz(NetBSD 7.0)
earmv6hf:ctemplate-2.3nb1.tgz(NetBSD 7.0)
earmv7hf:ctemplate-2.3nb1.tgz(NetBSD 7.0)
earmv7hf:ctemplate-2.3nb1.tgz(NetBSD 7.0)
earmv7hf:ctemplate-2.3nb1.tgz(NetBSD 7.99.21)
earmv7hf:ctemplate-2.3nb2.tgz(NetBSD 8.0_BETA)
earmv7hfeb:ctemplate-2.3nb1.tgz(NetBSD 7.0)
i386:ctemplate-2.2nb1.tgz(MirBSD 10)
i386:ctemplate-2.3nb2.tgz(NetBSD 6.0)
i386:ctemplate-2.3nb2.tgz(NetBSD 6.0)
i386:ctemplate-2.3nb2.tgz(NetBSD 6.0)
i386:ctemplate-2.3nb2.tgz(NetBSD 6.0)
i386:ctemplate-2.3nb2.tgz(NetBSD 6.1)
i386:ctemplate-2.3nb2.tgz(NetBSD 6.1)
i386:ctemplate-2.3nb2.tgz(NetBSD 6.1)
i386:ctemplate-2.3nb2.tgz(NetBSD 6.1)
i386:ctemplate-2.3nb2.tgz(NetBSD 7.0)
i386:ctemplate-2.3nb2.tgz(NetBSD 7.0)
i386:ctemplate-2.3nb2.tgz(NetBSD 7.0)
i386:ctemplate-2.3nb2.tgz(NetBSD 7.0)
m68k:ctemplate-2.2nb1.tgz(NetBSD 6.1_STABLE)
powerpc:ctemplate-2.3nb2.tgz(NetBSD 6.0)
powerpc:ctemplate-2.3nb2.tgz(NetBSD 6.1)
powerpc:ctemplate-2.3nb1.tgz(NetBSD 7.0)
powerpc:ctemplate-2.3nb2.tgz(NetBSD 7.1)
powerpc:ctemplate-2.3nb2.tgz(NetBSD 8.0)
sparc64:ctemplate-2.2nb2.tgz(NetBSD 7.0)
sparc64:ctemplate-2.3nb1.tgz(NetBSD 7.0)
sparc:ctemplate-2.2nb2.tgz(NetBSD 5.1)
sparc:ctemplate-2.2nb2.tgz(NetBSD 6.0)
x86_64:ctemplate-2.3nb2.tgz(NetBSD 6.0)
x86_64:ctemplate-2.3nb2.tgz(NetBSD 6.0)
x86_64:ctemplate-2.3nb2.tgz(NetBSD 6.0)
x86_64:ctemplate-2.3nb2.tgz(NetBSD 6.0)
x86_64:ctemplate-2.3nb2.tgz(NetBSD 6.1)
x86_64:ctemplate-2.3nb2.tgz(NetBSD 6.1)
x86_64:ctemplate-2.3nb2.tgz(NetBSD 6.1)
x86_64:ctemplate-2.3nb2.tgz(NetBSD 6.1)
x86_64:ctemplate-2.3nb2.tgz(NetBSD 7.0)
x86_64:ctemplate-2.3nb2.tgz(NetBSD 7.0)
x86_64:ctemplate-2.3nb2.tgz(NetBSD 7.0)
x86_64:ctemplate-2.3nb2.tgz(NetBSD 7.0)
x86_64:ctemplate-2.3nb2.tgz(NetBSD 7.0.1_PATCH)
x86_64:ctemplate-2.3nb2.tgz(NetBSD 8.99.1)
x86_64:ctemplate-2.3nb2.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]