Daemon Power

The NetBSD Packages Collection: devel/gdbus-codegen

Brief description of the package:
Generate code and/or documentation for one or more D-Bus interfaces

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://developer.gnome.org/glib/.

Please note that this package has a gnu-lgpl-v2 license.

The package is located in the "devel/gdbus-codegen" directory. The current source version of the package is "gdbus-codegen-2.52.3". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for devel/gdbus-codegen :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: py27-expat-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 cwrappers>=20150314 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 perl>=5.0 glib2>=2.4.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 pcre>=8.30nb1 glib2>=2.34.0 .

This package requires the following package(s) to run: py27-expat-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 python27>=2.7.1nb2 perl>=5.0 glib2>=2.4.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 pcre>=8.30nb1 glib2>=2.34.0 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.0)
alpha:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.0)
alpha:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.0)
arm:gdbus-codegen-2.38.2.tgz(NetBSD 6.1_STABLE)
earm:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.0)
earm:gdbus-codegen-2.42.2.tgz(NetBSD 7.0)
earm:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.0)
earm:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.0)
earm:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.0)
earmv4:gdbus-codegen-2.50.3.tgz(NetBSD 7.1)
earmv6hf:gdbus-codegen-2.42.2.tgz(NetBSD 7.0)
earmv6hf:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.0)
earmv6hf:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.0)
earmv7hf:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.0)
earmv7hf:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.0)
earmv7hf:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.99.21)
earmv7hfeb:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.0)
i386:gdbus-codegen-2.38.2.tgz(MirBSD 10)
i386:gdbus-codegen-2.44.1nb1.tgz(NetBSD 6.0)
i386:gdbus-codegen-2.48.1.tgz(NetBSD 6.0)
i386:gdbus-codegen-2.48.2.tgz(NetBSD 6.0)
i386:gdbus-codegen-2.50.2.tgz(NetBSD 6.0)
i386:gdbus-codegen-2.50.3.tgz(NetBSD 6.0)
i386:gdbus-codegen-2.48.1.tgz(NetBSD 6.1)
i386:gdbus-codegen-2.48.2.tgz(NetBSD 6.1)
i386:gdbus-codegen-2.50.2.tgz(NetBSD 6.1)
i386:gdbus-codegen-2.50.3.tgz(NetBSD 6.1)
i386:gdbus-codegen-2.50.3.tgz(NetBSD 7.0)
i386:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.0.0_PATCH)
i386:gdbus-codegen-2.48.1.tgz(NetBSD 7.0)
i386:gdbus-codegen-2.48.2.tgz(NetBSD 7.0)
i386:gdbus-codegen-2.50.2.tgz(NetBSD 7.0)
m68k:gdbus-codegen-2.42.2.tgz(NetBSD 7.0)
m68k:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.0)
powerpc:gdbus-codegen-2.48.2.tgz(NetBSD 6.0)
powerpc:gdbus-codegen-2.48.1.tgz(NetBSD 6.0)
powerpc:gdbus-codegen-2.50.3.tgz(NetBSD 6.1)
powerpc:gdbus-codegen-2.50.2.tgz(NetBSD 6.1)
powerpc:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.0)
powerpc:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.0)
powerpc:gdbus-codegen-2.50.3.tgz(NetBSD 7.1)
powerpc:gdbus-codegen-2.50.3.tgz(NetBSD 8.0)
sparc64:gdbus-codegen-2.38.2.tgz(NetBSD 6.1_STABLE)
sparc64:gdbus-codegen-2.42.2.tgz(NetBSD 7.0)
sparc64:gdbus-codegen-2.42.2.tgz(NetBSD 7.0)
sparc64:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.0)
sparc64:gdbus-codegen-2.42.2.tgz(NetBSD 7.0)
sparc64:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.0)
sparc64:gdbus-codegen-2.50.2.tgz(NetBSD 7.1_RC1)
sparc64:gdbus-codegen-2.42.2.tgz(NetBSD 7.0)
sparc64:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.0)
sparc:gdbus-codegen-2.40.0.tgz(NetBSD 6.0)
sparc:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.0)
sparc:gdbus-codegen-2.48.2.tgz(NetBSD 7.0)
x86_64:gdbus-codegen-2.44.1nb1.tgz(NetBSD 6.0)
x86_64:gdbus-codegen-2.48.1.tgz(NetBSD 6.0)
x86_64:gdbus-codegen-2.48.2.tgz(NetBSD 6.0)
x86_64:gdbus-codegen-2.50.2.tgz(NetBSD 6.0)
x86_64:gdbus-codegen-2.50.3.tgz(NetBSD 6.0)
x86_64:gdbus-codegen-2.48.1.tgz(NetBSD 6.1)
x86_64:gdbus-codegen-2.48.2.tgz(NetBSD 6.1)
x86_64:gdbus-codegen-2.50.2.tgz(NetBSD 6.1)
x86_64:gdbus-codegen-2.50.3.tgz(NetBSD 6.1)
x86_64:gdbus-codegen-2.50.3.tgz(NetBSD 7.0)
x86_64:gdbus-codegen-2.44.1nb1.tgz(NetBSD 7.0.0_PATCH)
x86_64:gdbus-codegen-2.48.1.tgz(NetBSD 7.0)
x86_64:gdbus-codegen-2.48.2.tgz(NetBSD 7.0)
x86_64:gdbus-codegen-2.50.2.tgz(NetBSD 7.0)
x86_64:gdbus-codegen-2.50.3.tgz(NetBSD 7.0.1_PATCH)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]