devel/glibmm - The NetBSD Packages Collection

C++ bindings for glib

glibmm is a C++ interface for the devel/glib2 library.

Build dependencies

devel/mm-common pkgtools/cwrappers devel/glib2-tools devel/meson devel/m4 devel/pkgconf

Runtime dependencies

lang/perl5 devel/glib2 devel/glib2 devel/libsigc++ devel/glib2 devel/libsigc++

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfglibmm-2.64.2nb1.tgz
NetBSD 8.0earmv7hfglibmm-2.64.2nb1.tgz
NetBSD 8.0earmv7hfglibmm-2.64.2nb1.tgz
NetBSD 8.0i386glibmm-2.64.2nb1.tgz
NetBSD 8.0i386glibmm-2.64.2nb1.tgz
NetBSD 8.0i386glibmm-2.64.2nb1.tgz
NetBSD 8.0powerpcglibmm-2.64.2nb1.tgz
NetBSD 8.0powerpcglibmm-2.64.2nb1.tgz
NetBSD 8.0powerpcglibmm-2.64.2nb1.tgz
NetBSD 8.0x86_64glibmm-2.64.2nb1.tgz
NetBSD 8.0x86_64glibmm-2.64.2nb1.tgz
NetBSD 8.0x86_64glibmm-2.64.2nb1.tgz
NetBSD 9.0aarch64glibmm-2.64.2nb1.tgz
NetBSD 9.0aarch64glibmm-2.64.2nb1.tgz
NetBSD 9.0aarch64glibmm-2.64.2nb1.tgz
NetBSD 9.0alphaglibmm-2.64.2nb1.tgz
NetBSD 9.0alphaglibmm-2.64.2nb1.tgz
NetBSD 9.0alphaglibmm-2.64.2nb1.tgz
NetBSD 9.0earmglibmm-2.64.2nb1.tgz
NetBSD 9.0earmglibmm-2.64.2nb1.tgz
NetBSD 9.0earmglibmm-2.64.2nb1.tgz
NetBSD 9.0earmv6hfglibmm-2.64.2nb1.tgz
NetBSD 9.0earmv6hfglibmm-2.64.2nb1.tgz
NetBSD 9.0earmv6hfglibmm-2.64.2nb1.tgz
NetBSD 9.0earmv6hfglibmm-2.64.2nb1.tgz
NetBSD 9.0earmv7hfglibmm-2.64.2nb1.tgz
NetBSD 9.0earmv7hfglibmm-2.64.2nb1.tgz
NetBSD 9.0earmv7hfglibmm-2.64.2nb1.tgz
NetBSD 9.0earmv7hfglibmm-2.64.2nb1.tgz
NetBSD 9.0i386glibmm-2.64.2nb1.tgz
NetBSD 9.0i386glibmm-2.64.2nb1.tgz
NetBSD 9.0i386glibmm-2.64.2nb1.tgz
NetBSD 9.0m68kglibmm-2.64.2nb1.tgz
NetBSD 9.0m68kglibmm-2.64.2nb1.tgz
NetBSD 9.0m68kglibmm-2.64.2nb1.tgz
NetBSD 9.0mips64ebglibmm-2.64.2nb1.tgz
NetBSD 9.0mips64ebglibmm-2.64.2nb1.tgz
NetBSD 9.0mips64ebglibmm-2.64.2nb1.tgz
NetBSD 9.0mipselglibmm-2.64.2nb1.tgz
NetBSD 9.0mipselglibmm-2.64.2nb1.tgz
NetBSD 9.0powerpcglibmm-2.64.2nb1.tgz
NetBSD 9.0powerpcglibmm-2.64.2nb1.tgz
NetBSD 9.0sh3elglibmm-2.64.2nb1.tgz
NetBSD 9.0sh3elglibmm-2.64.2nb1.tgz
NetBSD 9.0sh3elglibmm-2.64.2nb1.tgz
NetBSD 9.0sparc64glibmm-2.64.2nb1.tgz
NetBSD 9.0sparc64glibmm-2.64.2.tgz
NetBSD 9.0sparc64glibmm-2.64.2nb1.tgz
NetBSD 9.0sparc64glibmm-2.64.2nb1.tgz
NetBSD 9.0sparcglibmm-2.64.2nb1.tgz
NetBSD 9.0sparcglibmm-2.64.2nb1.tgz
NetBSD 9.0sparcglibmm-2.64.2nb1.tgz
NetBSD 9.0x86_64glibmm-2.64.2nb1.tgz
NetBSD 9.0x86_64glibmm-2.64.2nb1.tgz
NetBSD 9.0x86_64glibmm-2.64.2nb1.tgz
NetBSD 9.0x86_64glibmm-2.64.2nb1.tgz
NetBSD 9.0x86_64glibmm-2.64.2nb1.tgz
NetBSD 9.0x86_64glibmm-2.64.2nb1.tgz
NetBSD 9.0x86_64glibmm-2.64.2nb1.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.