Daemon Power

The NetBSD Packages Collection: devel/js_of_ocaml

Brief description of the package:
Compiler of OCaml bytecode to Javascript

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://ocsigen.org/js_of_ocaml/.

Please note that this package has a gnu-lgpl-v2 license.

The package is located in the "devel/js_of_ocaml" directory. The current source version of the package is "js_of_ocaml-2.8.3". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for devel/js_of_ocaml :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ocaml-deriving-ocsigen>=0.6 ocaml-oasis>=0.4.4 ocaml-odn>=0.0.11 ocaml-type_conv>=109.60.01 camlp4>=4.04 ocaml>=3.08.2 cwrappers>=20150314 ocaml>=4.04.0 ocamlbuild>=0.9.2 ocaml-findlib>=1.2 ocaml-findlib>=1.6 ocaml-type_conv>=113.00.02nb4 ocamlify>=0.0.2nb1 ocamlmod>=0.0.7nb1 ocaml-odn>=0.0.11nb7 ocaml-optcomp>=1.6nb1 ocaml-oasis>=0.4.6nb2 menhir-[0-9]* ocaml-tyxml>=4.0.1 ocaml-ppx_tools>=0.99.3 ocaml-re>=1.6.0 ocaml-markup>=0.7.2 ocaml-lwt>=2.4.2 ocaml-ppx_tools-[0-9]* ocaml-react-[0-9]* ocaml-ssl>=0.5.0 ocaml-ssl>=0.4.0 libev>=3.9nb1 ocaml-ssl>=0.5.3 libev>=4.01 ocaml-uutf>=0.9.3nb1 ocaml-reactiveData>=0.2.1 ocaml-react>=1.2.0nb1 ocaml-base64>=2.0.0 ocaml-cmdliner>=0.9.8 ocaml-cppo>=1.3.1 ocaml-optcomp>=1.6 ocaml-ppx_deriving>=4.0 ocaml-result>=1.2 ocaml-ppx_driver>=113.24.00 ocaml-ppx_optcomp>=113.24.00 ocaml-ppx_core>=113.24.00 ocaml-js-build-tools>=113.33.04 ocaml-opam>=1.2.2 ocaml-extlib>=1.7.0 ocamlgraph>=1.8.7 dose3>=5.0rc2 ocaml-cudf>=0.8 ocaml-jsonm>=0.9.1 curl>=7.12.3 libidn>=0.4.6 libidn>=1.20nb1 ocaml-cmdliner>=0.9.8nb2 curl>=7.52.1nb1 ocaml-uchar>=0.0.1 .

This package requires the following package(s) to run: ocaml-deriving-ocsigen>=0.6 ocaml-oasis>=0.4.4 ocaml-odn>=0.0.11 ocaml-type_conv>=109.60.01 camlp4>=4.04 ocaml>=3.08.2 ocaml>=4.04.0 ocaml-findlib>=1.2 ocaml-findlib>=1.6 ocaml-type_conv>=113.00.02nb4 ocamlify>=0.0.2nb1 ocamlmod>=0.0.7nb1 ocaml-odn>=0.0.11nb7 ocaml-optcomp>=1.6nb1 ocaml-oasis>=0.4.6nb2 menhir-[0-9]* ocaml-tyxml>=4.0.1 ocaml-ppx_tools>=0.99.3 ocaml-re>=1.6.0 ocaml-markup>=0.7.2 ocaml-lwt>=2.4.2 ocaml-ppx_tools-[0-9]* ocaml-react-[0-9]* ocaml-ssl>=0.5.0 ocaml-ssl>=0.4.0 libev>=3.9nb1 ocaml-ssl>=0.5.3 libev>=4.01 ocaml-uutf>=0.9.3nb1 ocaml-reactiveData>=0.2.1 ocaml-react>=1.2.0nb1 ocaml-base64>=2.0.0 ocaml-cmdliner>=0.9.8 ocaml-cppo>=1.3.1 ocaml-optcomp>=1.6 ocaml-ppx_deriving>=4.0 ocaml-result>=1.2 ocaml-ppx_driver>=113.24.00 ocaml-ppx_optcomp>=113.24.00 ocaml-ppx_core>=113.24.00 ocaml-js-build-tools>=113.33.04 ocaml-opam>=1.2.2 ocaml-extlib>=1.7.0 ocamlgraph>=1.8.7 dose3>=5.0rc2 ocaml-cudf>=0.8 ocaml-jsonm>=0.9.1 curl>=7.12.3 libidn>=0.4.6 libidn>=1.20nb1 ocaml-cmdliner>=0.9.8nb2 curl>=7.52.1nb1 ocaml-uchar>=0.0.1 .

This package supports the following build-time options:

ocaml-tyxml
Enable OCaml-tyxml support

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
i386:js_of_ocaml-2.8.1.tgz(NetBSD 6.0)
i386:js_of_ocaml-2.7nb1.tgz(NetBSD 6.0)
i386:js_of_ocaml-2.8.1.tgz(NetBSD 6.0)
i386:js_of_ocaml-2.8.1.tgz(NetBSD 6.1)
i386:js_of_ocaml-2.8.1.tgz(NetBSD 6.1)
i386:js_of_ocaml-2.8.1.tgz(NetBSD 7.0)
i386:js_of_ocaml-2.7nb1.tgz(NetBSD 7.0.0_PATCH)
i386:js_of_ocaml-2.8.1.tgz(NetBSD 7.0)
x86_64:js_of_ocaml-2.8.1.tgz(NetBSD 6.0)
x86_64:js_of_ocaml-2.7nb1.tgz(NetBSD 6.0)
x86_64:js_of_ocaml-2.8.1.tgz(NetBSD 6.0)
x86_64:js_of_ocaml-2.8.1.tgz(NetBSD 6.1)
x86_64:js_of_ocaml-2.8.1.tgz(NetBSD 6.1)
x86_64:js_of_ocaml-2.8.1.tgz(NetBSD 7.0)
x86_64:js_of_ocaml-2.7nb1.tgz(NetBSD 7.0.0_PATCH)
x86_64:js_of_ocaml-2.8.1.tgz(NetBSD 7.0)
x86_64:js_of_ocaml-2.8.3.tgz(NetBSD 7.0.1_PATCH)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]