devel/libsigsegv - The NetBSD Packages Collection

Library for handling page faults in user mode

GNU libsigsegv is a library for handling page faults in user mode. A page
fault occurs when a program tries to access a region of memory that is
currently unavailable. Catching and handling a page fault is a useful
technique for implementing:

* Pageable virtual memory
* Memory-mapped access to persistent databases
* Generational garbage collectors
* Stack overflow handlers
* Distributed shared memory

Build dependencies

pkgtools/cwrappers devel/libtool-base devel/pkgconf

Runtime dependencies

(none)

Available binary packages

aarch64:libsigsegv-2.12.tgz(NetBSD 9.0)
aarch64:libsigsegv-2.12.tgz(NetBSD 9.0)
aarch64:libsigsegv-2.12.tgz(NetBSD 9.0)
alpha:libsigsegv-2.12.tgz(NetBSD 9.0)
alpha:libsigsegv-2.12.tgz(NetBSD 9.0)
alpha:libsigsegv-2.12.tgz(NetBSD 9.0)
earm:libsigsegv-2.12.tgz(NetBSD 9.0)
earm:libsigsegv-2.12.tgz(NetBSD 9.0)
earm:libsigsegv-2.12.tgz(NetBSD 9.0)
earmv6hf:libsigsegv-2.12.tgz(NetBSD 9.0)
earmv6hf:libsigsegv-2.12.tgz(NetBSD 9.0)
earmv6hf:libsigsegv-2.12.tgz(NetBSD 9.0)
earmv6hf:libsigsegv-2.12.tgz(NetBSD 9.0)
earmv7hf:libsigsegv-2.12.tgz(NetBSD 8.0)
earmv7hf:libsigsegv-2.12.tgz(NetBSD 8.0)
earmv7hf:libsigsegv-2.12.tgz(NetBSD 8.0)
earmv7hf:libsigsegv-2.12.tgz(NetBSD 8.0)
earmv7hf:libsigsegv-2.12.tgz(NetBSD 9.0)
earmv7hf:libsigsegv-2.12.tgz(NetBSD 9.0)
earmv7hf:libsigsegv-2.12.tgz(NetBSD 9.0)
earmv7hf:libsigsegv-2.12.tgz(NetBSD 9.0)
earmv7hf:libsigsegv-2.12.tgz(NetBSD 9.0)
i386:libsigsegv-2.12.tgz(NetBSD 8.0)
i386:libsigsegv-2.12.tgz(NetBSD 8.0)
i386:libsigsegv-2.12.tgz(NetBSD 8.0)
i386:libsigsegv-2.12.tgz(NetBSD 9.0)
i386:libsigsegv-2.12.tgz(NetBSD 9.0)
i386:libsigsegv-2.12.tgz(NetBSD 9.0)
m68k:libsigsegv-2.12.tgz(NetBSD 9.0)
m68k:libsigsegv-2.12.tgz(NetBSD 9.0)
mips64eb:libsigsegv-2.12.tgz(NetBSD 9.0)
mips64eb:libsigsegv-2.12.tgz(NetBSD 9.0)
mipsel:libsigsegv-2.12.tgz(NetBSD 9.0)
powerpc:libsigsegv-2.12.tgz(NetBSD 8.0)
powerpc:libsigsegv-2.12.tgz(NetBSD 8.0)
powerpc:libsigsegv-2.12.tgz(NetBSD 8.0)
powerpc:libsigsegv-2.12.tgz(NetBSD 9.0)
powerpc:libsigsegv-2.12.tgz(NetBSD 9.0)
sh3el:libsigsegv-2.12.tgz(NetBSD 9.0)
sh3el:libsigsegv-2.12.tgz(NetBSD 9.0)
sparc64:libsigsegv-2.12.tgz(NetBSD 9.0)
sparc64:libsigsegv-2.12.tgz(NetBSD 9.0)
sparc64:libsigsegv-2.12.tgz(NetBSD 9.0)
sparc:libsigsegv-2.12.tgz(NetBSD 9.0)
sparc:libsigsegv-2.12.tgz(NetBSD 9.0)
vax:libsigsegv-2.12.tgz(NetBSD 9.0)
x86_64:libsigsegv-2.12.tgz(NetBSD 9.0)
x86_64:libsigsegv-2.12.tgz(NetBSD 9.0)
x86_64:libsigsegv-2.13.tgz(NetBSD 9.0)
x86_64:libsigsegv-2.12.tgz(NetBSD 9.0)
x86_64:libsigsegv-2.12.tgz(NetBSD 8.0)
x86_64:libsigsegv-2.12.tgz(NetBSD 8.0)
x86_64:libsigsegv-2.12.tgz(NetBSD 8.0)
x86_64:libsigsegv-2.12.tgz(NetBSD 9.0)
x86_64:libsigsegv-2.12.tgz(NetBSD 9.0)
x86_64:libsigsegv-2.12.tgz(NetBSD 9.0)
x86_64:libsigsegv-2.13.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]