Daemon Power

The NetBSD Packages Collection: devel/p5-subversion

Brief description of the package:
Perl bindings for Subversion

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://subversion.apache.org/.

Please note that this package has a apache-1.1 license.

The package is located in the "devel/p5-subversion" directory. The current source version of the package is "p5-subversion-1.9.7nb2". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for devel/p5-subversion :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: serf>=1.1.1 apr>=1.5.0 cwrappers>=20150314 apr-util>=1.2.8 apr-util>=1.5.4nb4 scons>=2.3.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 subversion-base>=1.9.7 serf>=1.2.1 serf>=1.3.8nb1 subversion-base>=1.5.2nb1 perl>=5.26.0 perl<5.28.0 subversion-base>=1.9.7nb2 .

This package requires the following package(s) to run: serf>=1.1.1 apr>=1.5.0 apr-util>=1.2.8 apr-util>=1.5.4nb4 subversion-base>=1.9.7 serf>=1.2.1 serf>=1.3.8nb1 subversion-base>=1.5.2nb1 perl>=5.26.0 perl<5.28.0 subversion-base>=1.9.7nb2 .

This package supports the following build-time options:

sasl
Enable SASL support.
serf
Use serf HTTP/WebDAV client library.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:p5-subversion-1.9.3nb1.tgz(NetBSD 7.0)
alpha:p5-subversion-1.9.1.tgz(NetBSD 7.0)
alpha:p5-subversion-1.9.3.tgz(NetBSD 7.0)
alpha:p5-subversion-1.9.5nb3.tgz(NetBSD 8.0)
arm:p5-subversion-1.8.8.tgz(NetBSD 6.1_STABLE)
earm:p5-subversion-1.9.3.tgz(NetBSD 7.0)
earm:p5-subversion-1.8.13nb2.tgz(NetBSD 7.0)
earm:p5-subversion-1.9.2nb1.tgz(NetBSD 7.0)
earmv6hf:p5-subversion-1.8.13.tgz(NetBSD 7.0)
earmv6hf:p5-subversion-1.8.13nb2.tgz(NetBSD 7.0)
earmv6hf:p5-subversion-1.9.2nb1.tgz(NetBSD 7.0)
earmv7hf:p5-subversion-1.9.3.tgz(NetBSD 7.0)
earmv7hf:p5-subversion-1.9.1.tgz(NetBSD 7.0)
earmv7hf:p5-subversion-1.9.2.tgz(NetBSD 7.99.21)
earmv7hf:p5-subversion-1.9.5nb3.tgz(NetBSD 8.0_BETA)
earmv7hfeb:p5-subversion-1.9.3.tgz(NetBSD 7.0)
i386:p5-subversion-1.8.8.tgz(MirBSD 10)
i386:p5-subversion-1.9.7nb1.tgz(NetBSD 6.0)
i386:p5-subversion-1.9.5.tgz(NetBSD 6.0)
i386:p5-subversion-1.9.5nb1.tgz(NetBSD 6.0)
i386:p5-subversion-1.9.5nb1.tgz(NetBSD 6.0)
i386:p5-subversion-1.9.5nb3.tgz(NetBSD 6.0)
i386:p5-subversion-1.9.7nb1.tgz(NetBSD 6.1)
i386:p5-subversion-1.9.5.tgz(NetBSD 6.1)
i386:p5-subversion-1.9.5nb1.tgz(NetBSD 6.1)
i386:p5-subversion-1.9.5nb1.tgz(NetBSD 6.1)
i386:p5-subversion-1.9.5nb3.tgz(NetBSD 6.1)
i386:p5-subversion-1.9.7nb1.tgz(NetBSD 7.0)
i386:p5-subversion-1.9.5.tgz(NetBSD 7.0)
i386:p5-subversion-1.9.5nb1.tgz(NetBSD 7.0)
i386:p5-subversion-1.9.5nb1.tgz(NetBSD 7.0)
i386:p5-subversion-1.9.5nb3.tgz(NetBSD 7.0)
powerpc:p5-subversion-1.9.4nb1.tgz(NetBSD 6.0)
powerpc:p5-subversion-1.9.5nb3.tgz(NetBSD 6.1)
powerpc:p5-subversion-1.9.3.tgz(NetBSD 7.0)
powerpc:p5-subversion-1.9.5nb3.tgz(NetBSD 7.1)
powerpc:p5-subversion-1.9.7nb1.tgz(NetBSD 7.1)
powerpc:p5-subversion-1.9.5nb3.tgz(NetBSD 8.0)
powerpc:p5-subversion-1.9.7nb1.tgz(NetBSD 8.0)
sh3el:p5-subversion-1.8.13nb2.tgz(NetBSD 7.0)
sparc64:p5-subversion-1.8.13nb2.tgz(NetBSD 7.0)
sparc64:p5-subversion-1.9.3.tgz(NetBSD 7.0)
sparc64:p5-subversion-1.9.5nb1.tgz(NetBSD 7.1_RC1)
sparc:p5-subversion-1.8.10.tgz(NetBSD 6.0)
x86_64:p5-subversion-1.9.7nb1.tgz(NetBSD 6.0)
x86_64:p5-subversion-1.9.5.tgz(NetBSD 6.0)
x86_64:p5-subversion-1.9.5nb1.tgz(NetBSD 6.0)
x86_64:p5-subversion-1.9.5nb1.tgz(NetBSD 6.0)
x86_64:p5-subversion-1.9.5nb3.tgz(NetBSD 6.0)
x86_64:p5-subversion-1.9.7nb1.tgz(NetBSD 6.1)
x86_64:p5-subversion-1.9.5.tgz(NetBSD 6.1)
x86_64:p5-subversion-1.9.5nb1.tgz(NetBSD 6.1)
x86_64:p5-subversion-1.9.5nb1.tgz(NetBSD 6.1)
x86_64:p5-subversion-1.9.5nb3.tgz(NetBSD 6.1)
x86_64:p5-subversion-1.9.7nb1.tgz(NetBSD 7.0)
x86_64:p5-subversion-1.9.4nb1.tgz(NetBSD 7.0)
x86_64:p5-subversion-1.9.5nb1.tgz(NetBSD 7.0)
x86_64:p5-subversion-1.9.5nb1.tgz(NetBSD 7.0)
x86_64:p5-subversion-1.9.5nb3.tgz(NetBSD 7.0)
x86_64:p5-subversion-1.9.5nb3.tgz(NetBSD 8.99.1)
x86_64:p5-subversion-1.9.7.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]