Daemon Power

The NetBSD Packages Collection: devel/py-idle

Brief description of the package:
IDLE - The Integrated DeveLopment Environment for Python

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://www.python.org/idle/.

The package is located in the "devel/py-idle" directory. The current source version of the package is "py27-idle-2.7.14". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for devel/py-idle :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: py27-Tk-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 cwrappers>=20150314 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 tcl>=8.5.7 sqlite3>=3.20.0 sqlite3>=3.0.8 sqlite3>=3.21.0nb1 tk>=8.5.7 Xft2>=2.1 fontconfig>=2.2 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 gperf-[0-9]* fontconfig>=2.10.93 fontconfig>=2.1nb2 Xrender>=0.9.0nb2 x11-links>=1.06 osabi-NetBSD-7.0.1 renderproto>=0.9.3nb1 renderproto>=0.9 Xrender>=0.2 Xrender>=0.8.2 fontconfig>=2.10.93nb2 Xrender>=0.9.0nb1 Xft2>=2.1nb2 Xft2>=2.1.7nb6 tcl>=8.6.1nb1 python27>=2.7.1nb2 tk>=8.6.1 .

This package requires the following package(s) to run: py27-Tk-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 tcl>=8.5.7 sqlite3>=3.20.0 sqlite3>=3.0.8 sqlite3>=3.21.0nb1 tk>=8.5.7 Xft2>=2.1 fontconfig>=2.2 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.10.93 fontconfig>=2.1nb2 Xrender>=0.9.0nb2 Xrender>=0.2 Xrender>=0.8.2 fontconfig>=2.10.93nb2 Xrender>=0.9.0nb1 Xft2>=2.1nb2 Xft2>=2.1.7nb6 tcl>=8.6.1nb1 python27>=2.7.1nb2 tk>=8.6.1 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:py27-idle-2.7.11.tgz(NetBSD 7.0)
alpha:py33-idle-3.3.6.tgz(NetBSD 7.0)
alpha:py34-idle-3.4.3.tgz(NetBSD 7.0)
alpha:py35-idle-3.5.1.tgz(NetBSD 7.0)
arm:py27-idle-0nb2.tgz(NetBSD 6.1_STABLE)
earm:py27-idle-2.7.11.tgz(NetBSD 7.0)
earm:py33-idle-3.3.6.tgz(NetBSD 7.0)
earm:py34-idle-3.4.3.tgz(NetBSD 7.0)
earmv6hf:py26-idle-2.6.9.tgz(NetBSD 7.0)
earmv6hf:py27-idle-2.7.9.tgz(NetBSD 7.0)
earmv6hf:py33-idle-3.3.6.tgz(NetBSD 7.0)
earmv6hf:py34-idle-3.4.3.tgz(NetBSD 7.0)
earmv6hf:py27-idle-2.7.11.tgz(NetBSD 7.0)
earmv6hf:py33-idle-3.3.6.tgz(NetBSD 7.0)
earmv6hf:py34-idle-3.4.3.tgz(NetBSD 7.0)
earmv6hf:py35-idle-3.5.1.tgz(NetBSD 7.0)
earmv7hf:py27-idle-2.7.11.tgz(NetBSD 7.0)
earmv7hf:py33-idle-3.3.6.tgz(NetBSD 7.0)
earmv7hf:py34-idle-3.4.3.tgz(NetBSD 7.0)
earmv7hf:py35-idle-3.5.1.tgz(NetBSD 7.0)
earmv7hf:py27-idle-2.7.10.tgz(NetBSD 7.99.21)
earmv7hf:py33-idle-3.3.6.tgz(NetBSD 7.99.21)
earmv7hf:py34-idle-3.4.3.tgz(NetBSD 7.99.21)
earmv7hf:py27-idle-2.7.13.tgz(NetBSD 8.0_BETA)
earmv7hf:py34-idle-3.4.6.tgz(NetBSD 8.0_BETA)
earmv7hf:py35-idle-3.5.3.tgz(NetBSD 8.0_BETA)
earmv7hf:py36-idle-3.6.1.tgz(NetBSD 8.0_BETA)
earmv7hfeb:py27-idle-2.7.11.tgz(NetBSD 7.0)
earmv7hfeb:py33-idle-3.3.6.tgz(NetBSD 7.0)
earmv7hfeb:py34-idle-3.4.3.tgz(NetBSD 7.0)
earmv7hfeb:py35-idle-3.5.1.tgz(NetBSD 7.0)
i386:py27-idle-2.7.12.tgz(NetBSD 6.0)
i386:py34-idle-3.4.5.tgz(NetBSD 6.0)
i386:py35-idle-3.5.2.tgz(NetBSD 6.0)
i386:py27-idle-2.7.12.tgz(NetBSD 6.0)
i386:py34-idle-3.4.5.tgz(NetBSD 6.0)
i386:py35-idle-3.5.2.tgz(NetBSD 6.0)
i386:py27-idle-2.7.13.tgz(NetBSD 6.0)
i386:py34-idle-3.4.6.tgz(NetBSD 6.0)
i386:py35-idle-3.5.3.tgz(NetBSD 6.0)
i386:py36-idle-3.6.0.tgz(NetBSD 6.0)
i386:py27-idle-2.7.13.tgz(NetBSD 6.0)
i386:py34-idle-3.4.6.tgz(NetBSD 6.0)
i386:py35-idle-3.5.3.tgz(NetBSD 6.0)
i386:py36-idle-3.6.1.tgz(NetBSD 6.0)
i386:py27-idle-2.7.14.tgz(NetBSD 6.1)
i386:py34-idle-3.4.7.tgz(NetBSD 6.1)
i386:py35-idle-3.5.4.tgz(NetBSD 6.1)
i386:py36-idle-3.6.2.tgz(NetBSD 6.1)
i386:py27-idle-2.7.12.tgz(NetBSD 6.1)
i386:py34-idle-3.4.5.tgz(NetBSD 6.1)
i386:py35-idle-3.5.2.tgz(NetBSD 6.1)
i386:py27-idle-2.7.12.tgz(NetBSD 6.1)
i386:py34-idle-3.4.5.tgz(NetBSD 6.1)
i386:py35-idle-3.5.2.tgz(NetBSD 6.1)
i386:py27-idle-2.7.13.tgz(NetBSD 6.1)
i386:py34-idle-3.4.6.tgz(NetBSD 6.1)
i386:py35-idle-3.5.3.tgz(NetBSD 6.1)
i386:py36-idle-3.6.0.tgz(NetBSD 6.1)
i386:py27-idle-2.7.13.tgz(NetBSD 6.1)
i386:py34-idle-3.4.6.tgz(NetBSD 6.1)
i386:py35-idle-3.5.3.tgz(NetBSD 6.1)
i386:py36-idle-3.6.1.tgz(NetBSD 6.1)
i386:py27-idle-2.7.14.tgz(NetBSD 7.0)
i386:py34-idle-3.4.7.tgz(NetBSD 7.0)
i386:py35-idle-3.5.4.tgz(NetBSD 7.0)
i386:py36-idle-3.6.2.tgz(NetBSD 7.0)
i386:py27-idle-2.7.12.tgz(NetBSD 7.0)
i386:py34-idle-3.4.5.tgz(NetBSD 7.0)
i386:py35-idle-3.5.2.tgz(NetBSD 7.0)
i386:py27-idle-2.7.12.tgz(NetBSD 7.0)
i386:py34-idle-3.4.5.tgz(NetBSD 7.0)
i386:py35-idle-3.5.2.tgz(NetBSD 7.0)
i386:py27-idle-2.7.13.tgz(NetBSD 7.0)
i386:py34-idle-3.4.6.tgz(NetBSD 7.0)
i386:py35-idle-3.5.3.tgz(NetBSD 7.0)
i386:py36-idle-3.6.0.tgz(NetBSD 7.0)
i386:py27-idle-2.7.13.tgz(NetBSD 7.0)
i386:py34-idle-3.4.6.tgz(NetBSD 7.0)
i386:py35-idle-3.5.3.tgz(NetBSD 7.0)
i386:py36-idle-3.6.1.tgz(NetBSD 7.0)
i386:py24-idle-0nb2.tgz(QNX 6.5.0)
i386:py25-idle-0nb2.tgz(QNX 6.5.0)
i386:py26-idle-0nb2.tgz(QNX 6.5.0)
i386:py27-idle-0nb2.tgz(QNX 6.5.0)
powerpc:py27-idle-2.7.12.tgz(NetBSD 6.0)
powerpc:py27-idle-2.7.13.tgz(NetBSD 6.1)
powerpc:py34-idle-3.4.6.tgz(NetBSD 6.1)
powerpc:py35-idle-3.5.3.tgz(NetBSD 6.1)
powerpc:py36-idle-3.6.1.tgz(NetBSD 6.1)
powerpc:py27-idle-2.7.11.tgz(NetBSD 7.0)
powerpc:py33-idle-3.3.6.tgz(NetBSD 7.0)
powerpc:py34-idle-3.4.3.tgz(NetBSD 7.0)
powerpc:py35-idle-3.5.1.tgz(NetBSD 7.0)
powerpc:py27-idle-2.7.13.tgz(NetBSD 7.1)
powerpc:py34-idle-3.4.6.tgz(NetBSD 7.1)
powerpc:py35-idle-3.5.3.tgz(NetBSD 7.1)
powerpc:py36-idle-3.6.1.tgz(NetBSD 7.1)
powerpc:py27-idle-2.7.14.tgz(NetBSD 7.1)
powerpc:py34-idle-3.4.7.tgz(NetBSD 7.1)
powerpc:py35-idle-3.5.4.tgz(NetBSD 7.1)
powerpc:py36-idle-3.6.2.tgz(NetBSD 7.1)
powerpc:py27-idle-2.7.13.tgz(NetBSD 8.0)
powerpc:py34-idle-3.4.6.tgz(NetBSD 8.0)
powerpc:py35-idle-3.5.3.tgz(NetBSD 8.0)
powerpc:py36-idle-3.6.1.tgz(NetBSD 8.0)
sparc64:py27-idle-2.7.10.tgz(NetBSD 7.0)
sparc64:py27-idle-2.7.11.tgz(NetBSD 7.0)
sparc64:py27-idle-2.7.9.tgz(NetBSD 7.0)
sparc64:py33-idle-3.3.6.tgz(NetBSD 7.0)
sparc64:py34-idle-3.4.3.tgz(NetBSD 7.0)
sparc64:py35-idle-3.5.1.tgz(NetBSD 7.0)
sparc:py26-idle-0nb2.tgz(NetBSD 6.0)
sparc:py27-idle-0nb2.tgz(NetBSD 6.0)
sparc:py33-idle-0nb2.tgz(NetBSD 6.0)
sparc:py34-idle-0nb2.tgz(NetBSD 6.0)
x86_64:py27-idle-2.7.12.tgz(NetBSD 6.0)
x86_64:py34-idle-3.4.5.tgz(NetBSD 6.0)
x86_64:py35-idle-3.5.2.tgz(NetBSD 6.0)
x86_64:py27-idle-2.7.12.tgz(NetBSD 6.0)
x86_64:py34-idle-3.4.5.tgz(NetBSD 6.0)
x86_64:py35-idle-3.5.2.tgz(NetBSD 6.0)
x86_64:py27-idle-2.7.13.tgz(NetBSD 6.0)
x86_64:py34-idle-3.4.6.tgz(NetBSD 6.0)
x86_64:py35-idle-3.5.3.tgz(NetBSD 6.0)
x86_64:py36-idle-3.6.0.tgz(NetBSD 6.0)
x86_64:py27-idle-2.7.13.tgz(NetBSD 6.0)
x86_64:py34-idle-3.4.6.tgz(NetBSD 6.0)
x86_64:py35-idle-3.5.3.tgz(NetBSD 6.0)
x86_64:py36-idle-3.6.1.tgz(NetBSD 6.0)
x86_64:py27-idle-2.7.12.tgz(NetBSD 6.1)
x86_64:py34-idle-3.4.5.tgz(NetBSD 6.1)
x86_64:py35-idle-3.5.2.tgz(NetBSD 6.1)
x86_64:py27-idle-2.7.12.tgz(NetBSD 6.1)
x86_64:py34-idle-3.4.5.tgz(NetBSD 6.1)
x86_64:py35-idle-3.5.2.tgz(NetBSD 6.1)
x86_64:py27-idle-2.7.13.tgz(NetBSD 6.1)
x86_64:py34-idle-3.4.6.tgz(NetBSD 6.1)
x86_64:py35-idle-3.5.3.tgz(NetBSD 6.1)
x86_64:py36-idle-3.6.0.tgz(NetBSD 6.1)
x86_64:py27-idle-2.7.13.tgz(NetBSD 6.1)
x86_64:py34-idle-3.4.6.tgz(NetBSD 6.1)
x86_64:py35-idle-3.5.3.tgz(NetBSD 6.1)
x86_64:py36-idle-3.6.1.tgz(NetBSD 6.1)
x86_64:py27-idle-2.7.14.tgz(NetBSD 7.0)
x86_64:py34-idle-3.4.7.tgz(NetBSD 7.0)
x86_64:py35-idle-3.5.4.tgz(NetBSD 7.0)
x86_64:py36-idle-3.6.2.tgz(NetBSD 7.0)
x86_64:py27-idle-2.7.12.tgz(NetBSD 7.0)
x86_64:py34-idle-3.4.5.tgz(NetBSD 7.0)
x86_64:py35-idle-3.5.2.tgz(NetBSD 7.0)
x86_64:py27-idle-2.7.12.tgz(NetBSD 7.0)
x86_64:py34-idle-3.4.5.tgz(NetBSD 7.0)
x86_64:py35-idle-3.5.2.tgz(NetBSD 7.0)
x86_64:py27-idle-2.7.13.tgz(NetBSD 7.0)
x86_64:py34-idle-3.4.6.tgz(NetBSD 7.0)
x86_64:py35-idle-3.5.3.tgz(NetBSD 7.0)
x86_64:py36-idle-3.6.0.tgz(NetBSD 7.0)
x86_64:py27-idle-2.7.13.tgz(NetBSD 7.0)
x86_64:py34-idle-3.4.6.tgz(NetBSD 7.0)
x86_64:py35-idle-3.5.3.tgz(NetBSD 7.0)
x86_64:py36-idle-3.6.1.tgz(NetBSD 7.0)
x86_64:py27-idle-2.7.13.tgz(NetBSD 7.0.1_PATCH)
x86_64:py34-idle-3.4.6.tgz(NetBSD 7.0.1_PATCH)
x86_64:py35-idle-3.5.3.tgz(NetBSD 7.0.1_PATCH)
x86_64:py36-idle-3.6.1.tgz(NetBSD 7.0.1_PATCH)
x86_64:py27-idle-2.7.13.tgz(NetBSD 8.99.1)
x86_64:py34-idle-3.4.6.tgz(NetBSD 8.99.1)
x86_64:py35-idle-3.5.3.tgz(NetBSD 8.99.1)
x86_64:py36-idle-3.6.1.tgz(NetBSD 8.99.1)
x86_64:py27-idle-2.7.13.tgz(NetBSD 8.99.1)
x86_64:py34-idle-3.4.7.tgz(NetBSD 8.99.1)
x86_64:py35-idle-3.5.4.tgz(NetBSD 8.99.1)
x86_64:py36-idle-3.6.2.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]