Daemon Power

The NetBSD Packages Collection: devel/ruby-contracts

Brief description of the package:
Contracts for Ruby

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://github.com/egonSchiele/contracts.ruby.

Please note that this package has a 2-clause-bsd license.

The package is located in the "devel/ruby-contracts" directory. The current source version of the package is "ruby23-contracts-0.16.0". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for devel/ruby-contracts :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ruby23-base>=2.3.5 libyaml>=0.1.1 cwrappers>=20150314 libyaml>=0.1.4 .

This package requires the following package(s) to run: ruby23-base>=2.3.5 libyaml>=0.1.1 libyaml>=0.1.4 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:ruby22-contracts-0.16.0.tgz(NetBSD 8.0)
alpha:ruby23-contracts-0.16.0.tgz(NetBSD 8.0)
alpha:ruby24-contracts-0.16.0.tgz(NetBSD 8.0)
earmv7hf:ruby22-contracts-0.16.0.tgz(NetBSD 8.0_BETA)
earmv7hf:ruby23-contracts-0.16.0.tgz(NetBSD 8.0_BETA)
i386:ruby22-contracts-0.16.0.tgz(NetBSD 6.0)
i386:ruby23-contracts-0.16.0.tgz(NetBSD 6.0)
i386:ruby24-contracts-0.16.0.tgz(NetBSD 6.0)
i386:ruby21-contracts-0.14.0.tgz(NetBSD 6.0)
i386:ruby22-contracts-0.14.0.tgz(NetBSD 6.0)
i386:ruby23-contracts-0.14.0.tgz(NetBSD 6.0)
i386:ruby21-contracts-0.14.0.tgz(NetBSD 6.0)
i386:ruby22-contracts-0.14.0.tgz(NetBSD 6.0)
i386:ruby23-contracts-0.14.0.tgz(NetBSD 6.0)
i386:ruby21-contracts-0.14.0.tgz(NetBSD 6.0)
i386:ruby22-contracts-0.14.0.tgz(NetBSD 6.0)
i386:ruby23-contracts-0.14.0.tgz(NetBSD 6.0)
i386:ruby22-contracts-0.16.0.tgz(NetBSD 6.0)
i386:ruby23-contracts-0.16.0.tgz(NetBSD 6.0)
i386:ruby24-contracts-0.16.0.tgz(NetBSD 6.0)
i386:ruby22-contracts-0.16.0.tgz(NetBSD 6.1)
i386:ruby23-contracts-0.16.0.tgz(NetBSD 6.1)
i386:ruby24-contracts-0.16.0.tgz(NetBSD 6.1)
i386:ruby21-contracts-0.14.0.tgz(NetBSD 6.1)
i386:ruby22-contracts-0.14.0.tgz(NetBSD 6.1)
i386:ruby23-contracts-0.14.0.tgz(NetBSD 6.1)
i386:ruby21-contracts-0.14.0.tgz(NetBSD 6.1)
i386:ruby22-contracts-0.14.0.tgz(NetBSD 6.1)
i386:ruby23-contracts-0.14.0.tgz(NetBSD 6.1)
i386:ruby21-contracts-0.14.0.tgz(NetBSD 6.1)
i386:ruby22-contracts-0.14.0.tgz(NetBSD 6.1)
i386:ruby23-contracts-0.14.0.tgz(NetBSD 6.1)
i386:ruby22-contracts-0.16.0.tgz(NetBSD 6.1)
i386:ruby23-contracts-0.16.0.tgz(NetBSD 6.1)
i386:ruby24-contracts-0.16.0.tgz(NetBSD 6.1)
i386:ruby22-contracts-0.16.0.tgz(NetBSD 7.0)
i386:ruby23-contracts-0.16.0.tgz(NetBSD 7.0)
i386:ruby24-contracts-0.16.0.tgz(NetBSD 7.0)
i386:ruby21-contracts-0.14.0.tgz(NetBSD 7.0)
i386:ruby22-contracts-0.14.0.tgz(NetBSD 7.0)
i386:ruby23-contracts-0.14.0.tgz(NetBSD 7.0)
i386:ruby21-contracts-0.14.0.tgz(NetBSD 7.0)
i386:ruby22-contracts-0.14.0.tgz(NetBSD 7.0)
i386:ruby23-contracts-0.14.0.tgz(NetBSD 7.0)
i386:ruby21-contracts-0.14.0.tgz(NetBSD 7.0)
i386:ruby22-contracts-0.14.0.tgz(NetBSD 7.0)
i386:ruby23-contracts-0.14.0.tgz(NetBSD 7.0)
i386:ruby22-contracts-0.16.0.tgz(NetBSD 7.0)
i386:ruby23-contracts-0.16.0.tgz(NetBSD 7.0)
i386:ruby24-contracts-0.16.0.tgz(NetBSD 7.0)
powerpc:ruby24-contracts-0.16.0.tgz(NetBSD 6.1)
powerpc:ruby22-contracts-0.16.0.tgz(NetBSD 7.1)
powerpc:ruby23-contracts-0.16.0.tgz(NetBSD 7.1)
powerpc:ruby24-contracts-0.16.0.tgz(NetBSD 7.1)
powerpc:ruby22-contracts-0.16.0.tgz(NetBSD 7.1)
powerpc:ruby23-contracts-0.16.0.tgz(NetBSD 7.1)
powerpc:ruby24-contracts-0.16.0.tgz(NetBSD 7.1)
powerpc:ruby22-contracts-0.16.0.tgz(NetBSD 8.0)
powerpc:ruby23-contracts-0.16.0.tgz(NetBSD 8.0)
powerpc:ruby24-contracts-0.16.0.tgz(NetBSD 8.0)
powerpc:ruby22-contracts-0.16.0.tgz(NetBSD 8.0)
powerpc:ruby23-contracts-0.16.0.tgz(NetBSD 8.0)
powerpc:ruby24-contracts-0.16.0.tgz(NetBSD 8.0)
x86_64:ruby22-contracts-0.16.0.tgz(NetBSD 6.0)
x86_64:ruby23-contracts-0.16.0.tgz(NetBSD 6.0)
x86_64:ruby24-contracts-0.16.0.tgz(NetBSD 6.0)
x86_64:ruby21-contracts-0.14.0.tgz(NetBSD 6.0)
x86_64:ruby22-contracts-0.14.0.tgz(NetBSD 6.0)
x86_64:ruby23-contracts-0.14.0.tgz(NetBSD 6.0)
x86_64:ruby21-contracts-0.14.0.tgz(NetBSD 6.0)
x86_64:ruby22-contracts-0.14.0.tgz(NetBSD 6.0)
x86_64:ruby23-contracts-0.14.0.tgz(NetBSD 6.0)
x86_64:ruby21-contracts-0.14.0.tgz(NetBSD 6.0)
x86_64:ruby22-contracts-0.14.0.tgz(NetBSD 6.0)
x86_64:ruby23-contracts-0.14.0.tgz(NetBSD 6.0)
x86_64:ruby22-contracts-0.16.0.tgz(NetBSD 6.0)
x86_64:ruby23-contracts-0.16.0.tgz(NetBSD 6.0)
x86_64:ruby24-contracts-0.16.0.tgz(NetBSD 6.0)
x86_64:ruby22-contracts-0.16.0.tgz(NetBSD 6.1)
x86_64:ruby23-contracts-0.16.0.tgz(NetBSD 6.1)
x86_64:ruby24-contracts-0.16.0.tgz(NetBSD 6.1)
x86_64:ruby21-contracts-0.14.0.tgz(NetBSD 6.1)
x86_64:ruby22-contracts-0.14.0.tgz(NetBSD 6.1)
x86_64:ruby23-contracts-0.14.0.tgz(NetBSD 6.1)
x86_64:ruby21-contracts-0.14.0.tgz(NetBSD 6.1)
x86_64:ruby22-contracts-0.14.0.tgz(NetBSD 6.1)
x86_64:ruby23-contracts-0.14.0.tgz(NetBSD 6.1)
x86_64:ruby21-contracts-0.14.0.tgz(NetBSD 6.1)
x86_64:ruby22-contracts-0.14.0.tgz(NetBSD 6.1)
x86_64:ruby23-contracts-0.14.0.tgz(NetBSD 6.1)
x86_64:ruby22-contracts-0.16.0.tgz(NetBSD 6.1)
x86_64:ruby23-contracts-0.16.0.tgz(NetBSD 6.1)
x86_64:ruby24-contracts-0.16.0.tgz(NetBSD 6.1)
x86_64:ruby22-contracts-0.16.0.tgz(NetBSD 7.0)
x86_64:ruby23-contracts-0.16.0.tgz(NetBSD 7.0)
x86_64:ruby24-contracts-0.16.0.tgz(NetBSD 7.0)
x86_64:ruby21-contracts-0.14.0.tgz(NetBSD 7.0)
x86_64:ruby22-contracts-0.14.0.tgz(NetBSD 7.0)
x86_64:ruby23-contracts-0.14.0.tgz(NetBSD 7.0)
x86_64:ruby21-contracts-0.14.0.tgz(NetBSD 7.0)
x86_64:ruby22-contracts-0.14.0.tgz(NetBSD 7.0)
x86_64:ruby23-contracts-0.14.0.tgz(NetBSD 7.0)
x86_64:ruby21-contracts-0.14.0.tgz(NetBSD 7.0)
x86_64:ruby22-contracts-0.14.0.tgz(NetBSD 7.0)
x86_64:ruby23-contracts-0.14.0.tgz(NetBSD 7.0)
x86_64:ruby22-contracts-0.16.0.tgz(NetBSD 7.0)
x86_64:ruby23-contracts-0.16.0.tgz(NetBSD 7.0)
x86_64:ruby24-contracts-0.16.0.tgz(NetBSD 7.0)
x86_64:ruby22-contracts-0.16.0.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby23-contracts-0.16.0.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby24-contracts-0.16.0.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby22-contracts-0.16.0.tgz(NetBSD 8.99.1)
x86_64:ruby23-contracts-0.16.0.tgz(NetBSD 8.99.1)
x86_64:ruby24-contracts-0.16.0.tgz(NetBSD 8.99.1)
x86_64:ruby22-contracts-0.16.0.tgz(NetBSD 8.99.1)
x86_64:ruby23-contracts-0.16.0.tgz(NetBSD 8.99.1)
x86_64:ruby24-contracts-0.16.0.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]