Daemon Power

The NetBSD Packages Collection: devel/ruby-curses

Brief description of the package:
Ruby binding for curses, ncurses, and PDCurses

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://github.com/ruby/curses.

Please note that this package has a 2-clause-bsd license.

The package is located in the "devel/ruby-curses" directory. The current source version of the package is "ruby23-curses-1.2.4". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for devel/ruby-curses :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ruby23-base>=2.3.5 libyaml>=0.1.1 cwrappers>=20150314 libyaml>=0.1.4 .

This package requires the following package(s) to run: ruby23-base>=2.3.5 libyaml>=0.1.1 libyaml>=0.1.4 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 7.0)
alpha:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 7.0)
alpha:ruby193-curses-1.9.3p551nb2.tgz(NetBSD 7.0)
alpha:ruby200-curses-2.0.0p647nb2.tgz(NetBSD 7.0)
alpha:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 7.0)
alpha:ruby200-curses-2.0.0p648nb2.tgz(NetBSD 7.0)
alpha:ruby22-curses-1.2.2.tgz(NetBSD 8.0)
alpha:ruby23-curses-1.2.2.tgz(NetBSD 8.0)
alpha:ruby24-curses-1.2.2.tgz(NetBSD 8.0)
arm:ruby18-curses-1.8.7.374nb1.tgz(NetBSD 6.1_STABLE)
arm:ruby193-curses-1.9.3p545nb1.tgz(NetBSD 6.1_STABLE)
arm:ruby200-curses-2.0.0p451nb1.tgz(NetBSD 6.1_STABLE)
earm:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 7.0)
earm:ruby200-curses-2.0.0p648nb2.tgz(NetBSD 7.0)
earm:ruby193-curses-1.9.3p551nb1.tgz(NetBSD 7.0)
earm:ruby200-curses-2.0.0p643nb1.tgz(NetBSD 7.0)
earm:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 7.0)
earm:ruby200-curses-2.0.0p647nb2.tgz(NetBSD 7.0)
earmv6hf:ruby18-curses-1.8.7.374nb1.tgz(NetBSD 7.0)
earmv6hf:ruby193-curses-1.9.3p551nb1.tgz(NetBSD 7.0)
earmv6hf:ruby200-curses-2.0.0p643nb1.tgz(NetBSD 7.0)
earmv6hf:ruby18-curses-1.8.7.374nb1.tgz(NetBSD 7.0)
earmv6hf:ruby193-curses-1.9.3p551nb1.tgz(NetBSD 7.0)
earmv6hf:ruby200-curses-2.0.0p645nb1.tgz(NetBSD 7.0)
earmv6hf:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 7.0)
earmv6hf:ruby200-curses-2.0.0p647nb2.tgz(NetBSD 7.0)
earmv7hf:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 7.0)
earmv7hf:ruby200-curses-2.0.0p648nb2.tgz(NetBSD 7.0)
earmv7hf:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 7.99.21)
earmv7hf:ruby193-curses-1.9.3p551nb2.tgz(NetBSD 7.99.21)
earmv7hf:ruby200-curses-2.0.0p647nb2.tgz(NetBSD 7.99.21)
earmv7hf:ruby22-curses-1.2.2.tgz(NetBSD 8.0_BETA)
earmv7hf:ruby23-curses-1.2.2.tgz(NetBSD 8.0_BETA)
earmv7hfeb:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 7.0)
earmv7hfeb:ruby200-curses-2.0.0p648nb2.tgz(NetBSD 7.0)
i386:ruby18-curses-1.8.7.374nb1.tgz(MirBSD 10)
i386:ruby193-curses-1.9.3p545nb1.tgz(MirBSD 10)
i386:ruby200-curses-2.0.0p451nb1.tgz(MirBSD 10)
i386:ruby22-curses-1.2.4.tgz(NetBSD 6.0)
i386:ruby23-curses-1.2.4.tgz(NetBSD 6.0)
i386:ruby24-curses-1.2.4.tgz(NetBSD 6.0)
i386:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 6.0)
i386:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 6.0)
i386:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 6.0)
i386:ruby22-curses-1.2.2.tgz(NetBSD 6.0)
i386:ruby23-curses-1.2.2.tgz(NetBSD 6.0)
i386:ruby24-curses-1.2.2.tgz(NetBSD 6.0)
i386:ruby22-curses-1.2.4.tgz(NetBSD 6.1)
i386:ruby23-curses-1.2.4.tgz(NetBSD 6.1)
i386:ruby24-curses-1.2.4.tgz(NetBSD 6.1)
i386:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 6.1)
i386:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 6.1)
i386:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 6.1)
i386:ruby22-curses-1.2.2.tgz(NetBSD 6.1)
i386:ruby23-curses-1.2.2.tgz(NetBSD 6.1)
i386:ruby24-curses-1.2.2.tgz(NetBSD 6.1)
i386:ruby22-curses-1.2.4.tgz(NetBSD 7.0)
i386:ruby23-curses-1.2.4.tgz(NetBSD 7.0)
i386:ruby24-curses-1.2.4.tgz(NetBSD 7.0)
i386:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 7.0)
i386:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 7.0)
i386:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 7.0)
i386:ruby22-curses-1.2.2.tgz(NetBSD 7.0)
i386:ruby23-curses-1.2.2.tgz(NetBSD 7.0)
i386:ruby24-curses-1.2.2.tgz(NetBSD 7.0)
i386:ruby18-curses-1.8.7.352.tgz(QNX 6.5.0)
i386:ruby19-curses-1.9.2pl290.tgz(QNX 6.5.0)
powerpc:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 6.0)
powerpc:ruby24-curses-1.2.2.tgz(NetBSD 6.1)
powerpc:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 7.0)
powerpc:ruby200-curses-2.0.0p648nb2.tgz(NetBSD 7.0)
powerpc:ruby22-curses-1.2.2.tgz(NetBSD 7.1)
powerpc:ruby23-curses-1.2.2.tgz(NetBSD 7.1)
powerpc:ruby24-curses-1.2.2.tgz(NetBSD 7.1)
powerpc:ruby22-curses-1.2.4.tgz(NetBSD 7.1)
powerpc:ruby23-curses-1.2.4.tgz(NetBSD 7.1)
powerpc:ruby24-curses-1.2.4.tgz(NetBSD 7.1)
powerpc:ruby22-curses-1.2.2.tgz(NetBSD 8.0)
powerpc:ruby23-curses-1.2.2.tgz(NetBSD 8.0)
powerpc:ruby24-curses-1.2.2.tgz(NetBSD 8.0)
sparc64:ruby18-curses-1.8.7.374nb1.tgz(NetBSD 7.0)
sparc64:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 7.0)
sparc64:ruby193-curses-1.9.3p551nb1.tgz(NetBSD 7.0)
sparc64:ruby200-curses-2.0.0p643nb1.tgz(NetBSD 7.0)
sparc64:ruby200-curses-2.0.0p645nb1.tgz(NetBSD 7.0)
sparc64:ruby200-curses-2.0.0p648nb2.tgz(NetBSD 7.0)
sparc:ruby18-curses-1.8.7.374nb1.tgz(NetBSD 5.1)
sparc:ruby193-curses-1.9.3p551nb1.tgz(NetBSD 5.1)
sparc:ruby18-curses-1.8.7.374nb1.tgz(NetBSD 5.1)
sparc:ruby193-curses-1.9.3p551nb1.tgz(NetBSD 5.1)
sparc:ruby193-curses-1.9.3p547nb1.tgz(NetBSD 6.0)
sparc:ruby200-curses-2.0.0p481nb1.tgz(NetBSD 6.0)
x86_64:ruby22-curses-1.2.4.tgz(NetBSD 6.0)
x86_64:ruby23-curses-1.2.4.tgz(NetBSD 6.0)
x86_64:ruby24-curses-1.2.4.tgz(NetBSD 6.0)
x86_64:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 6.0)
x86_64:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 6.0)
x86_64:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 6.0)
x86_64:ruby22-curses-1.2.2.tgz(NetBSD 6.0)
x86_64:ruby23-curses-1.2.2.tgz(NetBSD 6.0)
x86_64:ruby24-curses-1.2.2.tgz(NetBSD 6.0)
x86_64:ruby22-curses-1.2.4.tgz(NetBSD 6.1)
x86_64:ruby23-curses-1.2.4.tgz(NetBSD 6.1)
x86_64:ruby24-curses-1.2.4.tgz(NetBSD 6.1)
x86_64:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 6.1)
x86_64:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 6.1)
x86_64:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 6.1)
x86_64:ruby22-curses-1.2.2.tgz(NetBSD 6.1)
x86_64:ruby23-curses-1.2.2.tgz(NetBSD 6.1)
x86_64:ruby24-curses-1.2.2.tgz(NetBSD 6.1)
x86_64:ruby22-curses-1.2.4.tgz(NetBSD 7.0)
x86_64:ruby23-curses-1.2.4.tgz(NetBSD 7.0)
x86_64:ruby24-curses-1.2.4.tgz(NetBSD 7.0)
x86_64:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 7.0)
x86_64:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 7.0)
x86_64:ruby18-curses-1.8.7.374nb2.tgz(NetBSD 7.0)
x86_64:ruby22-curses-1.2.2.tgz(NetBSD 7.0)
x86_64:ruby23-curses-1.2.2.tgz(NetBSD 7.0)
x86_64:ruby24-curses-1.2.2.tgz(NetBSD 7.0)
x86_64:ruby22-curses-1.2.2.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby23-curses-1.2.2.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby24-curses-1.2.2.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby22-curses-1.2.2.tgz(NetBSD 8.99.1)
x86_64:ruby23-curses-1.2.2.tgz(NetBSD 8.99.1)
x86_64:ruby24-curses-1.2.2.tgz(NetBSD 8.99.1)
x86_64:ruby22-curses-1.2.3.tgz(NetBSD 8.99.1)
x86_64:ruby23-curses-1.2.3.tgz(NetBSD 8.99.1)
x86_64:ruby24-curses-1.2.3.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]