Daemon Power

The NetBSD Packages Collection: devel/ruby-subversion

Brief description of the package:
Ruby bindings for Subversion

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://subversion.apache.org/.

Please note that this package has a apache-1.1 license.

The package is located in the "devel/ruby-subversion" directory. The current source version of the package is "ruby23-subversion-1.9.7nb1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for devel/ruby-subversion :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: serf>=1.1.1 apr>=1.5.0 cwrappers>=20150314 apr-util>=1.2.8 apr-util>=1.5.4nb4 scons>=2.3.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 subversion-base>=1.9.7 serf>=1.2.1 serf>=1.3.8nb1 subversion-base>=1.5.2nb1 ruby23-base>=2.3.5 libyaml>=0.1.1 libyaml>=0.1.4 subversion-base>=1.9.7nb1 .

This package requires the following package(s) to run: serf>=1.1.1 apr>=1.5.0 apr-util>=1.2.8 apr-util>=1.5.4nb4 subversion-base>=1.9.7 serf>=1.2.1 serf>=1.3.8nb1 subversion-base>=1.5.2nb1 ruby23-base>=2.3.5 libyaml>=0.1.1 libyaml>=0.1.4 subversion-base>=1.9.7nb1 .

This package supports the following build-time options:

sasl
Enable SASL support.
serf
Use serf HTTP/WebDAV client library.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:ruby21-subversion-1.9.3nb1.tgz(NetBSD 7.0)
alpha:ruby22-subversion-1.9.3nb1.tgz(NetBSD 7.0)
alpha:ruby23-subversion-1.9.3nb1.tgz(NetBSD 7.0)
alpha:ruby193-subversion-1.9.1.tgz(NetBSD 7.0)
alpha:ruby200-subversion-1.9.1.tgz(NetBSD 7.0)
alpha:ruby21-subversion-1.9.1.tgz(NetBSD 7.0)
alpha:ruby22-subversion-1.9.1.tgz(NetBSD 7.0)
alpha:ruby200-subversion-1.9.3.tgz(NetBSD 7.0)
alpha:ruby21-subversion-1.9.3.tgz(NetBSD 7.0)
alpha:ruby22-subversion-1.9.3.tgz(NetBSD 7.0)
alpha:ruby22-subversion-1.9.5nb2.tgz(NetBSD 8.0)
alpha:ruby23-subversion-1.9.5nb2.tgz(NetBSD 8.0)
alpha:ruby24-subversion-1.9.5nb2.tgz(NetBSD 8.0)
arm:ruby200-subversion-1.8.8.tgz(NetBSD 6.1_STABLE)
earm:ruby200-subversion-1.9.3.tgz(NetBSD 7.0)
earm:ruby22-subversion-1.9.3.tgz(NetBSD 7.0)
earm:ruby200-subversion-1.9.2nb1.tgz(NetBSD 7.0)
earm:ruby21-subversion-1.9.2nb1.tgz(NetBSD 7.0)
earm:ruby22-subversion-1.9.2nb1.tgz(NetBSD 7.0)
earmv6hf:ruby193-subversion-1.8.13.tgz(NetBSD 7.0)
earmv6hf:ruby200-subversion-1.8.13.tgz(NetBSD 7.0)
earmv6hf:ruby21-subversion-1.8.13.tgz(NetBSD 7.0)
earmv6hf:ruby200-subversion-1.8.13nb1.tgz(NetBSD 7.0)
earmv6hf:ruby200-subversion-1.9.2nb1.tgz(NetBSD 7.0)
earmv6hf:ruby21-subversion-1.9.2nb1.tgz(NetBSD 7.0)
earmv6hf:ruby22-subversion-1.9.2nb1.tgz(NetBSD 7.0)
earmv7hf:ruby200-subversion-1.9.3.tgz(NetBSD 7.0)
earmv7hf:ruby21-subversion-1.9.3.tgz(NetBSD 7.0)
earmv7hf:ruby22-subversion-1.9.3.tgz(NetBSD 7.0)
earmv7hf:ruby193-subversion-1.9.2.tgz(NetBSD 7.99.21)
earmv7hf:ruby200-subversion-1.9.2.tgz(NetBSD 7.99.21)
earmv7hf:ruby21-subversion-1.9.2.tgz(NetBSD 7.99.21)
earmv7hf:ruby22-subversion-1.9.2.tgz(NetBSD 7.99.21)
earmv7hf:ruby22-subversion-1.9.5nb2.tgz(NetBSD 8.0_BETA)
earmv7hf:ruby23-subversion-1.9.5nb2.tgz(NetBSD 8.0_BETA)
earmv7hfeb:ruby200-subversion-1.9.3.tgz(NetBSD 7.0)
earmv7hfeb:ruby21-subversion-1.9.3.tgz(NetBSD 7.0)
earmv7hfeb:ruby22-subversion-1.9.3.tgz(NetBSD 7.0)
earmv7hfeb:ruby23-subversion-1.9.3.tgz(NetBSD 7.0)
i386:ruby22-subversion-1.9.7nb1.tgz(NetBSD 6.0)
i386:ruby23-subversion-1.9.7nb1.tgz(NetBSD 6.0)
i386:ruby24-subversion-1.9.7nb1.tgz(NetBSD 6.0)
i386:ruby21-subversion-1.9.5.tgz(NetBSD 6.0)
i386:ruby22-subversion-1.9.5.tgz(NetBSD 6.0)
i386:ruby23-subversion-1.9.5.tgz(NetBSD 6.0)
i386:ruby21-subversion-1.9.5nb1.tgz(NetBSD 6.0)
i386:ruby22-subversion-1.9.5nb1.tgz(NetBSD 6.0)
i386:ruby23-subversion-1.9.5nb1.tgz(NetBSD 6.0)
i386:ruby21-subversion-1.9.5nb1.tgz(NetBSD 6.0)
i386:ruby22-subversion-1.9.5nb1.tgz(NetBSD 6.0)
i386:ruby23-subversion-1.9.5nb1.tgz(NetBSD 6.0)
i386:ruby22-subversion-1.9.5nb2.tgz(NetBSD 6.0)
i386:ruby23-subversion-1.9.5nb2.tgz(NetBSD 6.0)
i386:ruby24-subversion-1.9.5nb2.tgz(NetBSD 6.0)
i386:ruby22-subversion-1.9.7nb1.tgz(NetBSD 6.1)
i386:ruby23-subversion-1.9.7nb1.tgz(NetBSD 6.1)
i386:ruby24-subversion-1.9.7nb1.tgz(NetBSD 6.1)
i386:ruby21-subversion-1.9.5.tgz(NetBSD 6.1)
i386:ruby22-subversion-1.9.5.tgz(NetBSD 6.1)
i386:ruby23-subversion-1.9.5.tgz(NetBSD 6.1)
i386:ruby21-subversion-1.9.5nb1.tgz(NetBSD 6.1)
i386:ruby22-subversion-1.9.5nb1.tgz(NetBSD 6.1)
i386:ruby23-subversion-1.9.5nb1.tgz(NetBSD 6.1)
i386:ruby21-subversion-1.9.5nb1.tgz(NetBSD 6.1)
i386:ruby22-subversion-1.9.5nb1.tgz(NetBSD 6.1)
i386:ruby23-subversion-1.9.5nb1.tgz(NetBSD 6.1)
i386:ruby22-subversion-1.9.5nb2.tgz(NetBSD 6.1)
i386:ruby23-subversion-1.9.5nb2.tgz(NetBSD 6.1)
i386:ruby24-subversion-1.9.5nb2.tgz(NetBSD 6.1)
i386:ruby22-subversion-1.9.7nb1.tgz(NetBSD 7.0)
i386:ruby23-subversion-1.9.7nb1.tgz(NetBSD 7.0)
i386:ruby24-subversion-1.9.7nb1.tgz(NetBSD 7.0)
i386:ruby21-subversion-1.9.5.tgz(NetBSD 7.0)
i386:ruby22-subversion-1.9.5.tgz(NetBSD 7.0)
i386:ruby23-subversion-1.9.5.tgz(NetBSD 7.0)
i386:ruby21-subversion-1.9.5nb1.tgz(NetBSD 7.0)
i386:ruby22-subversion-1.9.5nb1.tgz(NetBSD 7.0)
i386:ruby23-subversion-1.9.5nb1.tgz(NetBSD 7.0)
i386:ruby21-subversion-1.9.5nb1.tgz(NetBSD 7.0)
i386:ruby22-subversion-1.9.5nb1.tgz(NetBSD 7.0)
i386:ruby23-subversion-1.9.5nb1.tgz(NetBSD 7.0)
i386:ruby22-subversion-1.9.5nb2.tgz(NetBSD 7.0)
i386:ruby23-subversion-1.9.5nb2.tgz(NetBSD 7.0)
i386:ruby24-subversion-1.9.5nb2.tgz(NetBSD 7.0)
i386:ruby18-subversion-1.6.17nb1.tgz(QNX 6.5.0)
i386:ruby19-subversion-1.6.17nb1.tgz(QNX 6.5.0)
powerpc:ruby24-subversion-1.9.5nb2.tgz(NetBSD 6.1)
powerpc:ruby200-subversion-1.9.3.tgz(NetBSD 7.0)
powerpc:ruby21-subversion-1.9.3.tgz(NetBSD 7.0)
powerpc:ruby22-subversion-1.9.3.tgz(NetBSD 7.0)
powerpc:ruby22-subversion-1.9.5nb2.tgz(NetBSD 7.1)
powerpc:ruby23-subversion-1.9.5nb2.tgz(NetBSD 7.1)
powerpc:ruby24-subversion-1.9.5nb2.tgz(NetBSD 7.1)
powerpc:ruby22-subversion-1.9.7nb1.tgz(NetBSD 7.1)
powerpc:ruby23-subversion-1.9.7nb1.tgz(NetBSD 7.1)
powerpc:ruby24-subversion-1.9.7nb1.tgz(NetBSD 7.1)
powerpc:ruby22-subversion-1.9.5nb2.tgz(NetBSD 8.0)
powerpc:ruby23-subversion-1.9.5nb2.tgz(NetBSD 8.0)
powerpc:ruby24-subversion-1.9.5nb2.tgz(NetBSD 8.0)
sparc64:ruby193-subversion-1.8.13nb1.tgz(NetBSD 7.0)
sparc64:ruby200-subversion-1.8.13nb1.tgz(NetBSD 7.0)
sparc64:ruby200-subversion-1.9.3.tgz(NetBSD 7.0)
sparc64:ruby21-subversion-1.8.13nb1.tgz(NetBSD 7.0)
sparc64:ruby21-subversion-1.9.3.tgz(NetBSD 7.0)
sparc64:ruby22-subversion-1.8.13nb1.tgz(NetBSD 7.0)
sparc64:ruby22-subversion-1.9.3.tgz(NetBSD 7.0)
sparc:ruby200-subversion-1.8.10.tgz(NetBSD 6.0)
x86_64:ruby22-subversion-1.9.7nb1.tgz(NetBSD 6.0)
x86_64:ruby23-subversion-1.9.7nb1.tgz(NetBSD 6.0)
x86_64:ruby24-subversion-1.9.7nb1.tgz(NetBSD 6.0)
x86_64:ruby21-subversion-1.9.5.tgz(NetBSD 6.0)
x86_64:ruby22-subversion-1.9.5.tgz(NetBSD 6.0)
x86_64:ruby23-subversion-1.9.5.tgz(NetBSD 6.0)
x86_64:ruby21-subversion-1.9.5nb1.tgz(NetBSD 6.0)
x86_64:ruby22-subversion-1.9.5nb1.tgz(NetBSD 6.0)
x86_64:ruby23-subversion-1.9.5nb1.tgz(NetBSD 6.0)
x86_64:ruby21-subversion-1.9.5nb1.tgz(NetBSD 6.0)
x86_64:ruby22-subversion-1.9.5nb1.tgz(NetBSD 6.0)
x86_64:ruby23-subversion-1.9.5nb1.tgz(NetBSD 6.0)
x86_64:ruby22-subversion-1.9.5nb2.tgz(NetBSD 6.0)
x86_64:ruby23-subversion-1.9.5nb2.tgz(NetBSD 6.0)
x86_64:ruby24-subversion-1.9.5nb2.tgz(NetBSD 6.0)
x86_64:ruby22-subversion-1.9.7nb1.tgz(NetBSD 6.1)
x86_64:ruby23-subversion-1.9.7nb1.tgz(NetBSD 6.1)
x86_64:ruby24-subversion-1.9.7nb1.tgz(NetBSD 6.1)
x86_64:ruby21-subversion-1.9.5.tgz(NetBSD 6.1)
x86_64:ruby22-subversion-1.9.5.tgz(NetBSD 6.1)
x86_64:ruby23-subversion-1.9.5.tgz(NetBSD 6.1)
x86_64:ruby21-subversion-1.9.5nb1.tgz(NetBSD 6.1)
x86_64:ruby22-subversion-1.9.5nb1.tgz(NetBSD 6.1)
x86_64:ruby23-subversion-1.9.5nb1.tgz(NetBSD 6.1)
x86_64:ruby21-subversion-1.9.5nb1.tgz(NetBSD 6.1)
x86_64:ruby22-subversion-1.9.5nb1.tgz(NetBSD 6.1)
x86_64:ruby23-subversion-1.9.5nb1.tgz(NetBSD 6.1)
x86_64:ruby22-subversion-1.9.5nb2.tgz(NetBSD 6.1)
x86_64:ruby23-subversion-1.9.5nb2.tgz(NetBSD 6.1)
x86_64:ruby24-subversion-1.9.5nb2.tgz(NetBSD 6.1)
x86_64:ruby22-subversion-1.9.7nb1.tgz(NetBSD 7.0)
x86_64:ruby23-subversion-1.9.7nb1.tgz(NetBSD 7.0)
x86_64:ruby24-subversion-1.9.7nb1.tgz(NetBSD 7.0)
x86_64:ruby21-subversion-1.9.4.tgz(NetBSD 7.0)
x86_64:ruby22-subversion-1.9.4.tgz(NetBSD 7.0)
x86_64:ruby23-subversion-1.9.4.tgz(NetBSD 7.0)
x86_64:ruby21-subversion-1.9.5nb1.tgz(NetBSD 7.0)
x86_64:ruby22-subversion-1.9.5nb1.tgz(NetBSD 7.0)
x86_64:ruby23-subversion-1.9.5nb1.tgz(NetBSD 7.0)
x86_64:ruby21-subversion-1.9.5nb1.tgz(NetBSD 7.0)
x86_64:ruby22-subversion-1.9.5nb1.tgz(NetBSD 7.0)
x86_64:ruby23-subversion-1.9.5nb1.tgz(NetBSD 7.0)
x86_64:ruby22-subversion-1.9.5nb2.tgz(NetBSD 7.0)
x86_64:ruby23-subversion-1.9.5nb2.tgz(NetBSD 7.0)
x86_64:ruby24-subversion-1.9.5nb2.tgz(NetBSD 7.0)
x86_64:ruby22-subversion-1.9.5nb2.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby23-subversion-1.9.5nb2.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby24-subversion-1.9.5nb2.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby22-subversion-1.9.5nb2.tgz(NetBSD 8.99.1)
x86_64:ruby23-subversion-1.9.5nb2.tgz(NetBSD 8.99.1)
x86_64:ruby24-subversion-1.9.5nb2.tgz(NetBSD 8.99.1)
x86_64:ruby22-subversion-1.9.7.tgz(NetBSD 8.99.1)
x86_64:ruby23-subversion-1.9.7.tgz(NetBSD 8.99.1)
x86_64:ruby24-subversion-1.9.7.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]