Daemon Power

The NetBSD Packages Collection: devel/subversion

Brief description of the package:
Version control system, meta-package

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://subversion.apache.org/.

Please note that this package has a apache-1.1 license.

The package is located in the "devel/subversion" directory. The current source version of the package is "subversion-1.9.7". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for devel/subversion :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: subversion-base-1.9.7{,nb[0-9]*} serf>=1.1.1 apr>=1.5.0 cwrappers>=20150314 apr-util>=1.2.8 apr-util>=1.5.4nb4 scons>=2.3.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 serf>=1.2.1 serf>=1.3.8nb1 ap24-subversion-1.9.7{,nb[0-9]*} subversion-base>=1.9.7 subversion-base>=1.5.2nb1 apache>=2.4.7<2.5 apr-util>=1.5.3 pcre>=3.4nb1 nghttp2>=1.0.0 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 pcre>=8.30nb1 nghttp2>=1.25.0nb1 subversion-base>=1.9.7nb1 apache>=2.4.18nb1 p5-subversion-1.9.7{,nb[0-9]*} perl>=5.26.0 perl<5.28.0 py27-subversion-1.9.7{,nb[0-9]*} ruby23-subversion-1.9.7{,nb[0-9]*} ruby23-base>=2.3.5 libyaml>=0.1.1 libyaml>=0.1.4 .

This package requires the following package(s) to run: subversion-base-1.9.7{,nb[0-9]*} serf>=1.1.1 apr>=1.5.0 apr-util>=1.2.8 apr-util>=1.5.4nb4 serf>=1.2.1 serf>=1.3.8nb1 ap24-subversion-1.9.7{,nb[0-9]*} subversion-base>=1.9.7 subversion-base>=1.5.2nb1 apache>=2.4.7<2.5 apr-util>=1.5.3 pcre>=3.4nb1 nghttp2>=1.0.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 python27>=2.7.1nb2 libxml2>=2.8.0nb2 readline>=2.2 pcre>=8.30nb1 nghttp2>=1.25.0nb1 readline>=6.0 subversion-base>=1.9.7nb1 apache>=2.4.18nb1 p5-subversion-1.9.7{,nb[0-9]*} perl>=5.26.0 perl<5.28.0 py27-subversion-1.9.7{,nb[0-9]*} ruby23-subversion-1.9.7{,nb[0-9]*} ruby23-base>=2.3.5 libyaml>=0.1.1 libyaml>=0.1.4 .

This package supports the following build-time options:

sasl
Enable SASL support.
serf
Use serf HTTP/WebDAV client library.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:subversion-1.9.3.tgz(NetBSD 7.0)
alpha:subversion-1.9.3.tgz(NetBSD 7.0)
alpha:subversion-1.9.5.tgz(NetBSD 8.0)
arm:subversion-1.8.8.tgz(NetBSD 6.1_STABLE)
earm:subversion-1.9.3.tgz(NetBSD 7.0)
earm:subversion-1.9.2.tgz(NetBSD 7.0)
earmv6hf:subversion-1.8.13.tgz(NetBSD 7.0)
earmv6hf:subversion-1.8.13nb1.tgz(NetBSD 7.0)
earmv6hf:subversion-1.9.2.tgz(NetBSD 7.0)
earmv7hf:subversion-1.9.3.tgz(NetBSD 7.0)
earmv7hf:subversion-1.9.2.tgz(NetBSD 7.99.21)
earmv7hf:subversion-1.9.5.tgz(NetBSD 8.0_BETA)
i386:subversion-1.9.7.tgz(NetBSD 6.0)
i386:subversion-1.9.5.tgz(NetBSD 6.0)
i386:subversion-1.9.5.tgz(NetBSD 6.0)
i386:subversion-1.9.5.tgz(NetBSD 6.0)
i386:subversion-1.9.5.tgz(NetBSD 6.0)
i386:subversion-1.9.7.tgz(NetBSD 6.1)
i386:subversion-1.9.5.tgz(NetBSD 6.1)
i386:subversion-1.9.5.tgz(NetBSD 6.1)
i386:subversion-1.9.5.tgz(NetBSD 6.1)
i386:subversion-1.9.5.tgz(NetBSD 6.1)
i386:subversion-1.9.7.tgz(NetBSD 7.0)
i386:subversion-1.9.5.tgz(NetBSD 7.0)
i386:subversion-1.9.5.tgz(NetBSD 7.0)
i386:subversion-1.9.5.tgz(NetBSD 7.0)
i386:subversion-1.9.5.tgz(NetBSD 7.0)
powerpc:subversion-1.9.3.tgz(NetBSD 7.0)
powerpc:subversion-1.9.5.tgz(NetBSD 7.1)
powerpc:subversion-1.9.7.tgz(NetBSD 7.1)
powerpc:subversion-1.9.5.tgz(NetBSD 8.0)
x86_64:subversion-1.9.7.tgz(NetBSD 6.0)
x86_64:subversion-1.9.5.tgz(NetBSD 6.0)
x86_64:subversion-1.9.5.tgz(NetBSD 6.0)
x86_64:subversion-1.9.5.tgz(NetBSD 6.0)
x86_64:subversion-1.9.5.tgz(NetBSD 6.0)
x86_64:subversion-1.9.7.tgz(NetBSD 6.1)
x86_64:subversion-1.9.5.tgz(NetBSD 6.1)
x86_64:subversion-1.9.5.tgz(NetBSD 6.1)
x86_64:subversion-1.9.5.tgz(NetBSD 6.1)
x86_64:subversion-1.9.5.tgz(NetBSD 6.1)
x86_64:subversion-1.9.7.tgz(NetBSD 7.0)
x86_64:subversion-1.9.4nb1.tgz(NetBSD 7.0)
x86_64:subversion-1.9.5.tgz(NetBSD 7.0)
x86_64:subversion-1.9.5.tgz(NetBSD 7.0)
x86_64:subversion-1.9.5.tgz(NetBSD 7.0)
x86_64:subversion-1.9.5.tgz(NetBSD 8.99.1)
x86_64:subversion-1.9.7.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]