Daemon Power

The NetBSD Packages Collection: games/crossfire-server

Brief description of the package:
X11 multi/single player game similar to gauntlet and nethack

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://crossfire.real-time.com/.

The package is located in the "games/crossfire-server" directory. The current source version of the package is "crossfire-server-1.11.0nb24". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for games/crossfire-server :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: bash-[0-9]* cwrappers>=20150314 perl>=5.0 libXp>=1.0.0 x11-links>=1.04 osabi-NetBSD-7.0.1 printproto>=1.0.3 xproto>=7.0.9 libXpm>=3.5.4.2 png>=1.2.4 libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 xmlcatmgr>=2.0beta1 libxml2>=2.6.2 libgcrypt>=1.6.0 libxml2>=2.8.0nb2 docbook-xml-[0-9]* docbook-xsl-[0-9]* docbook-xml>=4.2 curl>=7.12.3 libidn>=0.4.6 libidn>=1.20nb1 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 png>=1.6.0nb1 libxslt>=1.1.28nb2 curl>=7.52.1nb1 python27>=2.7.1nb2 .

This package requires the following package(s) to run: bash-[0-9]* perl>=5.0 libXp>=1.0.0 libXpm>=3.5.4.2 png>=1.2.4 libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 xmlcatmgr>=2.0beta1 libxml2>=2.6.2 libgcrypt>=1.6.0 libxml2>=2.8.0nb2 curl>=7.12.3 libidn>=0.4.6 libidn>=1.20nb1 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 png>=1.6.0nb1 libxslt>=1.1.28nb2 curl>=7.52.1nb1 python27>=2.7.1nb2 .

This package supports the following build-time options:

x11
Enable X11 support.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:crossfire-server-1.11.0nb21.tgz(NetBSD 7.0)
arm:crossfire-server-1.11.0nb17.tgz(NetBSD 6.1_STABLE)
earm:crossfire-server-1.11.0nb20.tgz(NetBSD 7.0)
earm:crossfire-server-1.11.0nb20.tgz(NetBSD 7.0)
earmv6hf:crossfire-server-1.11.0nb20.tgz(NetBSD 7.0)
earmv7hf:crossfire-server-1.11.0nb20.tgz(NetBSD 7.0)
earmv7hf:crossfire-server-1.11.0nb20.tgz(NetBSD 7.99.21)
i386:crossfire-server-1.11.0nb17.tgz(MirBSD 10)
i386:crossfire-server-1.11.0nb21.tgz(NetBSD 6.0)
i386:crossfire-server-1.11.0nb21.tgz(NetBSD 6.0)
i386:crossfire-server-1.11.0nb22.tgz(NetBSD 6.0)
i386:crossfire-server-1.11.0nb21.tgz(NetBSD 6.1)
i386:crossfire-server-1.11.0nb22.tgz(NetBSD 6.1)
i386:crossfire-server-1.11.0nb23.tgz(NetBSD 7.0)
i386:crossfire-server-1.11.0nb21.tgz(NetBSD 7.0.0_PATCH)
i386:crossfire-server-1.11.0nb21.tgz(NetBSD 7.0)
i386:crossfire-server-1.11.0nb22.tgz(NetBSD 7.0)
powerpc:crossfire-server-1.11.0nb22.tgz(NetBSD 6.0)
powerpc:crossfire-server-1.11.0nb21.tgz(NetBSD 6.0)
powerpc:crossfire-server-1.11.0nb21.tgz(NetBSD 6.0)
powerpc:crossfire-server-1.11.0nb20.tgz(NetBSD 7.0)
powerpc:crossfire-server-1.11.0nb20.tgz(NetBSD 7.0)
sparc64:crossfire-server-1.11.0nb17.tgz(NetBSD 6.1_STABLE)
sparc64:crossfire-server-1.11.0nb20.tgz(NetBSD 7.0)
sparc64:crossfire-server-1.11.0nb20.tgz(NetBSD 7.0)
x86_64:crossfire-server-1.11.0nb21.tgz(NetBSD 6.0)
x86_64:crossfire-server-1.11.0nb21.tgz(NetBSD 6.0)
x86_64:crossfire-server-1.11.0nb22.tgz(NetBSD 6.0)
x86_64:crossfire-server-1.11.0nb21.tgz(NetBSD 6.1)
x86_64:crossfire-server-1.11.0nb22.tgz(NetBSD 6.1)
x86_64:crossfire-server-1.11.0nb23.tgz(NetBSD 7.0)
x86_64:crossfire-server-1.11.0nb21.tgz(NetBSD 7.0.0_PATCH)
x86_64:crossfire-server-1.11.0nb21.tgz(NetBSD 7.0)
x86_64:crossfire-server-1.11.0nb22.tgz(NetBSD 7.0)
x86_64:crossfire-server-1.11.0nb24.tgz(NetBSD 7.0.1_PATCH)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]