Daemon Power

The NetBSD Packages Collection: games/flightgear

Brief description of the package:
The FlightGear Simulator

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://www.flightgear.org/.

Please note that this package has a gnu-gpl-v2 license.

The package is located in the "games/flightgear" directory. The current source version of the package is "flightgear-2018.3.2nb12". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for games/flightgear :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: openal-soft>=1.5.304 cwrappers>=20150314 simgear>=2018.3.0 boost-libs-1.71.* icu>=3.4 python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.0.11 readline>=2.2 readline>=6.0 python37>=3.7.0 icu>=64.1 boost-jam-1.71.* MesaLib>=3.4.2 libelf>=0.8.5 libLLVM>=7.0.1nb2 libLLVM>=4.0.0 libvdpau>=0.3 x11-links>=1.30 osabi-NetBSD-8.0_STABLE xorgproto>=2016.1 libXdamage>=1.0.3 Xfixes>=2.0.0 fixesproto>=3.0.0<5 Xfixes>=2.0.1nb2 Xrandr>=0.99 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xrender>=0.9.0nb1 Xrandr>=1.0.1 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.13 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 xcb-proto>=1.4 libxshmfence>=1.2 xorg-util-macros>=1.17 libdrm>=2.4.15 libva>=2.3.0 Xrandr>=1.0.2nb3 meson-[0-9]* ninja-build-[0-9]* re2c>=0.11.3 py37-setuptools>=0.8 py37-expat-[0-9]* python37>=3.7.4 glu>=3.4.2 MesaLib>=7.11.2 glu>=6.0 osg>=2.8.3 ffmpeg4>=4.0 fontconfig>=2.11.91 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 libass>=0.9.12 fribidi>=0.19.0 fribidi>=0.19.1 harfbuzz>=2.1.1 glib2>=2.4.0 pcre>=3.4nb1 pcre>=8.30nb1 graphite2>=1.2 glib2>=2.34.0 enca>=1.9 fontconfig>=2.13.0 libaom>=1.0.0nb1 nasm>=2.13 asciidoc-[0-9]* docbook-xsl-[0-9]* docbook-xml>=4.2 perl>=5.0 getopt-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 docbook-xml-[0-9]* python27>=2.7.1nb2 libxslt>=1.1.28nb2 xmlto-[0-9]* docbook-xsl>=1.67.0nb1 libaom>=1.0.0 libtheora>=1.0alpha3 libvorbis>=1.0.1 libogg>=1.1 libogg>=1.1.2nb1 libvorbis>=1.1.0nb1 lame>=3.93.1nb2 xvidcore>=1.0.0 x264-devel>=20111207 nasm>=2.13.0 x264-devel>=20180224 libvpx>=1.6.0 yasm-[0-9]* libbluray>=0.8.1 libass>=0.14.0nb2 libtheora>=1.0alpha3nb1 lame>=3.98.2nb1 lame>=3.96.1nb4 xvidcore>=1.1.0nb1 libvpx>=1.6.1 giflib>=5.1.0 png>=1.2.4 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 ffmpeg4>=4.2 png>=1.6.0nb1 tiff>=4.0.3nb5 curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 nghttp2>=1.0.0 nghttp2>=1.39.2nb1 boost-libs>=1.71.0 glu>=7.11.2 osg>=3.4.1nb18 curl>=7.65.3nb3 boost-headers-1.71.* simgear>=2018.2.2nb7 freeglut>=2.2.0 glew>=1.3.4 qt5-qtbase>=5.9.1 pcre2>=10.21 dbus>=0.91 libproxy>=0.2.3 xcb-util>=0.3.9 gperf>=3.0.1 xcb-util-image>=0.3.9 xcb-util-keysyms>=0.3.9 xcb-util-renderutil>=0.3.8nb1 xcb-util-wm>=0.3.9 xcursor>=1.0 xcursor>=1.1.1 Xft2>=2.1 fontconfig>=2.2 Xrender>=0.9.0nb2 Xft2>=2.1nb2 libxkbcommon>=0.4.0 libxcb>=1.10 xkeyboard-config>=1.9 xkbcomp-[0-9]* pcre2>=10.30 libproxy>=0.4.11 xcursor>=1.1.2nb1 Xft2>=2.1.7nb7 libxkbcommon>=0.4.0nb1 qt5-qtquickcontrols2>=5.10.0 qt5-qtdeclarative>=5.9.1 qt5-qtxmlpatterns>=5.9.1 qt5-qtbase>=5.13.1 qt5-qtxmlpatterns>=5.13.1 qt5-qtdeclarative>=5.13.1 qt5-qtsvg>=5.9.1 simgear>=2018.3.2nb9 freeglut>=2.8.1nb1 glew>=2.1.0 qt5-qtquickcontrols2>=5.13.1 qt5-qtsvg>=5.13.1 plib>=1.8.5nb2 plib>=1.8.5nb4 .

This package requires the following package(s) to run: openal-soft>=1.5.304 simgear>=2018.3.0 boost-libs-1.71.* icu>=3.4 python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.0.11 python37>=3.7.0 icu>=64.1 MesaLib>=3.4.2 libelf>=0.8.5 libLLVM>=7.0.1nb2 libLLVM>=4.0.0 libvdpau>=0.3 libXdamage>=1.0.3 Xfixes>=2.0.0 Xfixes>=2.0.1nb2 Xrandr>=0.99 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xrender>=0.9.0nb1 Xrandr>=1.0.1 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 libxshmfence>=1.2 libdrm>=2.4.15 libva>=2.3.0 Xrandr>=1.0.2nb3 glu>=3.4.2 MesaLib>=7.11.2 glu>=6.0 osg>=2.8.3 ffmpeg4>=4.0 fontconfig>=2.11.91 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.1nb2 libass>=0.9.12 fribidi>=0.19.0 fribidi>=0.19.1 harfbuzz>=2.1.1 glib2>=2.4.0 pcre>=3.4nb1 pcre>=8.30nb1 graphite2>=1.2 glib2>=2.34.0 enca>=1.9 fontconfig>=2.13.0 libaom>=1.0.0nb1 libaom>=1.0.0 libtheora>=1.0alpha3 libvorbis>=1.0.1 libogg>=1.1 libogg>=1.1.2nb1 libvorbis>=1.1.0nb1 lame>=3.93.1nb2 xvidcore>=1.0.0 x264-devel>=20111207 x264-devel>=20180224 libvpx>=1.6.0 libbluray>=0.8.1 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 libass>=0.14.0nb2 libtheora>=1.0alpha3nb1 lame>=3.98.2nb1 lame>=3.96.1nb4 xvidcore>=1.1.0nb1 libvpx>=1.6.1 giflib>=5.1.0 png>=1.2.4 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 ffmpeg4>=4.2 png>=1.6.0nb1 tiff>=4.0.3nb5 curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 nghttp2>=1.0.0 nghttp2>=1.39.2nb1 boost-libs>=1.71.0 glu>=7.11.2 osg>=3.4.1nb18 curl>=7.65.3nb3 simgear>=2018.2.2nb7 freeglut>=2.2.0 glew>=1.3.4 qt5-qtbase>=5.9.1 pcre2>=10.21 dbus>=0.91 libproxy>=0.2.3 xcb-util>=0.3.9 xcb-util-image>=0.3.9 xcb-util-keysyms>=0.3.9 xcb-util-renderutil>=0.3.8nb1 xcb-util-wm>=0.3.9 xcursor>=1.0 xcursor>=1.1.1 Xft2>=2.1 fontconfig>=2.2 Xrender>=0.9.0nb2 Xft2>=2.1nb2 libxkbcommon>=0.4.0 libxcb>=1.10 pcre2>=10.30 libproxy>=0.4.11 xcursor>=1.1.2nb1 Xft2>=2.1.7nb7 libxkbcommon>=0.4.0nb1 qt5-qtquickcontrols2>=5.10.0 qt5-qtdeclarative>=5.9.1 qt5-qtxmlpatterns>=5.9.1 qt5-qtbase>=5.13.1 qt5-qtxmlpatterns>=5.13.1 qt5-qtdeclarative>=5.13.1 qt5-qtsvg>=5.9.1 simgear>=2018.3.2nb9 freeglut>=2.8.1nb1 glew>=2.1.0 qt5-qtquickcontrols2>=5.13.1 qt5-qtsvg>=5.13.1 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
earmv6hf:flightgear-2018.3.2nb6.tgz(NetBSD 8.0)
earmv7hf:flightgear-2018.3.2nb6.tgz(NetBSD 8.0)
i386:flightgear-2018.3.2nb6.tgz(NetBSD 8.0)
x86_64:flightgear-2018.3.2nb6.tgz(NetBSD 8.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]