Daemon Power

The NetBSD Packages Collection: graphics/freeglut

Brief description of the package:
Alternative to the OpenGL Utility Toolkit (GLUT) library

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://freeglut.sourceforge.net/.

Please note that this package has a x11 license.

The package is located in the "graphics/freeglut" directory. The current source version of the package is "freeglut-3.2.1nb2". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for graphics/freeglut :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: Xrandr>=0.99 libXrender>=0.9.2 x11-links>=1.32 osabi-NetBSD-9.0_STABLE cwrappers>=20150314 xorgproto>=2016.1 Xrandr>=1.0.1 MesaLib>=3.4.2 libelf>=0.8.5 libLLVM>=7.0.1nb2 python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.3nb1 readline>=2.2 readline>=6.0 python37>=3.7.0 libLLVM>=9.0.0 libvdpau>=0.3 meson-[0-9]* ninja-build>=1.7 re2c>=0.11.3 py37-setuptools-[0-9]* py37-expat-[0-9]* python37>=3.7.9 libXdamage>=1.0.3 Xfixes>=2.0.0 fixesproto>=3.0.0<5 Xfixes>=2.0.1nb2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.14 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.9.10nb2 xcb-proto>=1.4 libxshmfence>=1.2 xorg-util-macros>=1.17 libdrm>=2.4.99 libdrm>=2.4.100 libdrm>=2.4.15 libva>=2.3.0 Xrandr>=1.0.2nb3 glu>=3.4.2 MesaLib>=20.0.1nb1 glu>=6.0 glu>=7.11.2 .

This package requires the following package(s) to run: Xrandr>=0.99 libXrender>=0.9.2 Xrandr>=1.0.1 MesaLib>=3.4.2 libelf>=0.8.5 libLLVM>=7.0.1nb2 libLLVM>=9.0.0 libvdpau>=0.3 python37>=3.7 libffi>=1.20 libuuid>=2.18 libffi>=3.3nb1 python37>=3.7.0 libXdamage>=1.0.3 Xfixes>=2.0.0 Xfixes>=2.0.1nb2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 libxshmfence>=1.2 libdrm>=2.4.99 libdrm>=2.4.100 libdrm>=2.4.15 libva>=2.3.0 Xrandr>=1.0.2nb3 glu>=3.4.2 MesaLib>=20.0.1nb1 glu>=6.0 glu>=7.11.2 .

This package supports the following build-time options:

wayland
Enable support for the Wayland display server protocol.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
aarch64:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
aarch64:freeglut-3.2.1.tgz(NetBSD 9.0)
aarch64:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
aarch64:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
alpha:freeglut-3.0.0nb2.tgz(NetBSD 8.0)
alpha:freeglut-3.2.1.tgz(NetBSD 9.0)
alpha:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
earm:freeglut-3.0.0.tgz(NetBSD 8.0)
earm:freeglut-3.2.1.tgz(NetBSD 9.0)
earm:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
earmv4:freeglut-3.0.0nb2.tgz(NetBSD 8.0)
earmv6hf:freeglut-3.2.1.tgz(NetBSD 8.0)
earmv6hf:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
earmv6hf:freeglut-3.2.1.tgz(NetBSD 9.0)
earmv6hf:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
earmv7hf:freeglut-3.2.1nb2.tgz(NetBSD 8.0)
earmv7hf:freeglut-3.2.1.tgz(NetBSD 8.0)
earmv7hf:freeglut-3.2.1nb2.tgz(NetBSD 8.0)
earmv7hf:freeglut-3.2.1nb2.tgz(NetBSD 8.0)
earmv7hf:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
earmv7hf:freeglut-3.2.1.tgz(NetBSD 9.0)
earmv7hf:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
earmv7hf:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
i386:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
i386:freeglut-3.2.1nb2.tgz(NetBSD 8.0)
i386:freeglut-3.0.0nb2.tgz(NetBSD 8.0)
i386:freeglut-3.2.1.tgz(NetBSD 8.0)
i386:freeglut-3.2.1nb2.tgz(NetBSD 8.0)
i386:freeglut-3.2.1nb2.tgz(NetBSD 8.0)
i386:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
i386:freeglut-3.2.1.tgz(NetBSD 9.0)
i386:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
i386:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
i386:freeglut-2.2.0nb3.tgz(QNX 6.5.0)
m68k:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
mips64eb:freeglut-3.2.1.tgz(NetBSD 9.0)
powerpc:freeglut-3.2.1nb2.tgz(NetBSD 8.0)
powerpc:freeglut-3.2.1.tgz(NetBSD 8.0)
powerpc:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
powerpc:freeglut-3.2.1.tgz(NetBSD 9.0)
sparc64:freeglut-3.0.0.tgz(NetBSD 7.1)
sparc64:freeglut-3.0.0nb2.tgz(NetBSD 8.0)
sparc64:freeglut-3.2.1.tgz(NetBSD 9.0)
sparc64:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
sparc64:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
sparc:freeglut-3.2.1.tgz(NetBSD 8.0)
sparc:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
x86_64:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
x86_64:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
x86_64:freeglut-3.2.1nb2.tgz(NetBSD 8.0)
x86_64:freeglut-3.0.0nb2.tgz(NetBSD 8.0)
x86_64:freeglut-3.2.1.tgz(NetBSD 8.0)
x86_64:freeglut-3.2.1nb2.tgz(NetBSD 8.0)
x86_64:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
x86_64:freeglut-3.2.1.tgz(NetBSD 9.0)
x86_64:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
x86_64:freeglut-3.2.1nb2.tgz(NetBSD 9.0)
x86_64:freeglut-3.2.1nb2.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]