Daemon Power

The NetBSD Packages Collection: graphics/py-matplotlib-tk

Brief description of the package:
Tk frontend for matplotlib

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://matplotlib.org/.

The package is located in the "graphics/py-matplotlib-tk" directory. The current source version of the package is "py27-matplotlib-tk-2.2.2". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for graphics/py-matplotlib-tk :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: py27-matplotlib-[0-9]* py27-cairo-[0-9]* py27-setuptools>=0.8 py27-expat-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 cwrappers>=20150314 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 cairo>=1.13.1 MesaLib>=3.4.2 libxcb>=1.6 libXdmcp>=0.99 xorgproto>=2016.1 libXau>=1.0 xcb-proto>=1.13 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 xcb-proto>=1.4 py27-mako-[0-9]* x11-links>=1.12 osabi-NetBSD-8.0_RC1 Xrender>=0.2 Xrender>=0.8.2 lzo>=2.01 fontconfig>=2.2.95 libuuid>=2.18 freetype2>=2.8.1 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 gperf-[0-9]* fontconfig>=2.10.93 fontconfig>=2.1nb2 freetype2>=2.1.9 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 MesaLib>=7.11.2 Xrender>=0.9.0nb1 fontconfig>=2.13.0 png>=1.6.0nb1 cairo>=1.0.0nb2 cairo>=1.14.12nb1 py27-cycler>=0.10 py27-six-[0-9]* py27-dateutil>=2.1 py27-setuptools_scm-[0-9]* py27-kiwisolver>=1.0.1 py27-pytz>=2008b py27-pyparsing>=2.2.0 py27-six>=1.10 py27-backports.functools_lru_cache-[0-9]* py27-backports-[0-9]* py27-test>=2.8 py27-atomicwrites>=1.0 py27-attrs>=17.4.0 py27-more-itertools>=4.0.0 py27-six>=1.0.0 py27-pluggy>=0.5 py27-py>=1.5.0 py27-six>=1.10.0 py27-funcsigs-[0-9]* py27-unittest2-[0-9]* py27-six>=1.4 py27-argparse-[0-9]* py27-traceback2-[0-9]* py27-pbr-[0-9]* py27-pip-[0-9]* py27-linecache2-[0-9]* py27-subprocess32-[0-9]* py27-numpy>=1.0 g95>=0.91 py27-cython>=0.12.1 blas>=1.0nb2 libtool-fortran>=2.4.2nb9 lapack>=3.1.1 blas>=1.0nb3 py27-nose-[0-9]* py27-Tk-[0-9]* tcl>=8.5.7 sqlite3>=3.21.0 sqlite3>=3.0.8 sqlite3>=3.23.1nb1 tk>=8.5.7 Xft2>=2.1 fontconfig>=2.2 Xrender>=0.9.0nb2 Xft2>=2.1nb2 Xft2>=2.1.7nb7 tcl>=8.6.1nb1 tk>=8.6.8nb1 .

This package requires the following package(s) to run: py27-matplotlib-[0-9]* py27-cairo-[0-9]* py27-setuptools>=0.8 py27-expat-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 python27>=2.7.1nb2 cairo>=1.13.1 MesaLib>=3.4.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 Xrender>=0.2 Xrender>=0.8.2 lzo>=2.01 fontconfig>=2.2.95 libuuid>=2.18 freetype2>=2.8.1 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.10.93 fontconfig>=2.1nb2 freetype2>=2.1.9 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 MesaLib>=7.11.2 Xrender>=0.9.0nb1 fontconfig>=2.13.0 png>=1.6.0nb1 cairo>=1.0.0nb2 cairo>=1.14.12nb1 py27-cycler>=0.10 py27-six-[0-9]* py27-dateutil>=2.1 py27-kiwisolver>=1.0.1 py27-pytz>=2008b py27-pyparsing>=2.2.0 py27-six>=1.10 py27-backports.functools_lru_cache-[0-9]* py27-backports-[0-9]* py27-subprocess32-[0-9]* py27-numpy>=1.0 g95>=0.91 py27-cython>=0.12.1 blas>=1.0nb2 lapack>=3.1.1 blas>=1.0nb3 py27-Tk-[0-9]* tcl>=8.5.7 sqlite3>=3.21.0 sqlite3>=3.0.8 sqlite3>=3.23.1nb1 tk>=8.5.7 Xft2>=2.1 fontconfig>=2.2 Xrender>=0.9.0nb2 Xft2>=2.1nb2 Xft2>=2.1.7nb7 tcl>=8.6.1nb1 tk>=8.6.8nb1 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
i386:py27-matplotlib-tk-1.5.2.tgz(NetBSD 6.0)
i386:py34-matplotlib-tk-1.5.2.tgz(NetBSD 6.0)
i386:py35-matplotlib-tk-1.5.2.tgz(NetBSD 6.0)
i386:py27-matplotlib-tk-1.5.2.tgz(NetBSD 6.0)
i386:py34-matplotlib-tk-1.5.2.tgz(NetBSD 6.0)
i386:py35-matplotlib-tk-1.5.2.tgz(NetBSD 6.0)
i386:py27-matplotlib-tk-1.5.2.tgz(NetBSD 6.0)
i386:py34-matplotlib-tk-1.5.2.tgz(NetBSD 6.0)
i386:py35-matplotlib-tk-1.5.2.tgz(NetBSD 6.0)
i386:py36-matplotlib-tk-1.5.2.tgz(NetBSD 6.0)
i386:py27-matplotlib-tk-2.0.2.tgz(NetBSD 6.0)
i386:py34-matplotlib-tk-2.0.2.tgz(NetBSD 6.0)
i386:py35-matplotlib-tk-2.0.2.tgz(NetBSD 6.0)
i386:py36-matplotlib-tk-2.0.2.tgz(NetBSD 6.0)
i386:py27-matplotlib-tk-2.1.1.tgz(NetBSD 6.0)
i386:py34-matplotlib-tk-2.1.1.tgz(NetBSD 6.0)
i386:py35-matplotlib-tk-2.1.1.tgz(NetBSD 6.0)
i386:py36-matplotlib-tk-2.1.1.tgz(NetBSD 6.0)
i386:py27-matplotlib-tk-1.5.2.tgz(NetBSD 6.1)
i386:py34-matplotlib-tk-1.5.2.tgz(NetBSD 6.1)
i386:py35-matplotlib-tk-1.5.2.tgz(NetBSD 6.1)
i386:py27-matplotlib-tk-1.5.2.tgz(NetBSD 6.1)
i386:py34-matplotlib-tk-1.5.2.tgz(NetBSD 6.1)
i386:py35-matplotlib-tk-1.5.2.tgz(NetBSD 6.1)
i386:py27-matplotlib-tk-1.5.2.tgz(NetBSD 6.1)
i386:py34-matplotlib-tk-1.5.2.tgz(NetBSD 6.1)
i386:py35-matplotlib-tk-1.5.2.tgz(NetBSD 6.1)
i386:py36-matplotlib-tk-1.5.2.tgz(NetBSD 6.1)
i386:py27-matplotlib-tk-2.0.2.tgz(NetBSD 6.1)
i386:py34-matplotlib-tk-2.0.2.tgz(NetBSD 6.1)
i386:py35-matplotlib-tk-2.0.2.tgz(NetBSD 6.1)
i386:py36-matplotlib-tk-2.0.2.tgz(NetBSD 6.1)
i386:py27-matplotlib-tk-2.0.2.tgz(NetBSD 6.1)
i386:py34-matplotlib-tk-2.0.2.tgz(NetBSD 6.1)
i386:py35-matplotlib-tk-2.0.2.tgz(NetBSD 6.1)
i386:py36-matplotlib-tk-2.0.2.tgz(NetBSD 6.1)
i386:py27-matplotlib-tk-2.1.2nb1.tgz(NetBSD 7.0)
i386:py34-matplotlib-tk-2.1.2nb1.tgz(NetBSD 7.0)
i386:py35-matplotlib-tk-2.1.2nb1.tgz(NetBSD 7.0)
i386:py36-matplotlib-tk-2.1.2nb1.tgz(NetBSD 7.0)
i386:py27-matplotlib-tk-1.5.2.tgz(NetBSD 7.0)
i386:py34-matplotlib-tk-1.5.2.tgz(NetBSD 7.0)
i386:py35-matplotlib-tk-1.5.2.tgz(NetBSD 7.0)
i386:py36-matplotlib-tk-1.5.2.tgz(NetBSD 7.0)
i386:py27-matplotlib-tk-2.0.2.tgz(NetBSD 7.0)
i386:py34-matplotlib-tk-2.0.2.tgz(NetBSD 7.0)
i386:py35-matplotlib-tk-2.0.2.tgz(NetBSD 7.0)
i386:py36-matplotlib-tk-2.0.2.tgz(NetBSD 7.0)
i386:py27-matplotlib-tk-2.1.1.tgz(NetBSD 7.0)
i386:py34-matplotlib-tk-2.1.1.tgz(NetBSD 7.0)
i386:py35-matplotlib-tk-2.1.1.tgz(NetBSD 7.0)
i386:py36-matplotlib-tk-2.1.1.tgz(NetBSD 7.0)
i386:py27-matplotlib-tk-2.1.2nb1.tgz(NetBSD 7.1)
i386:py34-matplotlib-tk-2.1.2nb1.tgz(NetBSD 7.1)
i386:py35-matplotlib-tk-2.1.2nb1.tgz(NetBSD 7.1)
i386:py36-matplotlib-tk-2.1.2nb1.tgz(NetBSD 7.1)
i386:py27-matplotlib-tk-2.1.1.tgz(NetBSD 7.1)
i386:py34-matplotlib-tk-2.1.1.tgz(NetBSD 7.1)
i386:py35-matplotlib-tk-2.1.1.tgz(NetBSD 7.1)
i386:py36-matplotlib-tk-2.1.1.tgz(NetBSD 7.1)
i386:py27-matplotlib-tk-2.1.2nb1.tgz(NetBSD 8.0)
i386:py34-matplotlib-tk-2.1.2nb1.tgz(NetBSD 8.0)
i386:py35-matplotlib-tk-2.1.2nb1.tgz(NetBSD 8.0)
i386:py36-matplotlib-tk-2.1.2nb1.tgz(NetBSD 8.0)
i386:py27-matplotlib-tk-2.1.1.tgz(NetBSD 8.0)
i386:py34-matplotlib-tk-2.1.1.tgz(NetBSD 8.0)
i386:py35-matplotlib-tk-2.1.1.tgz(NetBSD 8.0)
i386:py36-matplotlib-tk-2.1.1.tgz(NetBSD 8.0)
powerpc:py27-matplotlib-tk-2.1.1.tgz(NetBSD 6.1)
powerpc:py34-matplotlib-tk-2.1.1.tgz(NetBSD 6.1)
powerpc:py35-matplotlib-tk-2.1.1.tgz(NetBSD 6.1)
powerpc:py36-matplotlib-tk-2.1.1.tgz(NetBSD 6.1)
powerpc:py27-matplotlib-tk-2.1.2nb1.tgz(NetBSD 8.0)
powerpc:py34-matplotlib-tk-2.1.2nb1.tgz(NetBSD 8.0)
powerpc:py35-matplotlib-tk-2.1.2nb1.tgz(NetBSD 8.0)
powerpc:py36-matplotlib-tk-2.1.2nb1.tgz(NetBSD 8.0)
sparc64:py27-matplotlib-tk-1.3.1.tgz(NetBSD 7.0)
sparc64:py27-matplotlib-tk-2.1.1.tgz(NetBSD 8.0)
sparc64:py34-matplotlib-tk-2.1.1.tgz(NetBSD 8.0)
sparc64:py35-matplotlib-tk-2.1.1.tgz(NetBSD 8.0)
sparc64:py36-matplotlib-tk-2.1.1.tgz(NetBSD 8.0)
x86_64:py27-matplotlib-tk-2.1.1.tgz(NetBSD 6.0)
x86_64:py34-matplotlib-tk-2.1.1.tgz(NetBSD 6.0)
x86_64:py35-matplotlib-tk-2.1.1.tgz(NetBSD 6.0)
x86_64:py36-matplotlib-tk-2.1.1.tgz(NetBSD 6.0)
x86_64:py27-matplotlib-tk-2.1.1.tgz(NetBSD 6.1)
x86_64:py34-matplotlib-tk-2.1.1.tgz(NetBSD 6.1)
x86_64:py35-matplotlib-tk-2.1.1.tgz(NetBSD 6.1)
x86_64:py36-matplotlib-tk-2.1.1.tgz(NetBSD 6.1)
x86_64:py27-matplotlib-tk-2.1.2nb1.tgz(NetBSD 7.0)
x86_64:py34-matplotlib-tk-2.1.2nb1.tgz(NetBSD 7.0)
x86_64:py35-matplotlib-tk-2.1.2nb1.tgz(NetBSD 7.0)
x86_64:py36-matplotlib-tk-2.1.2nb1.tgz(NetBSD 7.0)
x86_64:py27-matplotlib-tk-2.0.2.tgz(NetBSD 7.0)
x86_64:py34-matplotlib-tk-2.0.2.tgz(NetBSD 7.0)
x86_64:py35-matplotlib-tk-2.0.2.tgz(NetBSD 7.0)
x86_64:py36-matplotlib-tk-2.0.2.tgz(NetBSD 7.0)
x86_64:py27-matplotlib-tk-2.1.1.tgz(NetBSD 7.0)
x86_64:py34-matplotlib-tk-2.1.1.tgz(NetBSD 7.0)
x86_64:py35-matplotlib-tk-2.1.1.tgz(NetBSD 7.0)
x86_64:py36-matplotlib-tk-2.1.1.tgz(NetBSD 7.0)
x86_64:py27-matplotlib-tk-2.0.2.tgz(NetBSD 7.0.1_PATCH)
x86_64:py34-matplotlib-tk-2.0.2.tgz(NetBSD 7.0.1_PATCH)
x86_64:py35-matplotlib-tk-2.0.2.tgz(NetBSD 7.0.1_PATCH)
x86_64:py36-matplotlib-tk-2.0.2.tgz(NetBSD 7.0.1_PATCH)
x86_64:py27-matplotlib-tk-2.1.2nb1.tgz(NetBSD 7.1)
x86_64:py34-matplotlib-tk-2.1.2nb1.tgz(NetBSD 7.1)
x86_64:py35-matplotlib-tk-2.1.2nb1.tgz(NetBSD 7.1)
x86_64:py36-matplotlib-tk-2.1.2nb1.tgz(NetBSD 7.1)
x86_64:py27-matplotlib-tk-2.1.2.tgz(NetBSD 7.1.1)
x86_64:py34-matplotlib-tk-2.1.2.tgz(NetBSD 7.1.1)
x86_64:py35-matplotlib-tk-2.1.2.tgz(NetBSD 7.1.1)
x86_64:py36-matplotlib-tk-2.1.2.tgz(NetBSD 7.1.1)
x86_64:py27-matplotlib-tk-2.1.1.tgz(NetBSD 7.1)
x86_64:py34-matplotlib-tk-2.1.1.tgz(NetBSD 7.1)
x86_64:py35-matplotlib-tk-2.1.1.tgz(NetBSD 7.1)
x86_64:py36-matplotlib-tk-2.1.1.tgz(NetBSD 7.1)
x86_64:py27-matplotlib-tk-2.1.2nb1.tgz(NetBSD 8.0)
x86_64:py34-matplotlib-tk-2.1.2nb1.tgz(NetBSD 8.0)
x86_64:py35-matplotlib-tk-2.1.2nb1.tgz(NetBSD 8.0)
x86_64:py36-matplotlib-tk-2.1.2nb1.tgz(NetBSD 8.0)
x86_64:py27-matplotlib-tk-2.0.2.tgz(NetBSD 8.99.1)
x86_64:py34-matplotlib-tk-2.0.2.tgz(NetBSD 8.99.1)
x86_64:py35-matplotlib-tk-2.0.2.tgz(NetBSD 8.99.1)
x86_64:py36-matplotlib-tk-2.0.2.tgz(NetBSD 8.99.1)
x86_64:py27-matplotlib-tk-2.0.2.tgz(NetBSD 8.0)
x86_64:py34-matplotlib-tk-2.0.2.tgz(NetBSD 8.0)
x86_64:py35-matplotlib-tk-2.0.2.tgz(NetBSD 8.0)
x86_64:py36-matplotlib-tk-2.0.2.tgz(NetBSD 8.0)
x86_64:py27-matplotlib-tk-2.1.1.tgz(NetBSD 8.0)
x86_64:py34-matplotlib-tk-2.1.1.tgz(NetBSD 8.0)
x86_64:py35-matplotlib-tk-2.1.1.tgz(NetBSD 8.0)
x86_64:py36-matplotlib-tk-2.1.1.tgz(NetBSD 8.0)
x86_64:py27-matplotlib-tk-2.0.2.tgz(NetBSD 8.99.1)
x86_64:py34-matplotlib-tk-2.0.2.tgz(NetBSD 8.99.1)
x86_64:py35-matplotlib-tk-2.0.2.tgz(NetBSD 8.99.1)
x86_64:py36-matplotlib-tk-2.0.2.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]