graphics/py-matplotlib - The NetBSD Packages Collection

Matlab-style plotting package for Python

matplotlib is a pure python plotting library designed to bring
publication quality plotting to python with a syntax familiar to
matlab users.  A lot progress towards this goal has been made since
the first release of matplotlib, the library does produce high quality
2D plots.  All of the plotting commands can be accessed either via a
functional interface familiar to matlab users or an object oriented
interface familiar to python users, and several high resolution output
formats are supported.

Tutorial: https://matplotlib.org/users/tutorials.html

Build dependencies

pkgtools/cwrappers devel/pkgconf

Runtime dependencies

graphics/py-Pillow graphics/py-cairo graphics/py-cycler time/py-dateutil math/py-kiwisolver devel/py-pyparsing security/py-certifi devel/py-setuptools graphics/freetype2 graphics/freetype2 graphics/png lang/python38 lang/python38 math/py-numpy math/qhull graphics/png math/py-numpy math/qhull

Available binary packages

aarch64:py36-matplotlib-3.2.2.tgz(NetBSD 9.0)
aarch64:py37-matplotlib-3.2.2.tgz(NetBSD 9.0)
aarch64:py38-matplotlib-3.2.2.tgz(NetBSD 9.0)
aarch64:py36-matplotlib-3.2.2.tgz(NetBSD 9.0)
aarch64:py37-matplotlib-3.2.2.tgz(NetBSD 9.0)
aarch64:py38-matplotlib-3.2.2.tgz(NetBSD 9.0)
aarch64:py36-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
aarch64:py37-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
aarch64:py38-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
aarch64:py39-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
i386:py36-matplotlib-3.2.2.tgz(NetBSD 8.0)
i386:py37-matplotlib-3.2.2.tgz(NetBSD 8.0)
i386:py38-matplotlib-3.2.2.tgz(NetBSD 8.0)
i386:py36-matplotlib-3.2.2.tgz(NetBSD 8.0)
i386:py37-matplotlib-3.2.2.tgz(NetBSD 8.0)
i386:py38-matplotlib-3.2.2.tgz(NetBSD 8.0)
i386:py36-matplotlib-3.2.2nb1.tgz(NetBSD 8.0)
i386:py37-matplotlib-3.2.2nb1.tgz(NetBSD 8.0)
i386:py38-matplotlib-3.2.2nb1.tgz(NetBSD 8.0)
i386:py39-matplotlib-3.2.2nb1.tgz(NetBSD 8.0)
i386:py36-matplotlib-3.2.2.tgz(NetBSD 9.0)
i386:py37-matplotlib-3.2.2.tgz(NetBSD 9.0)
i386:py38-matplotlib-3.2.2.tgz(NetBSD 9.0)
i386:py36-matplotlib-3.2.2.tgz(NetBSD 9.0)
i386:py37-matplotlib-3.2.2.tgz(NetBSD 9.0)
i386:py38-matplotlib-3.2.2.tgz(NetBSD 9.0)
i386:py36-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
i386:py37-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
i386:py38-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
i386:py39-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
powerpc:py36-matplotlib-3.2.2.tgz(NetBSD 8.0)
powerpc:py37-matplotlib-3.2.2.tgz(NetBSD 8.0)
powerpc:py38-matplotlib-3.2.2.tgz(NetBSD 8.0)
powerpc:py36-matplotlib-3.2.2nb1.tgz(NetBSD 8.0)
powerpc:py37-matplotlib-3.2.2nb1.tgz(NetBSD 8.0)
powerpc:py38-matplotlib-3.2.2nb1.tgz(NetBSD 8.0)
powerpc:py39-matplotlib-3.2.2nb1.tgz(NetBSD 8.0)
powerpc:py36-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
powerpc:py37-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
powerpc:py38-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
powerpc:py39-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
powerpc:py36-matplotlib-3.2.2.tgz(NetBSD 9.0)
powerpc:py37-matplotlib-3.2.2.tgz(NetBSD 9.0)
powerpc:py38-matplotlib-3.2.2.tgz(NetBSD 9.0)
powerpc:py36-matplotlib-3.2.2.tgz(NetBSD 9.0)
powerpc:py37-matplotlib-3.2.2.tgz(NetBSD 9.0)
powerpc:py38-matplotlib-3.2.2.tgz(NetBSD 9.0)
x86_64:py36-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
x86_64:py37-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
x86_64:py38-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
x86_64:py39-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
x86_64:py36-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
x86_64:py37-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
x86_64:py38-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
x86_64:py39-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
x86_64:py36-matplotlib-3.3.3nb2.tgz(NetBSD 9.0)
x86_64:py37-matplotlib-3.3.3nb2.tgz(NetBSD 9.0)
x86_64:py38-matplotlib-3.3.3nb2.tgz(NetBSD 9.0)
x86_64:py39-matplotlib-3.3.3nb2.tgz(NetBSD 9.0)
x86_64:py36-matplotlib-3.2.2.tgz(NetBSD 9.0)
x86_64:py37-matplotlib-3.2.2.tgz(NetBSD 9.0)
x86_64:py38-matplotlib-3.2.2.tgz(NetBSD 9.0)
x86_64:py36-matplotlib-3.2.2.tgz(NetBSD 8.0)
x86_64:py37-matplotlib-3.2.2.tgz(NetBSD 8.0)
x86_64:py38-matplotlib-3.2.2.tgz(NetBSD 8.0)
x86_64:py36-matplotlib-3.2.2.tgz(NetBSD 8.0)
x86_64:py37-matplotlib-3.2.2.tgz(NetBSD 8.0)
x86_64:py38-matplotlib-3.2.2.tgz(NetBSD 8.0)
x86_64:py36-matplotlib-3.2.2nb1.tgz(NetBSD 8.0)
x86_64:py37-matplotlib-3.2.2nb1.tgz(NetBSD 8.0)
x86_64:py38-matplotlib-3.2.2nb1.tgz(NetBSD 8.0)
x86_64:py39-matplotlib-3.2.2nb1.tgz(NetBSD 8.0)
x86_64:py36-matplotlib-3.2.2.tgz(NetBSD 9.0)
x86_64:py37-matplotlib-3.2.2.tgz(NetBSD 9.0)
x86_64:py38-matplotlib-3.2.2.tgz(NetBSD 9.0)
x86_64:py36-matplotlib-3.2.2.tgz(NetBSD 9.0)
x86_64:py37-matplotlib-3.2.2.tgz(NetBSD 9.0)
x86_64:py38-matplotlib-3.2.2.tgz(NetBSD 9.0)
x86_64:py36-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
x86_64:py37-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
x86_64:py38-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
x86_64:py39-matplotlib-3.2.2nb1.tgz(NetBSD 9.0)
x86_64:py36-matplotlib-3.3.3nb2.tgz(NetBSD 9.0)
x86_64:py37-matplotlib-3.3.3nb2.tgz(NetBSD 9.0)
x86_64:py38-matplotlib-3.3.3nb2.tgz(NetBSD 9.0)
x86_64:py39-matplotlib-3.3.3nb2.tgz(NetBSD 9.0)

Binary packages can be installed with pkgin or pkg_add(1). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

(none)

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.


[ Go up one level | Go to top of packages tree | List all packages ]