Daemon Power

The NetBSD Packages Collection: lang/ruby

Brief description of the package:
Wrapper package for Ruby programming language

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://www.ruby-lang.org/en/.

The package is located in the "lang/ruby" directory. The current source version of the package is "ruby-2.3.5". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for lang/ruby :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ruby23-base>=2.3.5 libyaml>=0.1.1 cwrappers>=20150314 libyaml>=0.1.4 .

This package requires the following package(s) to run: ruby23-base>=2.3.5 libyaml>=0.1.1 libyaml>=0.1.4 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:ruby-1.8.7.374.tgz(NetBSD 7.0)
alpha:ruby-2.1.8.tgz(NetBSD 7.0)
alpha:ruby-2.2.4.tgz(NetBSD 7.0)
alpha:ruby-2.3.0.tgz(NetBSD 7.0)
alpha:ruby-1.8.7.374.tgz(NetBSD 7.0)
alpha:ruby-1.9.3p551.tgz(NetBSD 7.0)
alpha:ruby-2.0.0p647.tgz(NetBSD 7.0)
alpha:ruby-2.1.7.tgz(NetBSD 7.0)
alpha:ruby-2.2.3.tgz(NetBSD 7.0)
alpha:ruby-1.8.7.374.tgz(NetBSD 7.0)
alpha:ruby-2.0.0p648.tgz(NetBSD 7.0)
alpha:ruby-2.1.8.tgz(NetBSD 7.0)
alpha:ruby-2.2.4.tgz(NetBSD 7.0)
alpha:ruby-2.2.7.tgz(NetBSD 8.0)
alpha:ruby-2.3.4.tgz(NetBSD 8.0)
alpha:ruby-2.4.1.tgz(NetBSD 8.0)
arm:ruby-2.0.0p451.tgz(NetBSD 6.1_STABLE)
earm:ruby-1.8.7.374.tgz(NetBSD 7.0)
earm:ruby-2.0.0p648.tgz(NetBSD 7.0)
earm:ruby-2.2.4.tgz(NetBSD 7.0)
earm:ruby-1.8.7.374.tgz(NetBSD 7.0)
earm:ruby-2.0.0p647.tgz(NetBSD 7.0)
earm:ruby-2.1.7.tgz(NetBSD 7.0)
earm:ruby-2.2.3.tgz(NetBSD 7.0)
earmv6hf:ruby-1.8.7.374.tgz(NetBSD 7.0)
earmv6hf:ruby-1.9.3p551.tgz(NetBSD 7.0)
earmv6hf:ruby-2.0.0p643.tgz(NetBSD 7.0)
earmv6hf:ruby-2.1.5.tgz(NetBSD 7.0)
earmv6hf:ruby-2.2.1.tgz(NetBSD 7.0)
earmv6hf:ruby-1.9.3p551.tgz(NetBSD 7.0)
earmv6hf:ruby-2.0.0p645.tgz(NetBSD 7.0)
earmv6hf:ruby-2.1.6.tgz(NetBSD 7.0)
earmv6hf:ruby-2.2.2.tgz(NetBSD 7.0)
earmv6hf:ruby-1.8.7.374.tgz(NetBSD 7.0)
earmv6hf:ruby-2.0.0p647.tgz(NetBSD 7.0)
earmv6hf:ruby-2.1.7.tgz(NetBSD 7.0)
earmv6hf:ruby-2.2.3.tgz(NetBSD 7.0)
earmv7hf:ruby-1.8.7.374.tgz(NetBSD 7.0)
earmv7hf:ruby-2.0.0p648.tgz(NetBSD 7.0)
earmv7hf:ruby-2.1.8.tgz(NetBSD 7.0)
earmv7hf:ruby-2.2.4.tgz(NetBSD 7.0)
earmv7hf:ruby-1.8.7.374.tgz(NetBSD 7.0)
earmv7hf:ruby-1.9.3p551.tgz(NetBSD 7.0)
earmv7hf:ruby-2.0.0p647.tgz(NetBSD 7.0)
earmv7hf:ruby-2.1.7.tgz(NetBSD 7.0)
earmv7hf:ruby-2.2.3.tgz(NetBSD 7.0)
earmv7hf:ruby-2.2.7.tgz(NetBSD 8.0_BETA)
earmv7hf:ruby-2.3.4.tgz(NetBSD 8.0_BETA)
i386:ruby-1.8.7.374.tgz(MirBSD 10)
i386:ruby-1.9.3p545.tgz(MirBSD 10)
i386:ruby-2.0.0p451.tgz(MirBSD 10)
i386:ruby-2.1.1.tgz(MirBSD 10)
i386:ruby-2.2.8.tgz(NetBSD 6.0)
i386:ruby-2.3.5.tgz(NetBSD 6.0)
i386:ruby-2.4.2.tgz(NetBSD 6.0)
i386:ruby-1.8.7.374.tgz(NetBSD 6.0)
i386:ruby-2.1.10.tgz(NetBSD 6.0)
i386:ruby-2.2.5.tgz(NetBSD 6.0)
i386:ruby-2.3.1.tgz(NetBSD 6.0)
i386:ruby-1.8.7.374.tgz(NetBSD 6.0)
i386:ruby-2.1.10.tgz(NetBSD 6.0)
i386:ruby-2.2.6.tgz(NetBSD 6.0)
i386:ruby-2.3.3.tgz(NetBSD 6.0)
i386:ruby-1.8.7.374.tgz(NetBSD 6.0)
i386:ruby-2.1.10.tgz(NetBSD 6.0)
i386:ruby-2.2.6.tgz(NetBSD 6.0)
i386:ruby-2.3.3.tgz(NetBSD 6.0)
i386:ruby-2.2.7.tgz(NetBSD 6.0)
i386:ruby-2.3.4.tgz(NetBSD 6.0)
i386:ruby-2.4.1.tgz(NetBSD 6.0)
i386:ruby-2.2.8.tgz(NetBSD 6.1)
i386:ruby-2.3.5.tgz(NetBSD 6.1)
i386:ruby-2.4.2.tgz(NetBSD 6.1)
i386:ruby-1.8.7.374.tgz(NetBSD 6.1)
i386:ruby-2.1.10.tgz(NetBSD 6.1)
i386:ruby-2.2.5.tgz(NetBSD 6.1)
i386:ruby-2.3.1.tgz(NetBSD 6.1)
i386:ruby-1.8.7.374.tgz(NetBSD 6.1)
i386:ruby-2.1.10.tgz(NetBSD 6.1)
i386:ruby-2.2.6.tgz(NetBSD 6.1)
i386:ruby-2.3.3.tgz(NetBSD 6.1)
i386:ruby-1.8.7.374.tgz(NetBSD 6.1)
i386:ruby-2.1.10.tgz(NetBSD 6.1)
i386:ruby-2.2.6.tgz(NetBSD 6.1)
i386:ruby-2.3.3.tgz(NetBSD 6.1)
i386:ruby-2.2.7.tgz(NetBSD 6.1)
i386:ruby-2.3.4.tgz(NetBSD 6.1)
i386:ruby-2.4.1.tgz(NetBSD 6.1)
i386:ruby-2.2.8.tgz(NetBSD 7.0)
i386:ruby-2.3.5.tgz(NetBSD 7.0)
i386:ruby-2.4.2.tgz(NetBSD 7.0)
i386:ruby-1.8.7.374.tgz(NetBSD 7.0)
i386:ruby-2.1.10.tgz(NetBSD 7.0)
i386:ruby-2.2.5.tgz(NetBSD 7.0)
i386:ruby-2.3.1.tgz(NetBSD 7.0)
i386:ruby-1.8.7.374.tgz(NetBSD 7.0)
i386:ruby-2.1.10.tgz(NetBSD 7.0)
i386:ruby-2.2.6.tgz(NetBSD 7.0)
i386:ruby-2.3.3.tgz(NetBSD 7.0)
i386:ruby-1.8.7.374.tgz(NetBSD 7.0)
i386:ruby-2.1.10.tgz(NetBSD 7.0)
i386:ruby-2.2.6.tgz(NetBSD 7.0)
i386:ruby-2.3.3.tgz(NetBSD 7.0)
i386:ruby-2.2.7.tgz(NetBSD 7.0)
i386:ruby-2.3.4.tgz(NetBSD 7.0)
i386:ruby-2.4.1.tgz(NetBSD 7.0)
i386:ruby-1.8.7.352nb1.tgz(QNX 6.5.0)
i386:ruby-1.9.2pl290nb1.tgz(QNX 6.5.0)
m68k:ruby-2.2.4.tgz(NetBSD 7.0)
powerpc:ruby-1.8.7.374.tgz(NetBSD 6.0)
powerpc:ruby-2.4.1.tgz(NetBSD 6.1)
powerpc:ruby-1.8.7.374.tgz(NetBSD 7.0)
powerpc:ruby-2.0.0p648.tgz(NetBSD 7.0)
powerpc:ruby-2.1.8.tgz(NetBSD 7.0)
powerpc:ruby-2.2.4.tgz(NetBSD 7.0)
powerpc:ruby-2.2.7.tgz(NetBSD 7.1)
powerpc:ruby-2.3.4.tgz(NetBSD 7.1)
powerpc:ruby-2.4.1.tgz(NetBSD 7.1)
powerpc:ruby-2.2.8.tgz(NetBSD 7.1)
powerpc:ruby-2.3.5.tgz(NetBSD 7.1)
powerpc:ruby-2.4.2.tgz(NetBSD 7.1)
powerpc:ruby-2.2.7.tgz(NetBSD 8.0)
powerpc:ruby-2.3.4.tgz(NetBSD 8.0)
powerpc:ruby-2.4.1.tgz(NetBSD 8.0)
sparc64:ruby-1.8.7.374.tgz(NetBSD 7.0)
sparc64:ruby-1.9.3p551.tgz(NetBSD 7.0)
sparc64:ruby-2.0.0p645.tgz(NetBSD 7.0)
sparc64:ruby-2.1.6.tgz(NetBSD 7.0)
sparc64:ruby-2.2.2.tgz(NetBSD 7.0)
sparc:ruby-1.8.7.374.tgz(NetBSD 5.1)
sparc:ruby-1.9.3p551.tgz(NetBSD 5.1)
sparc:ruby-1.8.7.374.tgz(NetBSD 5.1)
sparc:ruby-1.9.3p551.tgz(NetBSD 5.1)
x86_64:ruby-2.2.8.tgz(NetBSD 6.0)
x86_64:ruby-2.3.5.tgz(NetBSD 6.0)
x86_64:ruby-2.4.2.tgz(NetBSD 6.0)
x86_64:ruby-1.8.7.374.tgz(NetBSD 6.0)
x86_64:ruby-2.1.10.tgz(NetBSD 6.0)
x86_64:ruby-2.2.5.tgz(NetBSD 6.0)
x86_64:ruby-2.3.1.tgz(NetBSD 6.0)
x86_64:ruby-1.8.7.374.tgz(NetBSD 6.0)
x86_64:ruby-2.1.10.tgz(NetBSD 6.0)
x86_64:ruby-2.2.6.tgz(NetBSD 6.0)
x86_64:ruby-2.3.3.tgz(NetBSD 6.0)
x86_64:ruby-1.8.7.374.tgz(NetBSD 6.0)
x86_64:ruby-2.1.10.tgz(NetBSD 6.0)
x86_64:ruby-2.2.6.tgz(NetBSD 6.0)
x86_64:ruby-2.3.3.tgz(NetBSD 6.0)
x86_64:ruby-2.2.7.tgz(NetBSD 6.0)
x86_64:ruby-2.3.4.tgz(NetBSD 6.0)
x86_64:ruby-2.4.1.tgz(NetBSD 6.0)
x86_64:ruby-2.2.8.tgz(NetBSD 6.1)
x86_64:ruby-2.3.5.tgz(NetBSD 6.1)
x86_64:ruby-2.4.2.tgz(NetBSD 6.1)
x86_64:ruby-1.8.7.374.tgz(NetBSD 6.1)
x86_64:ruby-2.1.10.tgz(NetBSD 6.1)
x86_64:ruby-2.2.5.tgz(NetBSD 6.1)
x86_64:ruby-2.3.1.tgz(NetBSD 6.1)
x86_64:ruby-1.8.7.374.tgz(NetBSD 6.1)
x86_64:ruby-2.1.10.tgz(NetBSD 6.1)
x86_64:ruby-2.2.6.tgz(NetBSD 6.1)
x86_64:ruby-2.3.3.tgz(NetBSD 6.1)
x86_64:ruby-1.8.7.374.tgz(NetBSD 6.1)
x86_64:ruby-2.1.10.tgz(NetBSD 6.1)
x86_64:ruby-2.2.6.tgz(NetBSD 6.1)
x86_64:ruby-2.3.3.tgz(NetBSD 6.1)
x86_64:ruby-2.2.7.tgz(NetBSD 6.1)
x86_64:ruby-2.3.4.tgz(NetBSD 6.1)
x86_64:ruby-2.4.1.tgz(NetBSD 6.1)
x86_64:ruby-2.2.8.tgz(NetBSD 7.0)
x86_64:ruby-2.3.5.tgz(NetBSD 7.0)
x86_64:ruby-2.4.2.tgz(NetBSD 7.0)
x86_64:ruby-1.8.7.374.tgz(NetBSD 7.0)
x86_64:ruby-2.1.10.tgz(NetBSD 7.0)
x86_64:ruby-2.2.5.tgz(NetBSD 7.0)
x86_64:ruby-2.3.1.tgz(NetBSD 7.0)
x86_64:ruby-1.8.7.374.tgz(NetBSD 7.0)
x86_64:ruby-2.1.10.tgz(NetBSD 7.0)
x86_64:ruby-2.2.6.tgz(NetBSD 7.0)
x86_64:ruby-2.3.3.tgz(NetBSD 7.0)
x86_64:ruby-1.8.7.374.tgz(NetBSD 7.0)
x86_64:ruby-2.1.10.tgz(NetBSD 7.0)
x86_64:ruby-2.2.6.tgz(NetBSD 7.0)
x86_64:ruby-2.3.3.tgz(NetBSD 7.0)
x86_64:ruby-2.2.7.tgz(NetBSD 7.0)
x86_64:ruby-2.3.4.tgz(NetBSD 7.0)
x86_64:ruby-2.4.1.tgz(NetBSD 7.0)
x86_64:ruby-2.2.7.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby-2.3.4.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby-2.4.1.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby-2.2.7.tgz(NetBSD 8.99.1)
x86_64:ruby-2.3.4.tgz(NetBSD 8.99.1)
x86_64:ruby-2.4.1.tgz(NetBSD 8.99.1)
x86_64:ruby-2.2.7.tgz(NetBSD 8.99.1)
x86_64:ruby-2.3.4.tgz(NetBSD 8.99.1)
x86_64:ruby-2.4.1.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]