Daemon Power

The NetBSD Packages Collection: lang/smalltalk

Brief description of the package:
GNU Smalltalk: A smalltalk-80 implementation

Please read the file "DESCR" for a longer description, or browse the package's history.

The package is located in the "lang/smalltalk" directory. The current source version of the package is "smalltalk-3.2.4nb31". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for lang/smalltalk :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: cairo>=1.0.0nb2 MesaLib>=3.4.2 libXdamage>=1.0.3 Xfixes>=2.0.0 x11-links>=1.06 osabi-NetBSD-7.0.1 cwrappers>=20150314 fixesproto>=3.0.0<5 xextproto>=7.0 inputproto>=1.4 xproto>=7.0.9 Xfixes>=2.0.1nb2 damageproto>=1.1.0 libdrm>=2.4.60 libdrm>=2.4.15 libva>=1.0.6 libvdpau>=0.3 dri2proto>=2.0 libelf>=0.8.5 libLLVM>=4.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 libLLVM>=4.0.0 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.12 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 xcb-proto>=1.4 py27-mako-[0-9]* py27-setuptools>=0.8 py27-expat-[0-9]* dri2proto>=2.1 glproto>=1.4.11 glproto>=1.4.6 xf86driproto>=2.0.3 xf86vidmodeproto>=2.3 Xrender>=0.2 renderproto>=0.9.3nb1 renderproto>=0.9 Xrender>=0.8.2 lzo>=2.01 fontconfig>=2.2.95 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 gperf-[0-9]* fontconfig>=2.10.93 fontconfig>=2.1nb2 freetype2>=2.1.9 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 MesaLib>=7.11.2 Xrender>=0.9.0nb1 fontconfig>=2.10.93nb2 png>=1.6.0nb1 gdbm>=1.8.3 atk>=1.11.4 glib2>=2.31.2 perl>=5.0 pcre>=8.31 pcre>=3.4nb1 pcre>=8.30nb1 glib2>=2.4.0 glib2>=2.34.0 gobject-introspection>=0.6.14nb1 py27-cElementTree-[0-9]* glib2>=2.54.0 libffi>=3.0.0 gobject-introspection>=1.34.0 pango>=1.6.0 Xft2>=2.1.7nb3 fontconfig>=2.2 Xrender>=0.9.0nb2 Xft2>=2.1 Xft2>=2.1nb2 fontconfig>=2.10.91 Xrender>=0.8 glib2>=2.33.12 harfbuzz>=0.9.9 icu>=3.4 icu>=59.1nb1 harfbuzz>=0.9.4 cairo>=1.12.10 cairo-gobject>=1.10.2 cairo>=1.14.2nb1 glib2>=2.14.0 Xft2>=2.1.7nb6 harfbuzz>=1.4.2nb1 cairo-gobject>=1.14.2nb1 help2man-[0-9]* p5-gettext>=1.01 perl>=5.26.0 perl<5.28.0 gtk2+>=2.4.0 shared-mime-info>=0.15 atk>=1.30.0 glib2>=2.28.0 gdk-pixbuf2>=2.22.0 glib2>=2.37.2 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 shared-mime-info>=1.0nb1 tiff>=4.0.3nb5 xcursor>=1.0 xcursor>=1.1.1 Xft2>=2.1.2nb2 libXi>=1.3.0 inputproto>=2.3 xextproto>=7.0.3 xproto>=7.0.13 libXi>=1.0.0 Xrandr>=0.99 randrproto>=1.2.0 randrproto>=1.0 Xrandr>=1.0.1 libXcomposite>=0.3.1 compositeproto>=0.4 compositeproto>=0.3.1 pango>=1.20.0 cairo>=1.6.0 atk>=2.6.0 gdk-pixbuf2>=2.34.0nb1 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 pango>=1.40.3nb2 gobject-introspection>=0.9.3 glu>=3.4.2 glu>=6.0 glut>=3.4.2 glu>=7.11.2 tcl>=8.5.7 sqlite3>=3.20.0 sqlite3>=3.0.8 sqlite3>=3.20.1nb1 tk>=8.5.7 tcl>=8.6.1nb1 gmp>=4.2.1 libltdl>=2.4.2 libsigsegv>=2.2 gdbm>=1.10nb3 gtk2+>=2.24.31nb2 glut>=7.11.2 tk>=8.6.1 gmp>=5.0.1 libltdl>=2.2.6 .

This package requires the following package(s) to run: cairo>=1.0.0nb2 MesaLib>=3.4.2 libXdamage>=1.0.3 Xfixes>=2.0.0 Xfixes>=2.0.1nb2 libdrm>=2.4.60 libdrm>=2.4.15 libva>=1.0.6 libvdpau>=0.3 libelf>=0.8.5 libLLVM>=4.0 libLLVM>=4.0.0 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 Xrender>=0.2 Xrender>=0.8.2 lzo>=2.01 fontconfig>=2.2.95 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.10.93 fontconfig>=2.1nb2 freetype2>=2.1.9 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 MesaLib>=7.11.2 Xrender>=0.9.0nb1 fontconfig>=2.10.93nb2 png>=1.6.0nb1 gdbm>=1.8.3 readline>=2.2 readline>=6.0 atk>=1.11.4 glib2>=2.31.2 perl>=5.0 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 glib2>=2.4.0 glib2>=2.34.0 pango>=1.6.0 Xft2>=2.1.7nb3 fontconfig>=2.2 Xrender>=0.9.0nb2 Xft2>=2.1 Xft2>=2.1nb2 fontconfig>=2.10.91 Xrender>=0.8 glib2>=2.33.12 harfbuzz>=0.9.9 icu>=3.4 icu>=59.1nb1 harfbuzz>=0.9.4 cairo>=1.12.10 cairo-gobject>=1.10.2 cairo>=1.14.2nb1 glib2>=2.14.0 Xft2>=2.1.7nb6 harfbuzz>=1.4.2nb1 cairo-gobject>=1.14.2nb1 gtk2+>=2.4.0 py27-expat-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 python27>=2.7.1nb2 shared-mime-info>=0.15 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 atk>=1.30.0 glib2>=2.28.0 gdk-pixbuf2>=2.22.0 glib2>=2.37.2 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 shared-mime-info>=1.0nb1 tiff>=4.0.3nb5 xcursor>=1.0 xcursor>=1.1.1 Xft2>=2.1.2nb2 libXi>=1.3.0 libXi>=1.0.0 Xrandr>=0.99 Xrandr>=1.0.1 libXcomposite>=0.3.1 pango>=1.20.0 cairo>=1.6.0 atk>=2.6.0 gdk-pixbuf2>=2.34.0nb1 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 pango>=1.40.3nb2 glu>=3.4.2 glu>=6.0 glut>=3.4.2 glu>=7.11.2 tcl>=8.5.7 sqlite3>=3.20.0 sqlite3>=3.0.8 sqlite3>=3.20.1nb1 tk>=8.5.7 tcl>=8.6.1nb1 gmp>=4.2.1 libltdl>=2.4.2 libsigsegv>=2.2 gdbm>=1.10nb3 gtk2+>=2.24.31nb2 glut>=7.11.2 tk>=8.6.1 gmp>=5.0.1 libltdl>=2.2.6 .

This package supports the following build-time options:

cairo
Enable cairo support.
curses
Enable curses support.
expat
Use the expat library for XML parsing.
gdbm
Use the GNU gdbm database library.
gtk
Enable support for GTK.
opengl
Use OpenGL as display library.
readline
Enable use of GNU readline library.
sdl
Use SDL as display library.
sqlite
Enable SQLite support.
tk

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
i386:smalltalk-3.2.4nb26.tgz(NetBSD 6.0)
i386:smalltalk-3.2.4nb27.tgz(NetBSD 6.0)
i386:smalltalk-3.2.4nb29.tgz(NetBSD 6.0)
i386:smalltalk-3.2.4nb30.tgz(NetBSD 6.0)
i386:smalltalk-3.2.4nb31.tgz(NetBSD 7.0)
i386:smalltalk-3.2.4nb26.tgz(NetBSD 7.0)
i386:smalltalk-3.2.4nb27.tgz(NetBSD 7.0)
i386:smalltalk-3.2.4nb29.tgz(NetBSD 7.0)
i386:smalltalk-3.2.4nb30.tgz(NetBSD 7.0)
powerpc:smalltalk-3.2.4nb26.tgz(NetBSD 6.0)
powerpc:smalltalk-3.2.4nb24.tgz(NetBSD 7.0)
powerpc:smalltalk-3.2.4nb30.tgz(NetBSD 7.1)
powerpc:smalltalk-3.2.4nb31.tgz(NetBSD 7.1)
powerpc:smalltalk-3.2.4nb30.tgz(NetBSD 8.0)
x86_64:smalltalk-3.2.4nb26.tgz(NetBSD 6.0)
x86_64:smalltalk-3.2.4nb27.tgz(NetBSD 6.0)
x86_64:smalltalk-3.2.4nb29.tgz(NetBSD 6.0)
x86_64:smalltalk-3.2.4nb30.tgz(NetBSD 6.0)
x86_64:smalltalk-3.2.4nb26.tgz(NetBSD 6.1)
x86_64:smalltalk-3.2.4nb27.tgz(NetBSD 6.1)
x86_64:smalltalk-3.2.4nb29.tgz(NetBSD 6.1)
x86_64:smalltalk-3.2.4nb30.tgz(NetBSD 6.1)
x86_64:smalltalk-3.2.4nb31.tgz(NetBSD 7.0)
x86_64:smalltalk-3.2.4nb26.tgz(NetBSD 7.0)
x86_64:smalltalk-3.2.4nb27.tgz(NetBSD 7.0)
x86_64:smalltalk-3.2.4nb29.tgz(NetBSD 7.0)
x86_64:smalltalk-3.2.4nb30.tgz(NetBSD 7.0)
x86_64:smalltalk-3.2.4nb30.tgz(NetBSD 7.0.1_PATCH)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]