Daemon Power

The NetBSD Packages Collection: math/py-rpy

Brief description of the package:
R interface for Python

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://rpy.sourceforge.io/.

Please note that this package has a mpl-1.1 license.

The package is located in the "math/py-rpy" directory. The current source version of the package is "py38-rpy-2.9.1nb2". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for math/py-rpy :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: py38-jinja2-[0-9]* py38-babel>=0.8 py38-pytz>=2015.7 py38-setuptools-[0-9]* py38-expat-[0-9]* python38>=3.8 libffi>=1.20 cwrappers>=20150314 libuuid>=2.18 libffi>=3.3nb1 readline>=2.2 readline>=6.0 python38>=3.8.0 python38>=3.8.7 py38-markupsafe>=0.23 py38-six-[0-9]* py38-sqlite3-[0-9]* pcre2>=10.21 R>=3.3.0 perl>=5.0 libiconv>=1.9.1 gettext-lib>=0.18 glib2>=2.4.0 pcre>=3.4nb1 pcre>=8.30nb1 meson-[0-9]* ninja-build>=1.7 re2c>=0.11.3 pango>=1.6.0 Xft2>=2.1.7nb3 fontconfig>=2.2 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.11.91 fontconfig>=2.1nb2 libXrender>=0.9.2 x11-links>=1.32 osabi-NetBSD-9.0_STABLE xorgproto>=2016.1 fontconfig>=2.13.1nb1 Xft2>=2.1 Xft2>=2.1nb2 fribidi>=0.19.7 fribidi>=0.19.1 glib2>=2.60 harfbuzz>=2.7.2 graphite2>=1.2 glib2>=2.64.0nb1 gtk-doc>=1.18 docbook-xml>=4.4nb1 xmlcatmgr>=2.0beta1 docbook-xsl>=1.68.1 docbook-xml>=4.2 py38-anytree-[0-9]* py38-six>=1.9.0 py38-lxml-[0-9]* libxml2>=2.9.2 libxml2>=2.6.2 libxslt>=1.1.27 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 libxml2>=2.9.10nb3 docbook-xml-[0-9]* docbook-xsl-[0-9]* libxslt>=1.1.8 libxslt>=1.1.34nb4 py38-pygments-[0-9]* pkgconf-[0-9]* itstool-[0-9]* py38-libxml2-[0-9]* libxml2>=2.9.10 py38-expat>=0 gnome-doc-utils>=0.8.0 py27-libxml2>=2.6.16 py27-libxslt>=1.1.12 py27-expat-[0-9]* py27-libxml2>=2.6.8 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 py27-libxml2>=2.6.27 libxslt>=1.1.34 python27>=2.7.1nb2 docbook-xml>=4.5 getopt-[0-9]* bash-[0-9]* libxml2>=2.6.12 gobject-introspection>=0.6.14nb1 py38-cElementTree-[0-9]* glib2>=2.58.0 libffi>=3.0.0 gtk-doc>=1.32nb2 gobject-introspection>=1.62.0nb1 harfbuzz>=2.1.1 cairo>=1.12.10 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.14 xcb-proto>=1.4 lzo>=2.01 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 png>=1.6.0nb1 cairo>=1.0.0nb2 cairo-gobject>=1.10.2 cairo>=1.16.0nb2 glib2>=2.14.0 Xft2>=2.1.7nb8 harfbuzz>=2.6.4nb2 cairo-gobject>=1.16.0nb5 jpeg>=8nb1 tiff>=3.6.1 jbigkit>=2.0 jpeg>=9 lapack>=3.9.0 blas>=3.9.0 gcc7>=3.0 gsed>=3.0.2 gcc7>=7.0 blas>=3.9.0nb1 curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 nghttp2>=1.0.0 nghttp2>=1.40.0nb4 tk>=8.5.7 libXScrnSaver>=1.1.2 tcl>=8.5.7 sqlite3>=3.30.1.2 sqlite3>=3.0.8 sqlite3>=3.33.0nb1 tcl>=8.6.1nb1 libiconv>=1.9.1nb4 pango>=1.44.7nb3 pcre2>=10.30 tiff>=4.0.3nb5 lapack>=3.9.0nb1 curl>=7.70.0nb2 tk>=8.6.10nb1 libtool-fortran>=2.4.2nb9 R>=1.7.0 py38-numpy>=1.0 py38-cython>=0.29.21 py38-cython>=0.12.1 R>=4.0.3nb1 py38-numpy>=1.19.2nb1 .

This package requires the following package(s) to run: py38-jinja2-[0-9]* py38-babel>=0.8 py38-pytz>=2015.7 py38-setuptools-[0-9]* py38-expat-[0-9]* python38>=3.8 libffi>=1.20 libuuid>=2.18 libffi>=3.3nb1 python38>=3.8.0 python38>=3.8.7 py38-markupsafe>=0.23 py38-six-[0-9]* py38-sqlite3-[0-9]* pcre2>=10.21 R>=3.3.0 perl>=5.0 libiconv>=1.9.1 gettext-lib>=0.18 glib2>=2.4.0 pcre>=3.4nb1 pcre>=8.30nb1 pango>=1.6.0 Xft2>=2.1.7nb3 fontconfig>=2.2 freetype2>=2.8.1 freetype2>=2.1.3 fontconfig>=2.11.91 fontconfig>=2.1nb2 libXrender>=0.9.2 fontconfig>=2.13.1nb1 Xft2>=2.1 Xft2>=2.1nb2 fribidi>=0.19.7 fribidi>=0.19.1 glib2>=2.60 harfbuzz>=2.7.2 graphite2>=1.2 glib2>=2.64.0nb1 harfbuzz>=2.1.1 cairo>=1.12.10 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 lzo>=2.01 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 png>=1.6.0nb1 cairo>=1.0.0nb2 cairo-gobject>=1.10.2 cairo>=1.16.0nb2 glib2>=2.14.0 Xft2>=2.1.7nb8 harfbuzz>=2.6.4nb2 cairo-gobject>=1.16.0nb5 readline>=2.2 jpeg>=8nb1 tiff>=3.6.1 jbigkit>=2.0 jpeg>=9 lapack>=3.9.0 blas>=3.9.0 gcc7>=3.0 gsed>=3.0.2 gcc7>=7.0 blas>=3.9.0nb1 curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 nghttp2>=1.0.0 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.9.10nb3 nghttp2>=1.40.0nb4 tk>=8.5.7 libXScrnSaver>=1.1.2 tcl>=8.5.7 sqlite3>=3.30.1.2 sqlite3>=3.0.8 sqlite3>=3.33.0nb1 tcl>=8.6.1nb1 libiconv>=1.9.1nb4 pango>=1.44.7nb3 pcre2>=10.30 readline>=6.0 tiff>=4.0.3nb5 lapack>=3.9.0nb1 curl>=7.70.0nb2 tk>=8.6.10nb1 R>=1.7.0 py38-numpy>=1.0 py38-cython>=0.29.21 py38-cython>=0.12.1 R>=4.0.3nb1 py38-numpy>=1.19.2nb1 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
aarch64:py36-rpy-2.9.1.tgz(NetBSD 9.0)
aarch64:py37-rpy-2.9.1.tgz(NetBSD 9.0)
aarch64:py38-rpy-2.9.1.tgz(NetBSD 9.0)
aarch64:py36-rpy-2.9.1nb1.tgz(NetBSD 9.0)
aarch64:py37-rpy-2.9.1nb1.tgz(NetBSD 9.0)
aarch64:py38-rpy-2.9.1nb1.tgz(NetBSD 9.0)
aarch64:py36-rpy-2.9.1nb2.tgz(NetBSD 9.0)
aarch64:py37-rpy-2.9.1nb2.tgz(NetBSD 9.0)
aarch64:py38-rpy-2.9.1nb2.tgz(NetBSD 9.0)
alpha:py36-rpy-2.9.1nb1.tgz(NetBSD 9.0)
alpha:py37-rpy-2.9.1nb1.tgz(NetBSD 9.0)
alpha:py38-rpy-2.9.1nb1.tgz(NetBSD 9.0)
i386:py36-rpy-2.9.1.tgz(NetBSD 8.0)
i386:py37-rpy-2.9.1.tgz(NetBSD 8.0)
i386:py38-rpy-2.9.1.tgz(NetBSD 8.0)
i386:py36-rpy-2.9.1nb1.tgz(NetBSD 8.0)
i386:py37-rpy-2.9.1nb1.tgz(NetBSD 8.0)
i386:py38-rpy-2.9.1nb1.tgz(NetBSD 8.0)
i386:py36-rpy-2.9.1nb2.tgz(NetBSD 8.0)
i386:py37-rpy-2.9.1nb2.tgz(NetBSD 8.0)
i386:py38-rpy-2.9.1nb2.tgz(NetBSD 8.0)
i386:py36-rpy-2.9.1.tgz(NetBSD 9.0)
i386:py37-rpy-2.9.1.tgz(NetBSD 9.0)
i386:py38-rpy-2.9.1.tgz(NetBSD 9.0)
i386:py36-rpy-2.9.1nb1.tgz(NetBSD 9.0)
i386:py37-rpy-2.9.1nb1.tgz(NetBSD 9.0)
i386:py38-rpy-2.9.1nb1.tgz(NetBSD 9.0)
i386:py36-rpy-2.9.1nb2.tgz(NetBSD 9.0)
i386:py37-rpy-2.9.1nb2.tgz(NetBSD 9.0)
i386:py38-rpy-2.9.1nb2.tgz(NetBSD 9.0)
powerpc:py36-rpy-2.9.1nb1.tgz(NetBSD 8.0)
powerpc:py37-rpy-2.9.1nb1.tgz(NetBSD 8.0)
powerpc:py38-rpy-2.9.1nb1.tgz(NetBSD 8.0)
powerpc:py36-rpy-2.9.1nb1.tgz(NetBSD 9.0)
powerpc:py37-rpy-2.9.1nb1.tgz(NetBSD 9.0)
powerpc:py38-rpy-2.9.1nb1.tgz(NetBSD 9.0)
powerpc:py36-rpy-2.9.1.tgz(NetBSD 9.0)
powerpc:py37-rpy-2.9.1.tgz(NetBSD 9.0)
powerpc:py38-rpy-2.9.1.tgz(NetBSD 9.0)
x86_64:py36-rpy-2.9.1nb2.tgz(NetBSD 9.0)
x86_64:py37-rpy-2.9.1nb2.tgz(NetBSD 9.0)
x86_64:py38-rpy-2.9.1nb2.tgz(NetBSD 9.0)
x86_64:py36-rpy-2.9.1nb1.tgz(NetBSD 9.0)
x86_64:py37-rpy-2.9.1nb1.tgz(NetBSD 9.0)
x86_64:py38-rpy-2.9.1nb1.tgz(NetBSD 9.0)
x86_64:py36-rpy-2.9.1nb1.tgz(NetBSD 8.0)
x86_64:py37-rpy-2.9.1nb1.tgz(NetBSD 8.0)
x86_64:py38-rpy-2.9.1nb1.tgz(NetBSD 8.0)
x86_64:py36-rpy-2.9.1.tgz(NetBSD 8.0)
x86_64:py37-rpy-2.9.1.tgz(NetBSD 8.0)
x86_64:py38-rpy-2.9.1.tgz(NetBSD 8.0)
x86_64:py36-rpy-2.9.1nb2.tgz(NetBSD 8.0)
x86_64:py37-rpy-2.9.1nb2.tgz(NetBSD 8.0)
x86_64:py38-rpy-2.9.1nb2.tgz(NetBSD 8.0)
x86_64:py36-rpy-2.9.1.tgz(NetBSD 9.0)
x86_64:py37-rpy-2.9.1.tgz(NetBSD 9.0)
x86_64:py38-rpy-2.9.1.tgz(NetBSD 9.0)
x86_64:py36-rpy-2.9.1nb1.tgz(NetBSD 9.0)
x86_64:py37-rpy-2.9.1nb1.tgz(NetBSD 9.0)
x86_64:py38-rpy-2.9.1nb1.tgz(NetBSD 9.0)
x86_64:py36-rpy-2.9.1nb2.tgz(NetBSD 9.0)
x86_64:py37-rpy-2.9.1nb2.tgz(NetBSD 9.0)
x86_64:py38-rpy-2.9.1nb2.tgz(NetBSD 9.0)
x86_64:py36-rpy-2.9.1nb2.tgz(NetBSD 9.0)
x86_64:py37-rpy-2.9.1nb2.tgz(NetBSD 9.0)
x86_64:py38-rpy-2.9.1nb2.tgz(NetBSD 9.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]