meta-pkgs/gstreamer1-default-backend - The NetBSD Packages Collection

Default audio backend for gstreamer1

This meta package provides the default audio backend for gstreamer1
that is best suited to your operating system.

Build dependencies

pkgtools/cwrappers

Runtime dependencies

audio/gst-plugins1-oss

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgstreamer1-default-backend-1.0.tgz
NetBSD 8.0powerpcgstreamer1-default-backend-1.0.tgz
NetBSD 9.0aarch64gstreamer1-default-backend-1.0.tgz
NetBSD 9.0alphagstreamer1-default-backend-1.0.tgz
NetBSD 9.0earmv6hfgstreamer1-default-backend-1.0.tgz
NetBSD 9.0earmv7hfgstreamer1-default-backend-1.0.tgz
NetBSD 9.0earmv7hfgstreamer1-default-backend-1.0.tgz
NetBSD 9.0i386gstreamer1-default-backend-1.0.tgz
NetBSD 9.0mips64ebgstreamer1-default-backend-1.0.tgz
NetBSD 9.0powerpcgstreamer1-default-backend-1.0.tgz
NetBSD 9.0sparc64gstreamer1-default-backend-1.0.tgz
NetBSD 9.0sparcgstreamer1-default-backend-1.0.tgz
NetBSD 9.0x86_64gstreamer1-default-backend-1.0.tgz
NetBSD 9.0x86_64gstreamer1-default-backend-1.0.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

alsa
Enable ALSA support.
oss
Enable support for the Open Sound System audio library.
pulseaudio
Enable support for the PulseAudio sound server.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.