Daemon Power

The NetBSD Packages Collection: meta-pkgs/php56-extensions

Brief description of the package:
"meta-package" for the PHP 5.6 HTML-embedded scripting language

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://www.php.net/.

The package is located in the "meta-pkgs/php56-extensions" directory. The current source version of the package is "php56-extensions-5.6.31nb1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for meta-pkgs/php56-extensions :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: php>=5.6.31<5.7 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 cwrappers>=20150314 libxml2>=2.8.0nb2 ap24-php56>=5.6.31<5.7 php>=5.6.0<5.7 apache>=2.4.7<2.5 apr>=1.5.0 apr-util>=1.5.3 apr-util>=1.2.8 pcre>=3.4nb1 nghttp2>=1.0.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 apr-util>=1.5.4nb4 pcre>=8.30nb1 nghttp2>=1.25.0nb1 apache>=2.4.18nb1 php56-fpm>=5.6.31<5.7 php56-bcmath>=5.6.31<5.7 php56-bz2>=5.6.31<5.7 php56-calendar>=5.6.31<5.7 php56-curl>=5.6.31<5.7 curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 curl>=7.55.1nb1 php56-dba>=5.6.31<5.7 php56-enchant>=5.6.31 enchant>=1.2.4 hunspell-en_US-[0-9]* hunspell>=1.2.2 perl>=5.0 glib2>=2.4.0 libelf>=0.8.5 pcre>=8.31 hunspell>=1.3.2 glib2>=2.34.0 enchant>=1.1.3 enchant>=1.6.0nb5 php56-exif>=5.6.31<5.7 php56-ftp>=5.6.31<5.7 php56-gd>=5.6.31<5.7 gd>=2.0.15nb1 fontconfig>=2.10.93 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 gperf-[0-9]* fontconfig>=2.1nb2 libimagequant>=2.8.2 libwebp>=0.2.0 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 giflib>=5.1.0 png>=1.2.4 tiff>=4.0.3nb5 png>=1.6.0nb1 fontconfig>=2.10.93nb2 libwebp>=0.6.0 gd>=2.2.4nb1 php56-gettext>=5.6.31<5.7 php56-gmp>=5.6.31<5.7 gmp>=4.2.1 gmp>=5.0.1 php56-iconv>=5.6.31<5.7 php56-recode>=5.6.31<5.7 recode>=3.6nb1 recode>=3.6nb5 php56-imap>=5.6.31<5.7 imap-uw>=2007dnb1 imap-uw>=2007fnb3 php56-intl>=5.6.31<5.7 icu>=3.4 icu>=59.1nb1 php56-json>=5.6.31<5.7 php56-ldap>=5.6.31<5.7 php56-mbstring>=5.6.31<5.7 php56-mcrypt>=5.6.31<5.7 libmcrypt>=2.5.6 libmcrypt>=2.5.7nb1 php56-mssql>=5.6.31<5.7 freetds>=1.00 libltdl>=2.4.2 libltdl>=2.2.6 php56-mysql>=5.6.31<5.7 mysql-client>=5.5.10<5.6 mysql-client>=5.5.48nb1 php56-mysqli>=5.6.31<5.7 php56-opcache>=5.6.31<5.7 php56-pcntl>=5.6.31<5.7 php56-pdo>=5.6.31<5.7 php56-pdo_dblib>=5.6.31<5.7 freetds>=0.63 php56-pdo-5.* php56-pdo>=5.2.9 php56-pdo_mysql>=5.6.31<5.7 php56-pdo_pgsql>=5.6.31<5.7 postgresql95-client>=9.5.1 postgresql95-client>=9.5.1nb1 php56-pdo_sqlite>=5.6.31<5.7 php56-pgsql>=5.6.31<5.7 php56-posix>=5.6.31<5.7 php56-pspell>=5.6.31<5.7 aspell>=0.50.3 ncurses>=5.3nb1 ncurses>=6.0 aspell>=0.60.6nb3 php56-shmop>=5.6.31<5.7 php56-snmp>=5.6.31<5.7 net-snmp>=5.0.9nb3 perl>=5.26.0 perl<5.28.0 osabi-NetBSD-7.0.1 net-snmp>=5.7.3nb3 php56-soap>=5.6.31<5.7 php56-sockets>=5.6.31<5.7 php56-sysvmsg>=5.6.31<5.7 php56-sysvsem>=5.6.31<5.7 php56-sysvshm>=5.6.31<5.7 php56-tidy>=5.6.31<5.7 tidy>=5.1.25<20000000 libxslt-[0-9]* libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 docbook-xml-[0-9]* docbook-xsl-[0-9]* docbook-xml>=4.2 php56-wddx>=5.6.31<5.7 php56-xmlrpc>=5.6.31<5.7 php56-xsl>=5.6.31<5.7 libxslt>=1.1.8 libxslt>=1.1.28nb2 php56-zip>=5.6.31<5.7 php56-zlib>=5.6.31<5.7 .

This package requires the following package(s) to run: php>=5.6.31<5.7 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 ap24-php56>=5.6.31<5.7 php>=5.6.0<5.7 apache>=2.4.7<2.5 apr>=1.5.0 apr-util>=1.5.3 apr-util>=1.2.8 pcre>=3.4nb1 nghttp2>=1.0.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 python27>=2.7.1nb2 readline>=2.2 apr-util>=1.5.4nb4 pcre>=8.30nb1 nghttp2>=1.25.0nb1 readline>=6.0 apache>=2.4.18nb1 php56-fpm>=5.6.31<5.7 php56-bcmath>=5.6.31<5.7 php56-bz2>=5.6.31<5.7 php56-calendar>=5.6.31<5.7 php56-curl>=5.6.31<5.7 curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 curl>=7.55.1nb1 php56-dba>=5.6.31<5.7 php56-enchant>=5.6.31 enchant>=1.2.4 hunspell-en_US-[0-9]* hunspell>=1.2.2 perl>=5.0 glib2>=2.4.0 libelf>=0.8.5 pcre>=8.31 hunspell>=1.3.2 glib2>=2.34.0 enchant>=1.1.3 enchant>=1.6.0nb5 php56-exif>=5.6.31<5.7 php56-ftp>=5.6.31<5.7 php56-gd>=5.6.31<5.7 gd>=2.0.15nb1 fontconfig>=2.10.93 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.1nb2 libimagequant>=2.8.2 libwebp>=0.2.0 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 giflib>=5.1.0 png>=1.2.4 tiff>=4.0.3nb5 png>=1.6.0nb1 fontconfig>=2.10.93nb2 libwebp>=0.6.0 gd>=2.2.4nb1 php56-gettext>=5.6.31<5.7 php56-gmp>=5.6.31<5.7 gmp>=4.2.1 gmp>=5.0.1 php56-iconv>=5.6.31<5.7 php56-recode>=5.6.31<5.7 recode>=3.6nb1 recode>=3.6nb5 php56-imap>=5.6.31<5.7 imap-uw>=2007dnb1 imap-uw>=2007fnb3 php56-intl>=5.6.31<5.7 icu>=3.4 icu>=59.1nb1 php56-json>=5.6.31<5.7 php56-ldap>=5.6.31<5.7 php56-mbstring>=5.6.31<5.7 php56-mcrypt>=5.6.31<5.7 libmcrypt>=2.5.6 libmcrypt>=2.5.7nb1 php56-mssql>=5.6.31<5.7 freetds>=1.00 libltdl>=2.4.2 libltdl>=2.2.6 php56-mysql>=5.6.31<5.7 mysql-client>=5.5.10<5.6 mysql-client>=5.5.48nb1 php56-mysqli>=5.6.31<5.7 php56-opcache>=5.6.31<5.7 php56-pcntl>=5.6.31<5.7 php56-pdo>=5.6.31<5.7 php56-pdo_dblib>=5.6.31<5.7 freetds>=0.63 php56-pdo-5.* php56-pdo>=5.2.9 php56-pdo_mysql>=5.6.31<5.7 php56-pdo_pgsql>=5.6.31<5.7 postgresql95-client>=9.5.1 postgresql95-client>=9.5.1nb1 php56-pdo_sqlite>=5.6.31<5.7 php56-pgsql>=5.6.31<5.7 php56-posix>=5.6.31<5.7 php56-pspell>=5.6.31<5.7 aspell>=0.50.3 ncurses>=5.3nb1 ncurses>=6.0 aspell>=0.60.6nb3 php56-shmop>=5.6.31<5.7 php56-snmp>=5.6.31<5.7 net-snmp>=5.0.9nb3 perl>=5.26.0 perl<5.28.0 osabi-NetBSD-7.0.1 net-snmp>=5.7.3nb3 php56-soap>=5.6.31<5.7 php56-sockets>=5.6.31<5.7 php56-sysvmsg>=5.6.31<5.7 php56-sysvsem>=5.6.31<5.7 php56-sysvshm>=5.6.31<5.7 php56-tidy>=5.6.31<5.7 tidy>=5.1.25<20000000 php56-wddx>=5.6.31<5.7 php56-xmlrpc>=5.6.31<5.7 php56-xsl>=5.6.31<5.7 libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 libxslt>=1.1.28nb2 php56-zip>=5.6.31<5.7 php56-zlib>=5.6.31<5.7 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
earm:php56-extensions-5.6.16.tgz(NetBSD 7.0)
earmv6hf:php56-extensions-5.6.7.tgz(NetBSD 7.0)
earmv7hf:php56-extensions-5.6.16.tgz(NetBSD 7.0)
i386:php56-extensions-5.6.28.tgz(NetBSD 6.0)
i386:php56-extensions-5.6.30nb1.tgz(NetBSD 6.0)
i386:php56-extensions-5.6.31nb1.tgz(NetBSD 6.0)
i386:php56-extensions-5.6.31nb1.tgz(NetBSD 7.0)
i386:php56-extensions-5.6.28.tgz(NetBSD 7.0)
i386:php56-extensions-5.6.30.tgz(NetBSD 7.0)
i386:php56-extensions-5.6.30nb1.tgz(NetBSD 7.0)
powerpc:php56-extensions-5.6.30nb1.tgz(NetBSD 7.1)
powerpc:php56-extensions-5.6.30nb1.tgz(NetBSD 8.0)
powerpc:php56-extensions-5.6.31nb1.tgz(NetBSD 8.0)
x86_64:php56-extensions-5.6.28.tgz(NetBSD 6.0)
x86_64:php56-extensions-5.6.30nb1.tgz(NetBSD 6.0)
x86_64:php56-extensions-5.6.31nb1.tgz(NetBSD 6.0)
x86_64:php56-extensions-5.6.28.tgz(NetBSD 6.1)
x86_64:php56-extensions-5.6.30nb1.tgz(NetBSD 6.1)
x86_64:php56-extensions-5.6.31nb1.tgz(NetBSD 6.1)
x86_64:php56-extensions-5.6.31nb1.tgz(NetBSD 7.0)
x86_64:php56-extensions-5.6.28.tgz(NetBSD 7.0)
x86_64:php56-extensions-5.6.30.tgz(NetBSD 7.0)
x86_64:php56-extensions-5.6.30nb1.tgz(NetBSD 7.0)
x86_64:php56-extensions-5.6.30nb1.tgz(NetBSD 7.0.1_PATCH)
x86_64:php56-extensions-5.6.31nb1.tgz(NetBSD 8.99.1)
x86_64:php56-extensions-5.6.31nb1.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]