Daemon Power

The NetBSD Packages Collection: meta-pkgs/pkgsrc-guide-tools

Brief description of the package:
Packages required to build the pkgsrc Guide

Please read the file "DESCR" for a longer description, or browse the package's history.

The package is located in the "meta-pkgs/pkgsrc-guide-tools" directory. The current source version of the package is "pkgsrc-guide-tools-1.0nb1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for meta-pkgs/pkgsrc-guide-tools :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: docbook>=4.5 iso8879>=1986 xmlcatmgr>=2.0beta1 cwrappers>=20150314 docbook-xml>=4.5 docbook-xsl>=1.62.4 docbook-xml>=4.2 perl>=5.0 dsssl-docbook-modular>=1.54 docbook>=4.0 opensp>=1.5 xmlto-[0-9]* getopt-[0-9]* docbook-xsl>=1.67.0nb1 libxml2>=2.6.2 bash-[0-9]* libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 libxml2>=2.8.0nb2 docbook-xml-[0-9]* docbook-xsl-[0-9]* libxslt>=1.1.28nb2 libxslt>=1.0.30 tidy-[0-9]* libxslt-[0-9]* w3m>=0.4 boehm-gc>=7.2 libatomic_ops>=7.4.0<2000 boehm-gc>=7.4 openjade>=1.3.2 opensp>=1.5.1 opensp>=1.5.2nb1 dvipsk-[0-9]* tex-dvips>=2013 kpathsea>=3.5.7 kpathsea>=6.2.1 kpathsea>=6.0.0 tex-texconfig-[0-9]* kpathsea-[0-9]* tex-jadetex>=3.13 tex-colortbl-[0-9]* tex-latex-bin-[0-9]* tex-latex>=2012 tex-latexconfig>=2011 tex-latex-fonts-[0-9]* tex-luatex-[0-9]* luatex>=0.60.1 zziplib>=0.10.82 cairo>=1.0.0nb2 MesaLib>=3.4.2 libXdamage>=1.0.3 Xfixes>=2.0.0 x11-links>=1.06 osabi-NetBSD-7.0.1 fixesproto>=3.0.0<5 xextproto>=7.0 inputproto>=1.4 xproto>=7.0.9 Xfixes>=2.0.1nb2 damageproto>=1.1.0 libdrm>=2.4.60 libdrm>=2.4.15 libva>=1.0.6 libvdpau>=0.3 dri2proto>=2.0 libelf>=0.8.5 libLLVM>=4.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 libLLVM>=4.0.0 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.12 xcb-proto>=1.4 py27-mako-[0-9]* py27-setuptools>=0.8 py27-expat-[0-9]* dri2proto>=2.1 glproto>=1.4.11 glproto>=1.4.6 xf86driproto>=2.0.3 xf86vidmodeproto>=2.3 Xrender>=0.2 renderproto>=0.9.3nb1 renderproto>=0.9 Xrender>=0.8.2 lzo>=2.01 fontconfig>=2.2.95 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 gperf-[0-9]* fontconfig>=2.10.93 fontconfig>=2.1nb2 freetype2>=2.1.9 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 MesaLib>=7.11.2 Xrender>=0.9.0nb1 fontconfig>=2.10.93nb2 png>=1.6.0nb1 mpfr>=2.0.3 gmp>=4.2.1 gmp>=5.0.1 zziplib>=0.13.56 cairo>=1.14.2nb1 mpfr>=3.0.0.3 tex-etex-[0-9]* tex-plain-[0-9]* tex-amsfonts-[0-9]* tex-tetex>=3.0.25424 dialog>=1.0 tex-kpathsea>=2012nb1 tex-texconfig>=2013 tex-texlive.infra-[0-9]* tex-cm-[0-9]* tex-hyphen-base-[0-9]* tex-knuth-lib-[0-9]* tex-tex-ini-files-[0-9]* tex-pdftex-[0-9]* tex-dvips-[0-9]* tex-kpathsea-[0-9]* tex-updmap-map-[0-9]* web2c-[0-9]* ptexenc>=1.3.4 ptexenc>=1.1.1 tex-tetex>=3.0.27774 tex-plain>=3.14159265.12854 tex-unicode-data-[0-9]* tex-graphics-[0-9]* tex-graphics-cfg-[0-9]* tex-graphics-def-[0-9]* tex-tools-[0-9]* tex-graphics>=1.0onb1 tex-ec-[0-9]* tex-babel-[0-9]* tex-carlisle>=2010 tex-latex-[0-9]* tex-latex>=2009 tex-latex-bin>=2009nb1 tex-fancyhdr-[0-9]* tex-hyperref-[0-9]* tex-ifxetex>=0.6 tex-oberdiek>=2009nb1 tex-amsmath-[0-9]* tex-etex-pkg-[0-9]* tex-ifluatex-[0-9]* tex-ifxetex-[0-9]* tex-url>=3.2 tex-lambda-[0-9]* tex-marvosym-[0-9]* tex-passivetex>=1.25nb2 tex-hyph-utf8-[0-9]* tex-psnfss-[0-9]* tex-avantgar-[0-9]* tex-bookman-[0-9]* tex-charter-[0-9]* tex-courier-[0-9]* tex-fpl-[0-9]* tex-helvetic-[0-9]* tex-mathpazo-[0-9]* tex-ncntrsbk-[0-9]* tex-palatino-[0-9]* tex-symbol-[0-9]* tex-times-[0-9]* tex-zapfchan-[0-9]* tex-zapfding-[0-9]* tex-rotating-[0-9]* tex-tipa-[0-9]* tex-xmltex-[0-9]* tex-latexconfig-[0-9]* tex-xmltexconfig-[0-9]* tex-ulem-[0-9]* ghostscript>=7.05 ghostscript-gpl-[0-9]* ghostscript-fonts>=6.0 libpaper>=1.1.22 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 tiff>=4.0.3nb5 .

This package requires the following package(s) to run: docbook>=4.5 iso8879>=1986 xmlcatmgr>=2.0beta1 docbook-xml>=4.5 docbook-xsl>=1.62.4 docbook-xml>=4.2 perl>=5.0 dsssl-docbook-modular>=1.54 docbook>=4.0 opensp>=1.5 libxslt>=1.0.30 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libxml2>=2.6.2 libgcrypt>=1.6.0 libxml2>=2.8.0nb2 tidy-[0-9]* w3m>=0.4 boehm-gc>=7.2 libatomic_ops>=7.4.0<2000 boehm-gc>=7.4 openjade>=1.3.2 opensp>=1.5.1 opensp>=1.5.2nb1 dvipsk-[0-9]* tex-dvips>=2013 kpathsea>=3.5.7 kpathsea>=6.2.1 kpathsea>=6.0.0 tex-jadetex>=3.13 tex-colortbl-[0-9]* tex-latex-bin-[0-9]* tex-latex>=2012 tex-latexconfig>=2011 tex-latex-fonts-[0-9]* tex-luatex-[0-9]* luatex>=0.60.1 zziplib>=0.10.82 cairo>=1.0.0nb2 MesaLib>=3.4.2 libXdamage>=1.0.3 Xfixes>=2.0.0 Xfixes>=2.0.1nb2 libdrm>=2.4.60 libdrm>=2.4.15 libva>=1.0.6 libvdpau>=0.3 libelf>=0.8.5 libLLVM>=4.0 libLLVM>=4.0.0 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 Xrender>=0.2 Xrender>=0.8.2 lzo>=2.01 fontconfig>=2.2.95 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.10.93 fontconfig>=2.1nb2 freetype2>=2.1.9 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 MesaLib>=7.11.2 Xrender>=0.9.0nb1 fontconfig>=2.10.93nb2 png>=1.6.0nb1 mpfr>=2.0.3 gmp>=4.2.1 gmp>=5.0.1 zziplib>=0.13.56 cairo>=1.14.2nb1 mpfr>=3.0.0.3 tex-etex-[0-9]* tex-plain-[0-9]* tex-amsfonts-[0-9]* tex-tetex>=3.0.25424 dialog>=1.0 kpathsea-[0-9]* tex-kpathsea>=2012nb1 tex-texconfig>=2013 tex-texlive.infra-[0-9]* tex-cm-[0-9]* tex-hyphen-base-[0-9]* tex-knuth-lib-[0-9]* tex-tex-ini-files-[0-9]* tex-pdftex-[0-9]* tex-dvips-[0-9]* tex-kpathsea-[0-9]* tex-updmap-map-[0-9]* web2c-[0-9]* ptexenc>=1.3.4 ptexenc>=1.1.1 tex-tetex>=3.0.27774 tex-plain>=3.14159265.12854 tex-unicode-data-[0-9]* tex-graphics-[0-9]* tex-graphics-cfg-[0-9]* tex-graphics-def-[0-9]* tex-tools-[0-9]* tex-graphics>=1.0onb1 tex-ec-[0-9]* tex-babel-[0-9]* tex-carlisle>=2010 tex-latex-[0-9]* tex-latex>=2009 tex-latex-bin>=2009nb1 tex-fancyhdr-[0-9]* tex-hyperref-[0-9]* tex-ifxetex>=0.6 tex-oberdiek>=2009nb1 tex-amsmath-[0-9]* tex-etex-pkg-[0-9]* tex-ifluatex-[0-9]* tex-ifxetex-[0-9]* tex-url>=3.2 tex-lambda-[0-9]* tex-marvosym-[0-9]* tex-passivetex>=1.25nb2 tex-hyph-utf8-[0-9]* tex-psnfss-[0-9]* tex-avantgar-[0-9]* tex-bookman-[0-9]* tex-charter-[0-9]* tex-courier-[0-9]* tex-fpl-[0-9]* tex-helvetic-[0-9]* tex-mathpazo-[0-9]* tex-ncntrsbk-[0-9]* tex-palatino-[0-9]* tex-symbol-[0-9]* tex-times-[0-9]* tex-zapfchan-[0-9]* tex-zapfding-[0-9]* tex-rotating-[0-9]* tex-tipa-[0-9]* tex-xmltex-[0-9]* tex-latexconfig-[0-9]* tex-xmltexconfig-[0-9]* tex-ulem-[0-9]* ghostscript>=7.05 ghostscript-gpl-[0-9]* ghostscript-fonts>=6.0 libpaper>=1.1.22 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 tiff>=4.0.3nb5 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
earm:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 7.0)
earmv6hf:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 7.0)
earmv6hf:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 7.0)
earmv7hf:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 7.0)
earmv7hf:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 7.99.21)
earmv7hf:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 8.0_BETA)
i386:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 6.0)
i386:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 6.0)
i386:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 7.0)
i386:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 7.0)
i386:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 7.0)
i386:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 7.0)
powerpc:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 6.1)
powerpc:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 7.1)
powerpc:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 7.1)
powerpc:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 8.0)
powerpc:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 8.0)
sparc64:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 7.0)
x86_64:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 6.0)
x86_64:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 6.0)
x86_64:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 6.0)
x86_64:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 6.1)
x86_64:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 6.1)
x86_64:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 7.0)
x86_64:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 7.0)
x86_64:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 7.0)
x86_64:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 7.0)
x86_64:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 7.0)
x86_64:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 7.0.1_PATCH)
x86_64:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 8.99.1)
x86_64:pkgsrc-guide-tools-1.0nb1.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]