Daemon Power

The NetBSD Packages Collection: net/freerdp

Brief description of the package:
Free implementation of the Remote Desktop Protocol

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://www.freerdp.com/.

Please note that this package has a apache-2.0 license.

The package is located in the "net/freerdp" directory. The current source version of the package is "freerdp-1.0.2nb30". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for net/freerdp :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: alsa-lib>=1.0.18 cwrappers>=20150314 cups-base>=1.1.19nb3 dbus>=0.91 xmlto-[0-9]* getopt-[0-9]* docbook-xsl>=1.67.0nb1 docbook-xml>=4.2 xmlcatmgr>=2.0beta1 perl>=5.0 libxml2>=2.6.2 libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 libxml2>=2.8.0nb2 docbook-xml-[0-9]* docbook-xsl-[0-9]* libxslt>=1.1.28nb2 x11-links>=1.12 osabi-NetBSD-8.0_RC1 libusb1>=1.0.9 png>=1.2.4 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 libpaper>=1.1.22 gnutls>=3.3.0 lzo>=2.01 gmp>=5.0 gmp>=4.2.1 libcfg+>=0.6.2nb1 libtasn1>=4.9 libtasn1>=0.2.7 nettle>=3.1 gmp>=5.0.1 nettle>=2.4 p11-kit>=0.23.1 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 libtasn1>=0.3.0 p11-kit>=0.10 p11-kit>=0.23 libunistring>=0.9.3 libcfg+>=0.6.2nb3 nettle>=3.1.1 libunistring>=0.9.4 png>=1.6.0nb1 tiff>=4.0.3nb5 gnutls>=3.6.0nb1 ffmpeg1>=1.2.6nb1 libass>=0.9.12 fribidi>=0.19.0 fribidi>=0.19.1 fontconfig>=2.10.93 libuuid>=2.18 freetype2>=2.8.1 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 gperf-[0-9]* fontconfig>=2.1nb2 harfbuzz>=0.9.4 icu>=3.4 glib2>=2.4.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 pcre>=8.30nb1 python27>=2.7 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 icu>=61.1 glib2>=2.34.0 enca>=1.9 fontconfig>=2.13.0 harfbuzz>=1.4.2nb1 libtheora>=1.0alpha3 libvorbis>=1.0.1 libogg>=1.1 libogg>=1.1.2nb1 libvorbis>=1.1.0nb1 lame>=3.93.1nb2 xvidcore>=1.0.0 libvdpau>=0.3 xorgproto>=2016.1 libva>=1.0.6 Xfixes>=2.0.0 fixesproto>=3.0.0<5 libdrm>=2.4.15 Xfixes>=2.0.1nb2 libvpx>=1.6.0 yasm-[0-9]* libass>=0.14.0nb1 libtheora>=1.0alpha3nb1 lame>=3.98.2nb1 lame>=3.96.1nb4 xvidcore>=1.1.0nb1 libvpx>=1.6.1 yasm>=0.7.2 xcursor>=1.0 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xrender>=0.9.0nb1 xcursor>=1.1.1 libXdamage>=1.0.3 libXv>=1.0.1 cups-base>=2.2.7nb2 ffmpeg1>=1.2.12nb8 xcursor>=1.1.2nb1 .

This package requires the following package(s) to run: alsa-lib>=1.0.18 cups-base>=1.1.19nb3 dbus>=0.91 libusb1>=1.0.9 png>=1.2.4 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 libpaper>=1.1.22 gnutls>=3.3.0 lzo>=2.01 gmp>=5.0 gmp>=4.2.1 libcfg+>=0.6.2nb1 libtasn1>=4.9 libtasn1>=0.2.7 nettle>=3.1 gmp>=5.0.1 nettle>=2.4 p11-kit>=0.23.1 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 libtasn1>=0.3.0 p11-kit>=0.10 p11-kit>=0.23 libunistring>=0.9.3 libcfg+>=0.6.2nb3 nettle>=3.1.1 libunistring>=0.9.4 png>=1.6.0nb1 tiff>=4.0.3nb5 gnutls>=3.6.0nb1 ffmpeg1>=1.2.6nb1 libass>=0.9.12 fribidi>=0.19.0 fribidi>=0.19.1 fontconfig>=2.10.93 libuuid>=2.18 freetype2>=2.8.1 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.1nb2 harfbuzz>=0.9.4 icu>=3.4 glib2>=2.4.0 perl>=5.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 pcre>=8.30nb1 icu>=61.1 glib2>=2.34.0 enca>=1.9 fontconfig>=2.13.0 harfbuzz>=1.4.2nb1 libtheora>=1.0alpha3 libvorbis>=1.0.1 libogg>=1.1 libogg>=1.1.2nb1 libvorbis>=1.1.0nb1 lame>=3.93.1nb2 xvidcore>=1.0.0 libvdpau>=0.3 libva>=1.0.6 Xfixes>=2.0.0 libdrm>=2.4.15 Xfixes>=2.0.1nb2 libvpx>=1.6.0 libass>=0.14.0nb1 libtheora>=1.0alpha3nb1 lame>=3.98.2nb1 lame>=3.96.1nb4 xvidcore>=1.1.0nb1 libvpx>=1.6.1 xcursor>=1.0 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xrender>=0.9.0nb1 xcursor>=1.1.1 libXdamage>=1.0.3 libXv>=1.0.1 cups-base>=2.2.7nb2 ffmpeg1>=1.2.12nb8 xcursor>=1.1.2nb1 .

This package supports the following build-time options:

alsa
Enable ALSA support.
cups
Enable cups (Common UNIX Printing System) support.
debug
Enable debugging facilities in the package.
ffmpeg
Enable ffmpeg support.
pcsc
Enable PC/SC support.
pulseaudio
Enable support for the PulseAudio sound server.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
earmv6hf:freerdp-1.0.2nb12.tgz(NetBSD 7.0)
earmv6hf:freerdp-1.0.2nb23.tgz(NetBSD 8.0)
earmv7hf:freerdp-1.0.2nb12.tgz(NetBSD 7.0)
earmv7hfeb:freerdp-1.0.2nb25.tgz(NetBSD 8.0)
i386:freerdp-1.0.2nb18.tgz(NetBSD 6.0)
i386:freerdp-1.0.2nb22.tgz(NetBSD 6.0)
i386:freerdp-1.0.2nb22.tgz(NetBSD 6.0)
i386:freerdp-1.0.2nb18.tgz(NetBSD 7.0)
i386:freerdp-1.0.2nb18.tgz(NetBSD 7.0)
i386:freerdp-1.0.2nb22.tgz(NetBSD 7.0)
i386:freerdp-1.0.2nb22.tgz(NetBSD 7.0)
i386:freerdp-1.0.2nb25.tgz(NetBSD 7.0)
i386:freerdp-1.0.2nb25.tgz(NetBSD 7.1)
i386:freerdp-1.0.2nb25.tgz(NetBSD 8.0)
sparc64:freerdp-1.0.2nb25.tgz(NetBSD 8.0)
x86_64:freerdp-1.0.2nb23.tgz(NetBSD 7.0)
x86_64:freerdp-1.0.2nb25.tgz(NetBSD 7.0)
x86_64:freerdp-1.0.2nb22.tgz(NetBSD 7.0.1_PATCH)
x86_64:freerdp-1.0.2nb26.tgz(NetBSD 7.1.1)
x86_64:freerdp-1.0.2nb25.tgz(NetBSD 7.1)
x86_64:freerdp-1.0.2nb22.tgz(NetBSD 8.99.1)
x86_64:freerdp-1.0.2nb23.tgz(NetBSD 8.0)
x86_64:freerdp-1.0.2nb25.tgz(NetBSD 8.0)
x86_64:freerdp-1.0.2nb22.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]