Daemon Power

The NetBSD Packages Collection: net/krfb

Brief description of the package:
KDE desktop sharing

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://www.kde.org/.

Please note that this package has a gnu-gpl-v2 license.

The package is located in the "net/krfb" directory. The current source version of the package is "krfb-4.14.3nb12". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for net/krfb :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: qt4-libs>=4.4.0 glu>=3.4.2 MesaLib>=3.4.2 libxcb>=1.6 libXdmcp>=0.99 xorgproto>=2016.1 cwrappers>=20150314 libXau>=1.0 xcb-proto>=1.13 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 xcb-proto>=1.4 py27-mako-[0-9]* py27-setuptools>=0.8 py27-expat-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 x11-links>=1.12 osabi-NetBSD-8.0_RC2 MesaLib>=7.11.2 glu>=6.0 xcursor>=1.0 Xfixes>=2.0.0 fixesproto>=3.0.0<5 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xfixes>=2.0.1nb2 Xrender>=0.9.0nb1 xcursor>=1.1.1 Xft2>=2.1 fontconfig>=2.2 libuuid>=2.18 freetype2>=2.8.1 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 gperf-[0-9]* fontconfig>=2.10.93 fontconfig>=2.1nb2 Xrender>=0.9.0nb2 fontconfig>=2.13.0 Xft2>=2.1nb2 Xrandr>=0.99 Xrandr>=1.0.1 jpeg>=8nb1 png>=1.2.4 glu>=7.11.2 xcursor>=1.1.2nb1 Xft2>=2.1.7nb7 Xrandr>=1.0.2nb3 jpeg>=9 png>=1.6.0nb1 qt4-libs>=4.6.1nb2 qt4-qdbus>=4.3.2 dbus>=0.91 xmlto-[0-9]* getopt-[0-9]* docbook-xsl>=1.67.0nb1 docbook-xml>=4.2 perl>=5.0 libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 docbook-xml-[0-9]* docbook-xsl-[0-9]* libxslt>=1.1.28nb2 qt4-libs>=4.8.7 qt4-libs>=4.8.7nb12 desktop-file-utils>=0.8 glib2>=2.4.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 pcre>=8.30nb1 glib2>=2.34.0 kdelibs4>=4.0.0 docbook-xsl>=1.75 zonetab-[0-9]* qt4-tools>=4.4.0 libtool-base-[0-9]* qt4-tools>=4.1.0 strigi>=0.5.11 cppunit>=1.10.2 exiv2>=0.18 gettext-tools-[0-9]* gettext-lib>=0.18 libclucene>=2.3.3.4 boost-libs-1.68.* icu>=3.4 icu>=62.1 boost-headers-1.68.* boost-jam-1.68.* boost-libs>=1.68.0 libclucene>=2.2.0 fam>=2.6.10 cppunit>=1.10.2nb5 exiv2>=0.24 libclucene>=2.3.3.4nb12 qt4-qdbus>=4.8.7nb2 fam>=2.7.0nb7 qt4-tools>=4.8.7nb3 strigi>=0.6.2 shared-mime-info>=0.15 grantlee>=0.3.0 libdbusmenu-qt>=0.8.2 hicolor-icon-theme>=0.4 jasper>=1.600.0 giflib>=5.1.0 openexr>=1.6.1 ilmbase>=1.0.2nb1 ilmbase>=1.0.1 ilmbase>=2.2.0nb1 attica>=0.1.2 phonon>=4.5.0 polkit-qt>=0.9.2 polkit>=0.103 spidermonkey52>=52.0.0 nspr>=4.9.3.2 libxslt-[0-9]* automoc4>=0.9.87 qca2>=2.0.0 mozilla-rootcerts-[0-9]* aspell>=0.50.3 ncurses>=5.3nb1 ncurses>=6.0 enchant>=1.1.3 hunspell-en_US-[0-9]* hunspell>=1.2.2 hunspell>=1.3.2 libXScrnSaver>=1.1.2 libXpm>=3.5.4.2 libXtst>=1.0.1 strigi>=0.7.8nb23 shared-mime-info>=1.0nb1 grantlee>=0.5.1nb4 libdbusmenu-qt>=0.9.3.16.04.20160218nb1 hicolor-icon-theme>=0.9nb1 jasper>=1.900.1nb7 openexr>=2.2.0nb3 attica>=0.4.2nb4 phonon>=4.9.1nb2 polkit-qt>=0.112.0nb1 qca2>=2.1.3nb1 aspell>=0.60.6nb3 enchant>=1.6.0nb5 desktop-file-utils>=0.10nb1 libXdamage>=1.0.3 kdelibs4>=4.14.38nb3 .

This package requires the following package(s) to run: qt4-libs>=4.4.0 glu>=3.4.2 MesaLib>=3.4.2 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 MesaLib>=7.11.2 glu>=6.0 xcursor>=1.0 Xfixes>=2.0.0 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xfixes>=2.0.1nb2 Xrender>=0.9.0nb1 xcursor>=1.1.1 Xft2>=2.1 fontconfig>=2.2 libuuid>=2.18 freetype2>=2.8.1 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.10.93 fontconfig>=2.1nb2 Xrender>=0.9.0nb2 fontconfig>=2.13.0 Xft2>=2.1nb2 Xrandr>=0.99 Xrandr>=1.0.1 jpeg>=8nb1 png>=1.2.4 glu>=7.11.2 xcursor>=1.1.2nb1 Xft2>=2.1.7nb7 Xrandr>=1.0.2nb3 jpeg>=9 png>=1.6.0nb1 qt4-libs>=4.6.1nb2 qt4-qdbus>=4.3.2 dbus>=0.91 qt4-libs>=4.8.7 qt4-libs>=4.8.7nb12 desktop-file-utils>=0.8 glib2>=2.4.0 perl>=5.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 glib2>=2.34.0 kdelibs4>=4.0.0 docbook-xml>=4.2 xmlcatmgr>=2.0beta1 docbook-xsl>=1.75 zonetab-[0-9]* qt4-tools>=4.4.0 libtool-base-[0-9]* qt4-tools>=4.1.0 strigi>=0.5.11 cppunit>=1.10.2 exiv2>=0.18 libclucene>=2.3.3.4 boost-libs-1.68.* icu>=3.4 icu>=62.1 boost-libs>=1.68.0 libclucene>=2.2.0 libxml2>=2.6.2 fam>=2.6.10 cppunit>=1.10.2nb5 exiv2>=0.24 libclucene>=2.3.3.4nb12 libxml2>=2.8.0nb2 qt4-qdbus>=4.8.7nb2 fam>=2.7.0nb7 strigi>=0.6.2 shared-mime-info>=0.15 grantlee>=0.3.0 libdbusmenu-qt>=0.8.2 hicolor-icon-theme>=0.4 jasper>=1.600.0 giflib>=5.1.0 openexr>=1.6.1 ilmbase>=1.0.2nb1 ilmbase>=1.0.1 ilmbase>=2.2.0nb1 attica>=0.1.2 phonon>=4.5.0 qt4-tools>=4.8.7nb3 polkit-qt>=0.9.2 polkit>=0.103 spidermonkey52>=52.0.0 py27-expat-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 python27>=2.7.1nb2 nspr>=4.9.3.2 qca2>=2.0.0 mozilla-rootcerts-[0-9]* aspell>=0.50.3 ncurses>=5.3nb1 ncurses>=6.0 enchant>=1.1.3 hunspell-en_US-[0-9]* hunspell>=1.2.2 hunspell>=1.3.2 libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 libXScrnSaver>=1.1.2 libXpm>=3.5.4.2 libXtst>=1.0.1 strigi>=0.7.8nb23 shared-mime-info>=1.0nb1 grantlee>=0.5.1nb4 libdbusmenu-qt>=0.9.3.16.04.20160218nb1 hicolor-icon-theme>=0.9nb1 jasper>=1.900.1nb7 openexr>=2.2.0nb3 attica>=0.4.2nb4 phonon>=4.9.1nb2 polkit-qt>=0.112.0nb1 qca2>=2.1.3nb1 aspell>=0.60.6nb3 enchant>=1.6.0nb5 libxslt>=1.1.28nb2 desktop-file-utils>=0.10nb1 libXdamage>=1.0.3 kdelibs4>=4.14.38nb3 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
earm:krfb-4.14.3.tgz(NetBSD 7.0)
earmv6hf:krfb-4.14.3nb2.tgz(NetBSD 7.0)
earmv6hf:krfb-4.14.3nb8.tgz(NetBSD 8.0)
earmv7hf:krfb-4.14.3nb2.tgz(NetBSD 7.0)
earmv7hf:krfb-4.14.3nb10.tgz(NetBSD 8.0)
earmv7hfeb:krfb-4.14.3nb3.tgz(NetBSD 7.0)
earmv7hfeb:krfb-4.14.3nb8.tgz(NetBSD 8.0)
i386:krfb-4.14.3nb11.tgz(NetBSD 7.0)
i386:krfb-4.14.3nb7.tgz(NetBSD 7.0)
i386:krfb-4.14.3nb8.tgz(NetBSD 7.0)
i386:krfb-4.14.3nb10.tgz(NetBSD 7.0)
i386:krfb-4.14.3nb11.tgz(NetBSD 7.1)
i386:krfb-4.14.3nb8.tgz(NetBSD 7.1)
i386:krfb-4.14.3nb10.tgz(NetBSD 7.1)
i386:krfb-4.14.3nb11.tgz(NetBSD 8.0)
i386:krfb-4.14.3nb8.tgz(NetBSD 8.0)
i386:krfb-4.14.3nb10.tgz(NetBSD 8.0)
powerpc:krfb-4.14.3nb10.tgz(NetBSD 8.0)
sparc64:krfb-4.14.3nb2.tgz(NetBSD 7.0)
x86_64:krfb-4.14.3nb11.tgz(NetBSD 7.0)
x86_64:krfb-4.14.3nb8.tgz(NetBSD 7.0)
x86_64:krfb-4.14.3nb8.tgz(NetBSD 7.0)
x86_64:krfb-4.14.3nb10.tgz(NetBSD 7.0)
x86_64:krfb-4.14.3nb7.tgz(NetBSD 7.0.1_PATCH)
x86_64:krfb-4.14.3nb11.tgz(NetBSD 7.1)
x86_64:krfb-4.14.3nb8.tgz(NetBSD 7.1)
x86_64:krfb-4.14.3nb10.tgz(NetBSD 7.1)
x86_64:krfb-4.14.3nb11.tgz(NetBSD 8.0)
x86_64:krfb-4.14.3nb7.tgz(NetBSD 8.99.1)
x86_64:krfb-4.14.3nb8.tgz(NetBSD 8.0)
x86_64:krfb-4.14.3nb8.tgz(NetBSD 8.0)
x86_64:krfb-4.14.3nb10.tgz(NetBSD 8.0)
x86_64:krfb-4.14.3nb8.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]