Daemon Power

The NetBSD Packages Collection: net/ocamlnet

Brief description of the package:
Library focusing on application-level network protocols (OCaml)

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://projects.camlcity.org/projects/ocamlnet.html.

Please note that this package has a zlib license.

The package is located in the "net/ocamlnet" directory. The current source version of the package is "ocamlnet-4.1.6nb2". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for net/ocamlnet :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ocaml-findlib>=1.2 ocaml>=4.07.0 cwrappers>=20150314 gnutls>=3.3.0 lzo>=2.01 gmp>=5.0 gmp>=4.2.1 libcfg+>=0.6.2nb1 libtasn1>=4.9 libtasn1>=0.2.7 nettle>=3.1 gmp>=5.0.1 nettle>=2.4 p11-kit>=0.23.1 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 libtasn1>=0.3.0 p11-kit>=0.10 p11-kit>=0.23 libunistring>=0.9.3 libcfg+>=0.6.2nb3 nettle>=3.1.1 libunistring>=0.9.4 pcre-ocaml>=5.10.3nb1 ocaml-jbuilder>=1.0_beta13nb1 ocaml-findlib>=1.8.0nb2 ocaml-base>=0.9.3 ocaml-sexplib0>=0.11.0 ocaml-jbuilder>=1.0_beta20nb1 ocaml-opaline>=0.3.1 ocaml-opam-file-format>=2.0.0beta ocaml-opam-file-format>=2.0.0beta3nb4 ocamlbuild>=0.9.2 ocamlbuild>=0.12.0nb2 ocaml-opaline>=0.3.1nb1 ocaml-sexplib0>=0.11.0nb1 ocaml-configurator>=0.9.1 ocaml-stdio>=0.9.0 ocaml-sexplib>=0.9.0 ocaml-parsexp>=0.11.0 ocaml-num>=1.1 ocaml-parsexp>=0.11.0nb1 ocaml-num>=1.1nb2 ocaml-base>=0.11.1 ocaml-sexplib>=0.11.0nb1 ocaml-stdio>=0.11.0nb1 pcre>=3.4nb1 ocaml-configurator>=0.11.0nb1 pcre>=8.30nb1 ocaml-zip>=1.05nb6 gnutls>=3.6.0nb1 pcre-ocaml>=7.3.4nb3 ocaml-zip>=1.07nb4 .

This package requires the following package(s) to run: ocaml-findlib>=1.2 ocaml>=4.07.0 gnutls>=3.3.0 lzo>=2.01 gmp>=5.0 gmp>=4.2.1 libcfg+>=0.6.2nb1 libtasn1>=4.9 libtasn1>=0.2.7 nettle>=3.1 gmp>=5.0.1 nettle>=2.4 p11-kit>=0.23.1 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 libtasn1>=0.3.0 p11-kit>=0.10 p11-kit>=0.23 libunistring>=0.9.3 libcfg+>=0.6.2nb3 nettle>=3.1.1 libunistring>=0.9.4 pcre-ocaml>=5.10.3nb1 ocaml-jbuilder>=1.0_beta13nb1 ocaml-findlib>=1.8.0nb2 ocaml-base>=0.9.3 ocaml-sexplib0>=0.11.0 ocaml-jbuilder>=1.0_beta20nb1 ocaml-sexplib0>=0.11.0nb1 ocaml-configurator>=0.9.1 ocaml-stdio>=0.9.0 ocaml-sexplib>=0.9.0 ocaml-parsexp>=0.11.0 ocaml-num>=1.1 ocaml-parsexp>=0.11.0nb1 ocaml-num>=1.1nb2 ocaml-base>=0.11.1 ocaml-sexplib>=0.11.0nb1 ocaml-stdio>=0.11.0nb1 pcre>=3.4nb1 ocaml-configurator>=0.11.0nb1 pcre>=8.30nb1 ocaml-zip>=1.05nb6 gnutls>=3.6.0nb1 pcre-ocaml>=7.3.4nb3 ocaml-zip>=1.07nb4 .

This package supports the following build-time options:

gnutls
Enable GNU TLS support.
gtk
Enable support for GTK.
gtk2
Enable support for GTK2.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
i386:ocamlnet-4.1.1nb2.tgz(NetBSD 6.0)
i386:ocamlnet-4.1.1nb3.tgz(NetBSD 6.0)
i386:ocamlnet-4.1.2nb2.tgz(NetBSD 6.0)
i386:ocamlnet-4.1.2nb3.tgz(NetBSD 6.0)
i386:ocamlnet-4.1.4nb2.tgz(NetBSD 6.0)
i386:ocamlnet-4.1.1nb2.tgz(NetBSD 6.1)
i386:ocamlnet-4.1.1nb3.tgz(NetBSD 6.1)
i386:ocamlnet-4.1.2nb2.tgz(NetBSD 6.1)
i386:ocamlnet-4.1.2nb3.tgz(NetBSD 6.1)
i386:ocamlnet-4.1.4nb2.tgz(NetBSD 6.1)
i386:ocamlnet-4.1.1nb2.tgz(NetBSD 7.0)
i386:ocamlnet-4.1.1nb3.tgz(NetBSD 7.0)
i386:ocamlnet-4.1.2nb2.tgz(NetBSD 7.0)
i386:ocamlnet-4.1.2nb3.tgz(NetBSD 7.0)
i386:ocamlnet-4.1.4nb2.tgz(NetBSD 7.0)
x86_64:ocamlnet-4.1.4nb2.tgz(NetBSD 6.0)
x86_64:ocamlnet-4.1.5nb2.tgz(NetBSD 6.0)
x86_64:ocamlnet-4.1.4nb2.tgz(NetBSD 6.1)
x86_64:ocamlnet-4.1.5nb2.tgz(NetBSD 6.1)
x86_64:ocamlnet-4.1.4nb2.tgz(NetBSD 7.0)
x86_64:ocamlnet-4.1.5nb2.tgz(NetBSD 7.0)
x86_64:ocamlnet-4.1.2nb3.tgz(NetBSD 7.0.1_PATCH)
x86_64:ocamlnet-4.1.5nb2.tgz(NetBSD 7.1)
x86_64:ocamlnet-4.1.5nb1.tgz(NetBSD 7.1.1)
x86_64:ocamlnet-4.1.2nb3.tgz(NetBSD 8.99.1)
x86_64:ocamlnet-4.1.4nb2.tgz(NetBSD 8.0)
x86_64:ocamlnet-4.1.5nb2.tgz(NetBSD 8.0)
x86_64:ocamlnet-4.1.2nb5.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]