Daemon Power

The NetBSD Packages Collection: net/py-s3transfer

Brief description of the package:
Amazon S3 Transfer Manager

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://github.com/boto/s3transfer.

Please note that this package has a apache-2.0 license.

The package is located in the "net/py-s3transfer" directory. The current source version of the package is "py27-s3transfer-0.1.12". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for net/py-s3transfer :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: py27-botocore>=1.3.0 py27-dateutil>=2.5.3 py27-six-[0-9]* py27-setuptools>=0.8 py27-expat-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 cwrappers>=20150314 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 py27-docutils>=0.12 py27-roman>=1.4 py27-expat>=0 py27-jmespath>=0.7.1 py27-futures>=2.2.0 .

This package requires the following package(s) to run: py27-botocore>=1.3.0 py27-dateutil>=2.5.3 py27-six-[0-9]* py27-setuptools>=0.8 py27-expat-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 python27>=2.7.1nb2 py27-docutils>=0.12 py27-roman>=1.4 py27-expat>=0 py27-jmespath>=0.7.1 py27-futures>=2.2.0 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
i386:py27-s3transfer-0.1.11.tgz(NetBSD 6.0)
i386:py34-s3transfer-0.1.11.tgz(NetBSD 6.0)
i386:py35-s3transfer-0.1.11.tgz(NetBSD 6.0)
i386:py36-s3transfer-0.1.11.tgz(NetBSD 6.0)
i386:py27-s3transfer-0.1.11.tgz(NetBSD 6.1)
i386:py34-s3transfer-0.1.11.tgz(NetBSD 6.1)
i386:py35-s3transfer-0.1.11.tgz(NetBSD 6.1)
i386:py36-s3transfer-0.1.11.tgz(NetBSD 6.1)
i386:py27-s3transfer-0.1.11.tgz(NetBSD 7.0)
i386:py34-s3transfer-0.1.11.tgz(NetBSD 7.0)
i386:py35-s3transfer-0.1.11.tgz(NetBSD 7.0)
i386:py36-s3transfer-0.1.11.tgz(NetBSD 7.0)
powerpc:py27-s3transfer-0.1.11.tgz(NetBSD 7.1)
powerpc:py34-s3transfer-0.1.11.tgz(NetBSD 7.1)
powerpc:py35-s3transfer-0.1.11.tgz(NetBSD 7.1)
powerpc:py36-s3transfer-0.1.11.tgz(NetBSD 7.1)
powerpc:py27-s3transfer-0.1.11.tgz(NetBSD 8.0)
powerpc:py34-s3transfer-0.1.11.tgz(NetBSD 8.0)
powerpc:py35-s3transfer-0.1.11.tgz(NetBSD 8.0)
powerpc:py36-s3transfer-0.1.11.tgz(NetBSD 8.0)
x86_64:py27-s3transfer-0.1.11.tgz(NetBSD 6.0)
x86_64:py34-s3transfer-0.1.11.tgz(NetBSD 6.0)
x86_64:py35-s3transfer-0.1.11.tgz(NetBSD 6.0)
x86_64:py36-s3transfer-0.1.11.tgz(NetBSD 6.0)
x86_64:py27-s3transfer-0.1.11.tgz(NetBSD 6.1)
x86_64:py34-s3transfer-0.1.11.tgz(NetBSD 6.1)
x86_64:py35-s3transfer-0.1.11.tgz(NetBSD 6.1)
x86_64:py36-s3transfer-0.1.11.tgz(NetBSD 6.1)
x86_64:py27-s3transfer-0.1.11.tgz(NetBSD 7.0)
x86_64:py34-s3transfer-0.1.11.tgz(NetBSD 7.0)
x86_64:py35-s3transfer-0.1.11.tgz(NetBSD 7.0)
x86_64:py36-s3transfer-0.1.11.tgz(NetBSD 7.0)
x86_64:py27-s3transfer-0.1.10.tgz(NetBSD 8.99.1)
x86_64:py34-s3transfer-0.1.10.tgz(NetBSD 8.99.1)
x86_64:py35-s3transfer-0.1.10.tgz(NetBSD 8.99.1)
x86_64:py36-s3transfer-0.1.10.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]