Daemon Power

The NetBSD Packages Collection: net/rabbiter

Brief description of the package:
Twitter client for Rabbit

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://rabbit-shocker.org/en/rabbiter/.

Please note that this package has a gnu-gpl-v2 license.

The package is located in the "net/rabbiter" directory. The current source version of the package is "ruby23-rabbiter-2.0.1nb1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for net/rabbiter :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ruby23-rabbit>=2.0.0 ruby23-gnome2-gtk>=0.90.3 ruby23-gnome2-atk>=3.2.0 ruby23-gnome2-glib>=3.2.0 ruby23-native-package-installer>=1.0.3 ruby23-base>=2.3.5 libyaml>=0.1.1 cwrappers>=20150314 libyaml>=0.1.4 ruby23-pkg-config>=1.2.2 glib2>=2.4.0 perl>=5.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 glib2>=2.34.0 atk>=1.11.4 glib2>=2.31.2 gobject-introspection>=0.6.14nb1 py27-cElementTree-[0-9]* py27-expat-[0-9]* glib2>=2.54.0 libffi>=3.0.0 gobject-introspection>=1.34.0 ruby23-gnome2-glib>=0.17.0 atk>=2.6.0 ruby23-gnome2-glib>=2.2.0 ruby23-gnome2-pango>=3.2.0 ruby23-cairo>=1.14.3 ruby23-native-package-installer>=0 cairo>=1.2.0 MesaLib>=3.4.2 libXdamage>=1.0.3 Xfixes>=2.0.0 x11-links>=1.06 osabi-NetBSD-7.0.1 fixesproto>=3.0.0<5 xextproto>=7.0 inputproto>=1.4 xproto>=7.0.9 Xfixes>=2.0.1nb2 damageproto>=1.1.0 libdrm>=2.4.60 libdrm>=2.4.15 libva>=1.0.6 libvdpau>=0.3 dri2proto>=2.0 libLLVM>=4.0 libLLVM>=4.0.0 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.12 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 xcb-proto>=1.4 py27-mako-[0-9]* py27-setuptools>=0.8 dri2proto>=2.1 glproto>=1.4.11 glproto>=1.4.6 xf86driproto>=2.0.3 xf86vidmodeproto>=2.3 Xrender>=0.2 renderproto>=0.9.3nb1 renderproto>=0.9 Xrender>=0.8.2 lzo>=2.01 fontconfig>=2.2.95 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 gperf-[0-9]* fontconfig>=2.10.93 fontconfig>=2.1nb2 freetype2>=2.1.9 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 MesaLib>=7.11.2 Xrender>=0.9.0nb1 fontconfig>=2.10.93nb2 png>=1.6.0nb1 cairo>=1.0.0nb2 cairo>=1.14.2nb1 ruby23-pkg-config-[0-9]* ruby23-gnome2-cairo-gobject>=3.2.0 ruby23-cairo>=1.6.0 cairo-gobject>=1.10.2 glib2>=2.14.0 ruby23-cairo>=1.14.1nb1 cairo-gobject>=1.14.2nb1 pango>=1.6.0 Xft2>=2.1.7nb3 fontconfig>=2.2 Xrender>=0.9.0nb2 Xft2>=2.1 Xft2>=2.1nb2 fontconfig>=2.10.91 Xrender>=0.8 glib2>=2.33.12 harfbuzz>=0.9.9 icu>=3.4 icu>=59.1nb1 harfbuzz>=0.9.4 cairo>=1.12.10 Xft2>=2.1.7nb6 harfbuzz>=1.4.2nb1 help2man-[0-9]* p5-gettext>=1.01 perl>=5.26.0 perl<5.28.0 pango>=1.40.3nb2 ruby23-gnome2-gdkpixbuf>=3.2.0 ruby23-gnome2-gio>=3.2.0 ruby23-gnome2-gobject-introspection>=3.2.0 gobject-introspection>=1.32.1 ruby23-gnome2-gobject-introspection>=1.2.0 ruby23-gnome2-gobject-introspection>=2.2.0 gdk-pixbuf2>=2.36.4 shared-mime-info>=0.15 glib2>=2.37.2 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 shared-mime-info>=1.0nb1 tiff>=4.0.3nb5 ruby23-gnome2-gio>=1.2.0 gdk-pixbuf2>=2.22.0 gdk-pixbuf2>=2.34.0nb1 ruby23-gnome2-pango>=0.16.0 gtk2+>=2.4.0 atk>=1.30.0 glib2>=2.28.0 xcursor>=1.0 xcursor>=1.1.1 Xft2>=2.1.2nb2 libXi>=1.3.0 inputproto>=2.3 xextproto>=7.0.3 xproto>=7.0.13 libXi>=1.0.0 Xrandr>=0.99 randrproto>=1.2.0 randrproto>=1.0 Xrandr>=1.0.1 libXcomposite>=0.3.1 compositeproto>=0.4 compositeproto>=0.3.1 pango>=1.20.0 cairo>=1.6.0 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 gobject-introspection>=0.9.3 ruby23-gnome2-pango>=3.1.1nb2 gtk2+>=2.24.31nb2 ruby23-gnome2-rsvg-[0-9]* librsvg>=2.12.6nb1 glib2>=2.24.0 libcroco>=0.6.1 libcroco>=0.6.0 libcroco>=0.6.5nb2 librsvg>=2.40.15nb4 ruby23-gnome2-poppler-[0-9]* poppler-glib>=0.8.0 openjpeg>=2.1.0 lcms2>=2.2 poppler-0.59.0{,nb*} poppler>=0.5.1 poppler>=0.59.0 glib2>=2.41.0 poppler-glib>=0.5.1 poppler-glib>=0.59.0 ruby23-hikidoc-[0-9]* ruby23-nokogiri-[0-9]* ruby23-mini_portile2>=2.3.0<2.4.0 libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 docbook-xml-[0-9]* docbook-xsl-[0-9]* docbook-xml>=4.2 libxslt>=1.1.28nb2 ruby23-rdtool>=0.6.20 ruby23-rttool-[0-9]* ruby23-rdtool>=0.6.18 ruby23-coderay>=1.0.0 ruby23-kramdown-[0-9]* ruby23-gettext>=3.0.1 ruby23-locale>=2.0.5 ruby23-text>=1.3.0 ruby23-faraday-[0-9]* ruby23-multipart-post>=1.2<3 ruby23-rouge-[0-9]* ruby23-setup>=3.4.0 ruby23-twitter_oauth-[0-9]* ruby23-mime-types>=1.16 ruby23-mime-types-data>=3.2015<4 ruby23-oauth>=0.4.7 ruby23-twitter-stream>=0.1.16 ruby23-eventmachine>=0.12.8 ruby23-simple_oauth>=0.1.4 ruby23-http_parser.rb>=0.5.1 .

This package requires the following package(s) to run: ruby23-rabbit>=2.0.0 ruby23-gnome2-gtk>=0.90.3 ruby23-gnome2-atk>=3.2.0 ruby23-gnome2-glib>=3.2.0 ruby23-native-package-installer>=1.0.3 ruby23-base>=2.3.5 libyaml>=0.1.1 libyaml>=0.1.4 ruby23-pkg-config>=1.2.2 glib2>=2.4.0 perl>=5.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 libffi>=1.20 pcre>=8.30nb1 libffi>=3.0.11 glib2>=2.34.0 atk>=1.11.4 glib2>=2.31.2 ruby23-gnome2-glib>=0.17.0 atk>=2.6.0 ruby23-gnome2-glib>=2.2.0 ruby23-gnome2-pango>=3.2.0 ruby23-cairo>=1.14.3 ruby23-native-package-installer>=0 cairo>=1.2.0 MesaLib>=3.4.2 libXdamage>=1.0.3 Xfixes>=2.0.0 Xfixes>=2.0.1nb2 libdrm>=2.4.60 libdrm>=2.4.15 libva>=1.0.6 libvdpau>=0.3 libLLVM>=4.0 libLLVM>=4.0.0 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 Xrender>=0.2 Xrender>=0.8.2 lzo>=2.01 fontconfig>=2.2.95 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.10.93 fontconfig>=2.1nb2 freetype2>=2.1.9 png>=1.2.4 pixman>=0.30.0 pixman>=0.25.2 MesaLib>=7.11.2 Xrender>=0.9.0nb1 fontconfig>=2.10.93nb2 png>=1.6.0nb1 cairo>=1.0.0nb2 cairo>=1.14.2nb1 ruby23-gnome2-cairo-gobject>=3.2.0 ruby23-cairo>=1.6.0 cairo-gobject>=1.10.2 glib2>=2.14.0 ruby23-cairo>=1.14.1nb1 cairo-gobject>=1.14.2nb1 pango>=1.6.0 Xft2>=2.1.7nb3 fontconfig>=2.2 Xrender>=0.9.0nb2 Xft2>=2.1 Xft2>=2.1nb2 fontconfig>=2.10.91 Xrender>=0.8 glib2>=2.33.12 harfbuzz>=0.9.9 icu>=3.4 icu>=59.1nb1 harfbuzz>=0.9.4 cairo>=1.12.10 Xft2>=2.1.7nb6 harfbuzz>=1.4.2nb1 pango>=1.40.3nb2 ruby23-gnome2-gdkpixbuf>=3.2.0 ruby23-gnome2-gio>=3.2.0 ruby23-gnome2-gobject-introspection>=3.2.0 gobject-introspection>=1.32.1 py27-cElementTree-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 python27>=2.7.1nb2 py27-expat-[0-9]* glib2>=2.54.0 libffi>=3.0.0 gobject-introspection>=0.6.14nb1 gobject-introspection>=1.34.0 ruby23-gnome2-gobject-introspection>=1.2.0 ruby23-gnome2-gobject-introspection>=2.2.0 gdk-pixbuf2>=2.36.4 shared-mime-info>=0.15 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 glib2>=2.37.2 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 shared-mime-info>=1.0nb1 tiff>=4.0.3nb5 ruby23-gnome2-gio>=1.2.0 gdk-pixbuf2>=2.22.0 gdk-pixbuf2>=2.34.0nb1 ruby23-gnome2-pango>=0.16.0 gtk2+>=2.4.0 atk>=1.30.0 glib2>=2.28.0 xcursor>=1.0 xcursor>=1.1.1 Xft2>=2.1.2nb2 libXi>=1.3.0 libXi>=1.0.0 Xrandr>=0.99 Xrandr>=1.0.1 libXcomposite>=0.3.1 pango>=1.20.0 cairo>=1.6.0 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 ruby23-gnome2-pango>=3.1.1nb2 gtk2+>=2.24.31nb2 ruby23-gnome2-rsvg-[0-9]* librsvg>=2.12.6nb1 glib2>=2.24.0 libcroco>=0.6.1 libcroco>=0.6.0 libcroco>=0.6.5nb2 librsvg>=2.40.15nb4 ruby23-gnome2-poppler-[0-9]* poppler-glib>=0.8.0 openjpeg>=2.1.0 lcms2>=2.2 poppler-0.59.0{,nb*} poppler>=0.5.1 poppler>=0.59.0 glib2>=2.41.0 poppler-glib>=0.5.1 poppler-glib>=0.59.0 ruby23-hikidoc-[0-9]* ruby23-nokogiri-[0-9]* ruby23-mini_portile2>=2.3.0<2.4.0 libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 libxslt>=1.1.28nb2 ruby23-rdtool>=0.6.20 ruby23-rttool-[0-9]* ruby23-rdtool>=0.6.18 ruby23-coderay>=1.0.0 ruby23-kramdown-[0-9]* ruby23-gettext>=3.0.1 ruby23-locale>=2.0.5 ruby23-text>=1.3.0 ruby23-faraday-[0-9]* ruby23-multipart-post>=1.2<3 ruby23-rouge-[0-9]* ruby23-twitter_oauth-[0-9]* ruby23-mime-types>=1.16 ruby23-mime-types-data>=3.2015<4 ruby23-oauth>=0.4.7 ruby23-twitter-stream>=0.1.16 ruby23-eventmachine>=0.12.8 ruby23-simple_oauth>=0.1.4 ruby23-http_parser.rb>=0.5.1 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
arm:ruby200-rabbiter-2.0.1.tgz(NetBSD 6.1_STABLE)
earm:ruby200-rabbiter-2.0.1.tgz(NetBSD 7.0)
earm:ruby22-rabbiter-2.0.1.tgz(NetBSD 7.0)
earm:ruby200-rabbiter-2.0.1.tgz(NetBSD 7.0)
earm:ruby21-rabbiter-2.0.1.tgz(NetBSD 7.0)
earm:ruby22-rabbiter-2.0.1.tgz(NetBSD 7.0)
earmv6hf:ruby200-rabbiter-2.0.1.tgz(NetBSD 7.0)
earmv6hf:ruby21-rabbiter-2.0.1.tgz(NetBSD 7.0)
earmv6hf:ruby22-rabbiter-2.0.1.tgz(NetBSD 7.0)
earmv7hf:ruby200-rabbiter-2.0.1.tgz(NetBSD 7.0)
earmv7hf:ruby21-rabbiter-2.0.1.tgz(NetBSD 7.0)
earmv7hf:ruby22-rabbiter-2.0.1.tgz(NetBSD 7.0)
earmv7hf:ruby193-rabbiter-2.0.1.tgz(NetBSD 7.0)
earmv7hf:ruby200-rabbiter-2.0.1.tgz(NetBSD 7.0)
earmv7hf:ruby21-rabbiter-2.0.1.tgz(NetBSD 7.0)
earmv7hf:ruby22-rabbiter-2.0.1.tgz(NetBSD 7.0)
earmv7hf:ruby22-rabbiter-2.0.1nb1.tgz(NetBSD 8.0_BETA)
earmv7hf:ruby23-rabbiter-2.0.1nb1.tgz(NetBSD 8.0_BETA)
i386:ruby21-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
i386:ruby22-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
i386:ruby23-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
i386:ruby21-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
i386:ruby22-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
i386:ruby23-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
i386:ruby21-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
i386:ruby22-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
i386:ruby23-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
i386:ruby22-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
i386:ruby23-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
i386:ruby24-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
powerpc:ruby21-rabbiter-2.0.1nb1.tgz(NetBSD 7.1)
powerpc:ruby22-rabbiter-2.0.1nb1.tgz(NetBSD 7.1)
powerpc:ruby23-rabbiter-2.0.1nb1.tgz(NetBSD 7.1)
powerpc:ruby24-rabbiter-2.0.1nb1.tgz(NetBSD 7.1)
powerpc:ruby21-rabbiter-2.0.1nb1.tgz(NetBSD 7.1)
powerpc:ruby22-rabbiter-2.0.1nb1.tgz(NetBSD 7.1)
powerpc:ruby23-rabbiter-2.0.1nb1.tgz(NetBSD 7.1)
powerpc:ruby24-rabbiter-2.0.1nb1.tgz(NetBSD 7.1)
powerpc:ruby22-rabbiter-2.0.1nb1.tgz(NetBSD 8.0)
powerpc:ruby23-rabbiter-2.0.1nb1.tgz(NetBSD 8.0)
powerpc:ruby24-rabbiter-2.0.1nb1.tgz(NetBSD 8.0)
powerpc:ruby22-rabbiter-2.0.1nb1.tgz(NetBSD 8.0)
powerpc:ruby23-rabbiter-2.0.1nb1.tgz(NetBSD 8.0)
powerpc:ruby24-rabbiter-2.0.1nb1.tgz(NetBSD 8.0)
sparc:ruby193-rabbiter-2.0.1.tgz(NetBSD 6.0)
sparc:ruby200-rabbiter-2.0.1.tgz(NetBSD 6.0)
x86_64:ruby22-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
x86_64:ruby23-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
x86_64:ruby24-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
x86_64:ruby21-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
x86_64:ruby22-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
x86_64:ruby23-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
x86_64:ruby21-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
x86_64:ruby22-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
x86_64:ruby23-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
x86_64:ruby21-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
x86_64:ruby22-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
x86_64:ruby23-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
x86_64:ruby22-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
x86_64:ruby23-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
x86_64:ruby24-rabbiter-2.0.1nb1.tgz(NetBSD 7.0)
x86_64:ruby22-rabbiter-2.0.1nb1.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby23-rabbiter-2.0.1nb1.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby24-rabbiter-2.0.1nb1.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby22-rabbiter-2.0.1nb1.tgz(NetBSD 8.99.1)
x86_64:ruby23-rabbiter-2.0.1nb1.tgz(NetBSD 8.99.1)
x86_64:ruby24-rabbiter-2.0.1nb1.tgz(NetBSD 8.99.1)
x86_64:ruby22-rabbiter-2.0.1nb1.tgz(NetBSD 8.99.1)
x86_64:ruby23-rabbiter-2.0.1nb1.tgz(NetBSD 8.99.1)
x86_64:ruby24-rabbiter-2.0.1nb1.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]