Daemon Power

The NetBSD Packages Collection: net/snort

Brief description of the package:
The Open Source Network Intrusion Detection System

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://www.snort.org/.

Please note that this package has a gnu-gpl-v2 license.

The package is located in the "net/snort" directory. The current source version of the package is "snort-2.9.9.0". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for net/snort :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: daq>=2.0.0 libdnet>=1.7 cwrappers>=20150314 libdnet>=1.10nb1 bison-[0-9]* m4>=1.4 pcre>=3.4nb1 pcre>=8.30nb1 .

This package requires the following package(s) to run: daq>=2.0.0 libdnet>=1.7 libdnet>=1.10nb1 pcre>=3.4nb1 pcre>=8.30nb1 .

This package supports the following build-time options:

debug
Enable debugging facilities in the package.
inet6
Enable support for IPv6.
snmp
Enable SNMP support.
snort-dynamicplugin
snort-gre
snort-prelude
Enable support for the Prelude Hybrid IDS system.
snort-rulestate
snort-timestats
ssl
Enable SSL support.
snort-flexresp
Flexible responses on hostile connection attempts.
snort-flexresp2
Newer flexible responses on hostile connection attempts.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:snort-2.8.5.1nb7.tgz(NetBSD 7.0)
alpha:snort-2.8.5.1nb7.tgz(NetBSD 7.0)
alpha:snort-2.8.5.1nb7.tgz(NetBSD 7.0)
alpha:snort-2.9.9.0.tgz(NetBSD 8.0)
arm:snort-2.8.5.1nb6.tgz(NetBSD 6.1_STABLE)
earm:snort-2.8.5.1nb7.tgz(NetBSD 7.0)
earm:snort-2.8.5.1nb6.tgz(NetBSD 7.0)
earm:snort-2.8.5.1nb7.tgz(NetBSD 7.0)
earmv6hf:snort-2.8.5.1nb6.tgz(NetBSD 7.0)
earmv6hf:snort-2.8.5.1nb6.tgz(NetBSD 7.0)
earmv6hf:snort-2.8.5.1nb7.tgz(NetBSD 7.0)
earmv6hf:snort-2.8.5.1nb7.tgz(NetBSD 7.0)
earmv7hf:snort-2.8.5.1nb7.tgz(NetBSD 7.0)
earmv7hf:snort-2.8.5.1nb7.tgz(NetBSD 7.0)
earmv7hf:snort-2.8.5.1nb7.tgz(NetBSD 7.99.21)
earmv7hf:snort-2.9.9.0.tgz(NetBSD 8.0_BETA)
earmv7hfeb:snort-2.8.5.1nb7.tgz(NetBSD 7.0)
i386:snort-2.8.5.1nb6.tgz(MirBSD 10)
i386:snort-2.9.9.0.tgz(NetBSD 6.0)
i386:snort-2.8.5.1nb8.tgz(NetBSD 6.0)
i386:snort-2.8.5.1nb9.tgz(NetBSD 6.0)
i386:snort-2.8.5.1nb9.tgz(NetBSD 6.0)
i386:snort-2.9.9.0.tgz(NetBSD 6.0)
i386:snort-2.9.9.0.tgz(NetBSD 6.1)
i386:snort-2.8.5.1nb8.tgz(NetBSD 6.1)
i386:snort-2.8.5.1nb9.tgz(NetBSD 6.1)
i386:snort-2.8.5.1nb9.tgz(NetBSD 6.1)
i386:snort-2.9.9.0.tgz(NetBSD 6.1)
i386:snort-2.9.9.0.tgz(NetBSD 7.0)
i386:snort-2.8.5.1nb8.tgz(NetBSD 7.0)
i386:snort-2.8.5.1nb9.tgz(NetBSD 7.0)
i386:snort-2.8.5.1nb9.tgz(NetBSD 7.0)
i386:snort-2.9.9.0.tgz(NetBSD 7.0)
powerpc:snort-2.8.5.1nb8.tgz(NetBSD 6.0)
powerpc:snort-2.9.9.0.tgz(NetBSD 6.1)
powerpc:snort-2.8.5.1nb7.tgz(NetBSD 7.0)
powerpc:snort-2.9.9.0.tgz(NetBSD 7.1)
powerpc:snort-2.9.9.0.tgz(NetBSD 7.1)
powerpc:snort-2.9.9.0.tgz(NetBSD 8.0)
powerpc:snort-2.9.9.0.tgz(NetBSD 8.0)
sh3el:snort-2.8.5.1nb6.tgz(NetBSD 7.0)
sparc64:snort-2.8.5.1nb6.tgz(NetBSD 7.0)
sparc64:snort-2.8.5.1nb7.tgz(NetBSD 7.0)
sparc:snort-2.8.5.1nb6.tgz(NetBSD 5.1)
sparc:snort-2.8.5.1nb6.tgz(NetBSD 5.1)
sparc:snort-2.8.5.1nb6.tgz(NetBSD 6.0)
sparc:snort-2.8.5.1nb6.tgz(NetBSD 6.0)
x86_64:snort-2.9.9.0.tgz(NetBSD 6.0)
x86_64:snort-2.8.5.1nb8.tgz(NetBSD 6.0)
x86_64:snort-2.8.5.1nb9.tgz(NetBSD 6.0)
x86_64:snort-2.8.5.1nb9.tgz(NetBSD 6.0)
x86_64:snort-2.9.9.0.tgz(NetBSD 6.0)
x86_64:snort-2.9.9.0.tgz(NetBSD 6.1)
x86_64:snort-2.8.5.1nb8.tgz(NetBSD 6.1)
x86_64:snort-2.8.5.1nb9.tgz(NetBSD 6.1)
x86_64:snort-2.8.5.1nb9.tgz(NetBSD 6.1)
x86_64:snort-2.9.9.0.tgz(NetBSD 6.1)
x86_64:snort-2.9.9.0.tgz(NetBSD 7.0)
x86_64:snort-2.8.5.1nb8.tgz(NetBSD 7.0)
x86_64:snort-2.8.5.1nb9.tgz(NetBSD 7.0)
x86_64:snort-2.8.5.1nb9.tgz(NetBSD 7.0)
x86_64:snort-2.9.9.0.tgz(NetBSD 7.0)
x86_64:snort-2.9.9.0.tgz(NetBSD 7.0.1_PATCH)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]