Daemon Power

The NetBSD Packages Collection: parallel/slurm

Brief description of the package:
Simple Linux Utility for Resource Management

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://www.schedmd.com/.

Please note that this package has a gnu-gpl-v2 license.

The package is located in the "parallel/slurm" directory. The current source version of the package is "slurm-17.11.5". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for parallel/slurm :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 cwrappers>=20150314 libunistring>=0.9.4 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 munge>=0.5.10 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libgcrypt>=1.6.0 hwloc>=1.4 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 hdf5>=1.8.7 lz4>=1.7.3<100 json-c>=0.12 libssh2>=0.18 lua52>=5.2.0<5.3 mysql-client>=5.7.12<5.8 perl>=5.0 editline>=3.0.20130712nb1 boost-libs-1.66.* icu>=3.4 icu>=61.1 boost-headers-1.66.* boost-jam-1.66.* lz4>=1.7.3 boost-libs>=1.66.0 curl>=7.57.0nb1 python27>=2.7.1nb2 hdf5>=1.8.11 libssh2>=1.7.0nb1 mysql-client>=5.7.12 libtool-base-[0-9]* man2html-[0-9]* .

This package requires the following package(s) to run: curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 munge>=0.5.10 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libgcrypt>=1.6.0 hwloc>=1.4 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 hdf5>=1.8.7 readline>=2.2 lz4>=1.7.3<100 json-c>=0.12 libssh2>=0.18 lua52>=5.2.0<5.3 mysql-client>=5.7.12<5.8 perl>=5.0 editline>=3.0.20130712nb1 boost-libs-1.66.* icu>=3.4 icu>=61.1 lz4>=1.7.3 boost-libs>=1.66.0 curl>=7.57.0nb1 python27>=2.7.1nb2 hdf5>=1.8.11 readline>=6.0 libssh2>=1.7.0nb1 mysql-client>=5.7.12 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:slurm-2.6.4nb8.tgz(NetBSD 7.0)
alpha:slurm-2.6.4nb9.tgz(NetBSD 8.0)
arm:slurm-2.6.4nb2.tgz(NetBSD 6.1_STABLE)
earm:slurm-2.6.4nb7.tgz(NetBSD 7.0)
earm:slurm-2.6.4nb7.tgz(NetBSD 7.0)
earmv6hf:slurm-2.6.4nb7.tgz(NetBSD 7.0)
earmv6hf:slurm-2.6.4nb9.tgz(NetBSD 8.0)
earmv6hf:slurm-2.6.4nb9.tgz(NetBSD 8.0)
earmv7hf:slurm-2.6.4nb7.tgz(NetBSD 7.0)
earmv7hf:slurm-2.6.4nb9.tgz(NetBSD 8.0)
earmv7hf:slurm-2.6.4nb9.tgz(NetBSD 8.0_BETA)
i386:slurm-2.6.4nb9.tgz(NetBSD 6.0)
i386:slurm-2.6.4nb9.tgz(NetBSD 6.0)
i386:slurm-2.6.4nb9.tgz(NetBSD 6.0)
i386:slurm-2.6.4nb9.tgz(NetBSD 6.0)
i386:slurm-2.6.4nb9.tgz(NetBSD 6.0)
i386:slurm-2.6.4nb9.tgz(NetBSD 6.0)
i386:slurm-2.6.4nb9.tgz(NetBSD 6.1)
i386:slurm-2.6.4nb9.tgz(NetBSD 6.1)
i386:slurm-2.6.4nb9.tgz(NetBSD 6.1)
i386:slurm-2.6.4nb9.tgz(NetBSD 6.1)
i386:slurm-2.6.4nb9.tgz(NetBSD 6.1)
i386:slurm-2.6.4nb9.tgz(NetBSD 6.1)
i386:slurm-2.6.4nb9.tgz(NetBSD 7.0)
i386:slurm-2.6.4nb9.tgz(NetBSD 7.0)
i386:slurm-2.6.4nb9.tgz(NetBSD 7.0)
i386:slurm-2.6.4nb9.tgz(NetBSD 7.0)
i386:slurm-2.6.4nb9.tgz(NetBSD 7.0)
i386:slurm-2.6.4nb9.tgz(NetBSD 7.0)
i386:slurm-2.6.4nb9.tgz(NetBSD 7.1)
i386:slurm-2.6.4nb9.tgz(NetBSD 8.0)
powerpc:slurm-2.6.4nb9.tgz(NetBSD 6.1)
powerpc:slurm-2.6.4nb7.tgz(NetBSD 7.0)
powerpc:slurm-2.6.4nb9.tgz(NetBSD 7.1)
powerpc:slurm-2.6.4nb9.tgz(NetBSD 7.1)
powerpc:slurm-2.6.4nb9.tgz(NetBSD 8.0)
powerpc:slurm-2.6.4nb9.tgz(NetBSD 8.0)
sparc64:slurm-2.6.4nb5.tgz(NetBSD 7.0)
x86_64:slurm-2.6.4nb9.tgz(NetBSD 6.0)
x86_64:slurm-2.6.4nb9.tgz(NetBSD 6.0)
x86_64:slurm-2.6.4nb9.tgz(NetBSD 6.1)
x86_64:slurm-2.6.4nb9.tgz(NetBSD 6.1)
x86_64:slurm-2.6.4nb9.tgz(NetBSD 7.0)
x86_64:slurm-2.6.4nb9.tgz(NetBSD 7.0)
x86_64:slurm-2.6.4nb9.tgz(NetBSD 7.0.1_PATCH)
x86_64:slurm-17.11.5.tgz(NetBSD 7.1)
x86_64:slurm-2.6.4nb9.tgz(NetBSD 7.1.1)
x86_64:slurm-2.6.4nb9.tgz(NetBSD 7.1)
x86_64:slurm-17.11.5.tgz(NetBSD 8.0)
x86_64:slurm-2.6.4nb9.tgz(NetBSD 8.99.1)
x86_64:slurm-2.6.4nb9.tgz(NetBSD 8.0)
x86_64:slurm-2.6.4nb9.tgz(NetBSD 8.0)
x86_64:slurm-2.6.4nb9.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]