Daemon Power

The NetBSD Packages Collection: print/hplip

Brief description of the package:
HP Linux Imaging and Printing

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://hplipopensource.com/.

Please note that this package has a gnu-gpl-v2 license.

The package is located in the "print/hplip" directory. The current source version of the package is "hplip-3.16.11". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for print/hplip :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: wget-[0-9]* libidn>=0.4.6 cwrappers>=20150314 libidn>=1.20nb1 py27-reportlab-[0-9]* py27-expat-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 py27-{Pillow-[0-9]*,imaging-[0-9]*} py27-olefile-* py27-setuptools>=0.8 py27-appdirs-[0-9]* py27-packaging-[0-9]* py27-pyparsing-[0-9]* py27-six-[0-9]* freetype2>=2.4.5 freetype2>=2.1.3 lcms2>=2.2 jpeg>=8nb1 tiff>=3.6.1 jbigkit>=2.0 jpeg>=9 tiff>=4.0.3nb5 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.1.0 png>=1.2.4 png>=1.6.0nb1 openjpeg>=2.1.0 freetype2>=2.4.11 libwebp>=0.6.0 libart>=2.3.10nb1 libart>=2.3.16nb1 perl>=5.0 dbus>=0.91 xmlto-[0-9]* getopt-[0-9]* docbook-xsl>=1.67.0nb1 docbook-xml>=4.2 xmlcatmgr>=2.0beta1 libxml2>=2.6.2 bash-[0-9]* libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 libxml2>=2.8.0nb2 docbook-xml-[0-9]* docbook-xsl-[0-9]* libxslt>=1.1.28nb2 x11-links>=1.04 osabi-NetBSD-7.0.1 py27-dbus>=0.23.4 glib2>=2.4.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 pcre>=8.30nb1 dbus>=1.6 dbus-glib>=0.61 glib2>=2.32 dbus>=1.8 glib2>=2.34.0 dbus-glib>=0.100nb1 dbus-python-common>=1.1.1 dbus>=1.0 net-snmp>=5.0.9nb3 perl>=5.24.0 perl<5.26.0 cups>=1.1.19nb3<1.7 poppler-utils-[0-9]* poppler>=0.52.0 fontconfig>=2.10.93 fontconfig>=2.1nb2 fontconfig>=2.10.93nb2 poppler>=0.5.1 poppler>=0.50.0 libusb1>=1.0.9 openslp>=1.0.1 libpaper>=1.1.22 openslp>=1.2.1 ghostscript>=8.63nb1 ghostscript-gpl-[0-9]* ghostscript-fonts>=6.0 libxcb>=1.6 libXdmcp>=0.99 xproto>=7.0.9 libXau>=1.0 xcb-proto>=1.12 xcb-proto>=1.4 py27-dbus>=1.1.1nb1 net-snmp>=5.7.3nb3 cups>=1.5.4nb15 ghostscript>=9.05nb8 .

This package requires the following package(s) to run: wget-[0-9]* libidn>=0.4.6 libidn>=1.20nb1 py27-reportlab-[0-9]* py27-expat-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 python27>=2.7.1nb2 py27-{Pillow-[0-9]*,imaging-[0-9]*} py27-olefile-* py27-setuptools>=0.8 py27-appdirs-[0-9]* py27-packaging-[0-9]* py27-pyparsing-[0-9]* py27-six-[0-9]* freetype2>=2.4.5 freetype2>=2.1.3 lcms2>=2.2 jpeg>=8nb1 tiff>=3.6.1 jbigkit>=2.0 jpeg>=9 tiff>=4.0.3nb5 libimagequant>=2.8.2 libwebp>=0.2.0 giflib>=5.1.0 png>=1.2.4 png>=1.6.0nb1 openjpeg>=2.1.0 freetype2>=2.4.11 libwebp>=0.6.0 libart>=2.3.10nb1 libart>=2.3.16nb1 perl>=5.0 dbus>=0.91 py27-dbus>=0.23.4 glib2>=2.4.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 pcre>=8.30nb1 dbus>=1.6 dbus-glib>=0.61 glib2>=2.32 dbus>=1.8 glib2>=2.34.0 dbus-glib>=0.100nb1 net-snmp>=5.0.9nb3 perl>=5.24.0 perl<5.26.0 osabi-NetBSD-7.0.1 cups>=1.1.19nb3<1.7 poppler-utils-[0-9]* poppler>=0.52.0 fontconfig>=2.10.93 fontconfig>=2.1nb2 fontconfig>=2.10.93nb2 poppler>=0.5.1 poppler>=0.50.0 libusb1>=1.0.9 openslp>=1.0.1 libpaper>=1.1.22 openslp>=1.2.1 ghostscript>=8.63nb1 ghostscript-gpl-[0-9]* ghostscript-fonts>=6.0 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 py27-dbus>=1.1.1nb1 net-snmp>=5.7.3nb3 cups>=1.5.4nb15 ghostscript>=9.05nb8 .

This package supports the following build-time options:

fax
Enable fax support
sane
Enable support for SANE scanners.
qt4
Enable support for QT4.
qt5
Enable support for QT5.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:hplip-3.16.2nb2.tgz(NetBSD 7.0)
earm:hplip-3.15.11.tgz(NetBSD 7.0)
earmv6hf:hplip-3.15.11.tgz(NetBSD 7.0)
earmv7hf:hplip-3.15.11.tgz(NetBSD 7.0)
i386:hplip-3.16.2nb2.tgz(NetBSD 6.0)
i386:hplip-3.16.5.tgz(NetBSD 6.0)
i386:hplip-3.16.7.tgz(NetBSD 6.0)
i386:hplip-3.16.11.tgz(NetBSD 7.0)
i386:hplip-3.16.2nb2.tgz(NetBSD 7.0.0_PATCH)
i386:hplip-3.16.5.tgz(NetBSD 7.0)
i386:hplip-3.16.7.tgz(NetBSD 7.0)
powerpc:hplip-3.16.7.tgz(NetBSD 6.0)
powerpc:hplip-3.16.2nb2.tgz(NetBSD 6.0)
powerpc:hplip-3.16.5.tgz(NetBSD 6.0)
powerpc:hplip-3.16.11.tgz(NetBSD 6.1)
powerpc:hplip-3.15.11.tgz(NetBSD 7.0)
powerpc:hplip-3.15.7nb2.tgz(NetBSD 7.0)
x86_64:hplip-3.16.2nb2.tgz(NetBSD 6.0)
x86_64:hplip-3.16.5.tgz(NetBSD 6.0)
x86_64:hplip-3.16.7.tgz(NetBSD 6.0)
x86_64:hplip-3.16.11.tgz(NetBSD 6.1)
x86_64:hplip-3.16.5.tgz(NetBSD 6.1)
x86_64:hplip-3.16.7.tgz(NetBSD 6.1)
x86_64:hplip-3.16.11.tgz(NetBSD 7.0)
x86_64:hplip-3.16.2nb2.tgz(NetBSD 7.0.0_PATCH)
x86_64:hplip-3.16.5.tgz(NetBSD 7.0)
x86_64:hplip-3.16.7.tgz(NetBSD 7.0)
x86_64:hplip-3.16.11.tgz(NetBSD 7.0.1_PATCH)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]