Daemon Power

The NetBSD Packages Collection: security/codecrypt

Brief description of the package:
Post-quantum cryptographic software

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://github.com/exaexa/codecrypt.

Please note that this package has a gnu-lgpl-v3 license.

The package is located in the "security/codecrypt" directory. The current source version of the package is "codecrypt-1.7.5". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for security/codecrypt :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: gmp>=4.2.1 cwrappers>=20150314 fftw>=3.0 cryptopp>=5.6.2 gmp>=5.0.1 fftw>=3.1nb1 .

This package requires the following package(s) to run: gmp>=4.2.1 fftw>=3.0 cryptopp>=5.6.2 gmp>=5.0.1 fftw>=3.1nb1 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
i386:codecrypt-1.7.5.tgz(NetBSD 7.0)
i386:codecrypt-1.7.5.tgz(NetBSD 7.0)
powerpc:codecrypt-1.7.5.tgz(NetBSD 7.1)
powerpc:codecrypt-1.7.5.tgz(NetBSD 8.0)
x86_64:codecrypt-1.7.5.tgz(NetBSD 7.0)
x86_64:codecrypt-1.7.5.tgz(NetBSD 7.0)
x86_64:codecrypt-1.7.5.tgz(NetBSD 7.0)
x86_64:codecrypt-1.7.5.tgz(NetBSD 7.0)
x86_64:codecrypt-1.7.5.tgz(NetBSD 7.0.1_PATCH)
x86_64:codecrypt-1.7.5.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]