Daemon Power

The NetBSD Packages Collection: security/gnupg21

Brief description of the package:
GnuPG with OpenPGP and S/MIME capabilities

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://www.gnupg.org/.

Please note that this package has a gnu-gpl-v3 license.

The package is located in the "security/gnupg21" directory. The current source version of the package is "gnupg21-2.1.18". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for security/gnupg21 :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: pinentry-[0-9]* libassuan>=2.1.0 libgpg-error>=0.6 cwrappers>=20150314 libgpg-error>=1.17 libgpg-error>=1.10nb1 libassuan>=2.4.2 libgpg-error>=1.16 libksba>=0.9.7 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=1.2 libgcrypt>=1.6.0 libksba>=1.3.0nb1 libusb1>=1.0.9 libgcrypt>=1.7 libgpg-error>=1.24 libassuan>=2.4.3 libksba>=1.3.4 npth>=0.91 npth>=1.1 .

This package requires the following package(s) to run: pinentry-[0-9]* libassuan>=2.1.0 libgpg-error>=0.6 libgpg-error>=1.17 libgpg-error>=1.10nb1 libassuan>=2.4.2 libgpg-error>=1.16 libksba>=0.9.7 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=1.2 libgcrypt>=1.6.0 libksba>=1.3.0nb1 libusb1>=1.0.9 libgcrypt>=1.7 libgpg-error>=1.24 libassuan>=2.4.3 libksba>=1.3.4 npth>=0.91 npth>=1.1 .

This package supports the following build-time options:

ldap
Enable LDAP support.
libusb-1
Enable USB access via libusb-1.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:gnupg21-2.1.11nb1.tgz(NetBSD 7.0)
alpha:gnupg2-2.1.6nb2.tgz(NetBSD 7.0)
alpha:gnupg21-2.1.10.tgz(NetBSD 7.0)
earm:gnupg21-2.1.10.tgz(NetBSD 7.0)
earm:gnupg2-2.1.6nb2.tgz(NetBSD 7.0)
earm:gnupg21-2.1.10.tgz(NetBSD 7.0)
earmv6hf:gnupg2-2.1.6nb2.tgz(NetBSD 7.0)
earmv6hf:gnupg21-2.1.10.tgz(NetBSD 7.0)
earmv7hf:gnupg21-2.1.10.tgz(NetBSD 7.0)
earmv7hf:gnupg2-2.1.6nb2.tgz(NetBSD 7.0)
earmv7hf:gnupg21-2.1.6nb4.tgz(NetBSD 7.0)
i386:gnupg21-2.1.11nb1.tgz(NetBSD 6.0)
i386:gnupg21-2.1.13.tgz(NetBSD 6.0)
i386:gnupg21-2.1.13.tgz(NetBSD 6.1)
i386:gnupg21-2.1.16.tgz(NetBSD 7.0)
i386:gnupg21-2.1.11nb1.tgz(NetBSD 7.0.0_PATCH)
i386:gnupg21-2.1.13.tgz(NetBSD 7.0)
i386:gnupg21-2.1.14.tgz(NetBSD 7.0)
m68k:gnupg21-2.1.11nb1.tgz(NetBSD 7.0)
powerpc:gnupg21-2.1.11nb1.tgz(NetBSD 6.0)
powerpc:gnupg21-2.1.13.tgz(NetBSD 6.0)
powerpc:gnupg21-2.1.10.tgz(NetBSD 7.0)
powerpc:gnupg2-2.1.6nb2.tgz(NetBSD 7.0)
vax:gnupg21-2.1.11nb1.tgz(NetBSD 7.0)
x86_64:gnupg21-2.1.11nb1.tgz(NetBSD 6.0)
x86_64:gnupg21-2.1.13.tgz(NetBSD 6.0)
x86_64:gnupg21-2.1.13.tgz(NetBSD 6.1)
x86_64:gnupg21-2.1.16.tgz(NetBSD 7.0)
x86_64:gnupg21-2.1.11nb1.tgz(NetBSD 7.0.0_PATCH)
x86_64:gnupg21-2.1.13.tgz(NetBSD 7.0)
x86_64:gnupg21-2.1.14.tgz(NetBSD 7.0)
x86_64:gnupg21-2.1.18.tgz(NetBSD 7.0.1_PATCH)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]