Daemon Power

The NetBSD Packages Collection: sysutils/duplicity

Brief description of the package:
Remote encrypting incremental backup utility

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://www.nongnu.org/duplicity/.

Please note that this package has a gnu-gpl-v2 license.

The package is located in the "sysutils/duplicity" directory. The current source version of the package is "duplicity-0.7.17". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for sysutils/duplicity :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: gnupg>=1.0.0 readline>=2.2 cwrappers>=20150314 readline>=6.0 lftp-[0-9]* hicolor-icon-theme>=0.4 hicolor-icon-theme>=0.9nb1 ncftp3-[0-9]* rsync-[0-9]* py27-boto-[0-9]* py27-filechunkio-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 python27>=2.7.1nb2 py27-setuptools>=0.8 py27-expat-[0-9]* py27-dropbox-[0-9]* py27-paramiko-[0-9]* py27-asn1>=0.1.7 py27-bcrypt>=3.1.3 py27-cffi>=1.1 py27-cparser-[0-9]* py27-test-[0-9]* py27-atomicwrites>=1.0 py27-attrs>=17.4.0 py27-more-itertools>=4.0.0 py27-six>=1.0.0 py27-pluggy>=0.7 py27-setuptools_scm-[0-9]* py27-py>=1.5.0 py27-six>=1.10.0 py27-funcsigs-[0-9]* py27-unittest2-[0-9]* py27-six>=1.4 py27-argparse-[0-9]* py27-traceback2-[0-9]* py27-pbr-[0-9]* py27-pip-[0-9]* py27-linecache2-[0-9]* py27-six>=1.4.1 py27-cryptography>=1.5 py27-asn1crypto>=0.21.0 py27-cffi>=1.11.4 py27-cparser>=2.10 py27-idna>=2.1 py27-enum34-[0-9]* py27-ipaddress-[0-9]* py27-nacl>=1.0.1 py27-cffi>=1.4.1 py27-six-[0-9]* libsodium>=0.3 py27-pexpect-[0-9]* py27-ptyprocess>=0.5 py27-requests-oauthlib-[0-9]* py27-requests>=2.2.0 py27-OpenSSL>=0.14 py27-cryptography>=2.2.1 py27-six>=1.5.2 py27-certifi>=2017.4.17 py27-chardet>=3.0.2 py27-cryptography>=1.3.4 py27-idna>=2.5 py27-urllib3>=1.12.1 py27-Socks>=1.6.0 py27-certifi-[0-9]* py27-idna>=2.0.0 py27-oauthlib>=0.6.1 py27-JWT>=1.0.0 py27-cryptography>=1.4 py27-test-cov-[0-9]* py27-coverage>=4.4 py27-greenlet-[0-9]* py27-mock-[0-9]* py27-pbr>=0.11 py27-six>=1.7 py27-funcsigs>=1 py27-nose-[0-9]* py27-unittest-mixins>=1.4 py27-six>=1.4.0 py27-test>=2.9 py27-test-runner-[0-9]* py27-test>=2.8 py27-blinker-[0-9]* py27-cryptography-[0-9]* py27-requests-mock-[0-9]* py27-requests>=1.1 py27-fasteners-[0-9]* py27-monotonic>=0.1 py27-cloudfiles-[0-9]* py27-swiftclient-[0-9]* py27-keystone>=0.7.0 keystone>=0.9 py27-futures>=3.1 py27-gdata-[0-9]* py27-cElementTree-[0-9]* librsync>=1.0.1 popt>=1.7nb3 popt>=1.16nb1 librsync>=2.0 .

This package requires the following package(s) to run: gnupg>=1.0.0 readline>=2.2 readline>=6.0 lftp-[0-9]* hicolor-icon-theme>=0.4 hicolor-icon-theme>=0.9nb1 ncftp3-[0-9]* rsync-[0-9]* py27-boto-[0-9]* py27-filechunkio-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 python27>=2.7.1nb2 py27-setuptools>=0.8 py27-expat-[0-9]* py27-dropbox-[0-9]* py27-paramiko-[0-9]* py27-asn1>=0.1.7 py27-bcrypt>=3.1.3 py27-cffi>=1.1 py27-cparser-[0-9]* py27-six>=1.4.1 py27-cryptography>=1.5 py27-asn1crypto>=0.21.0 py27-cffi>=1.11.4 py27-cparser>=2.10 py27-idna>=2.1 py27-enum34-[0-9]* py27-ipaddress-[0-9]* py27-nacl>=1.0.1 py27-cffi>=1.4.1 py27-six-[0-9]* libsodium>=0.3 py27-pexpect-[0-9]* py27-ptyprocess>=0.5 py27-requests-oauthlib-[0-9]* py27-requests>=2.2.0 py27-OpenSSL>=0.14 py27-cryptography>=2.2.1 py27-six>=1.5.2 py27-certifi>=2017.4.17 py27-chardet>=3.0.2 py27-cryptography>=1.3.4 py27-idna>=2.5 py27-urllib3>=1.12.1 py27-Socks>=1.6.0 py27-certifi-[0-9]* py27-idna>=2.0.0 py27-oauthlib>=0.6.1 py27-JWT>=1.0.0 py27-cryptography>=1.4 py27-blinker-[0-9]* py27-cryptography-[0-9]* py27-fasteners-[0-9]* py27-monotonic>=0.1 py27-cloudfiles-[0-9]* py27-swiftclient-[0-9]* py27-keystone>=0.7.0 keystone>=0.9 py27-requests>=1.1 py27-futures>=3.1 py27-gdata-[0-9]* py27-cElementTree-[0-9]* librsync>=1.0.1 popt>=1.7nb3 popt>=1.16nb1 librsync>=2.0 .

This package supports the following build-time options:

gnupg2
Use GNU Privacy Guard (GnuPG) Version 2.0

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:duplicity-0.6.26.tgz(NetBSD 7.0)
alpha:duplicity-0.7.09nb1.tgz(NetBSD 8.0)
arm:duplicity-0.6.22.tgz(NetBSD 6.1_STABLE)
earm:duplicity-0.6.26.tgz(NetBSD 7.0)
earm:duplicity-0.6.26.tgz(NetBSD 7.0)
earmv6hf:duplicity-0.6.26.tgz(NetBSD 7.0)
earmv6hf:duplicity-0.7.09nb1.tgz(NetBSD 8.0)
earmv6hf:duplicity-0.7.09nb1.tgz(NetBSD 8.0)
earmv7hf:duplicity-0.6.26.tgz(NetBSD 7.0)
earmv7hf:duplicity-0.7.17.tgz(NetBSD 8.0)
i386:duplicity-0.7.09nb1.tgz(NetBSD 6.0)
i386:duplicity-0.7.09nb1.tgz(NetBSD 6.0)
i386:duplicity-0.7.17.tgz(NetBSD 7.0)
i386:duplicity-0.7.09nb1.tgz(NetBSD 7.0)
i386:duplicity-0.7.17.tgz(NetBSD 7.0)
i386:duplicity-0.7.17.tgz(NetBSD 7.0)
i386:duplicity-0.7.17.tgz(NetBSD 7.1)
i386:duplicity-0.7.09nb1.tgz(NetBSD 7.1)
i386:duplicity-0.7.17.tgz(NetBSD 7.1)
i386:duplicity-0.7.17.tgz(NetBSD 7.1)
i386:duplicity-0.7.17.tgz(NetBSD 8.0)
i386:duplicity-0.7.09nb1.tgz(NetBSD 8.0)
i386:duplicity-0.7.17.tgz(NetBSD 8.0)
i386:duplicity-0.7.17.tgz(NetBSD 8.0)
i386:duplicity-0.5.20nb1.tgz(QNX 6.5.0)
powerpc:duplicity-0.7.17.tgz(NetBSD 7.1)
powerpc:duplicity-0.7.17.tgz(NetBSD 7.1)
powerpc:duplicity-0.7.17.tgz(NetBSD 8.0)
powerpc:duplicity-0.7.17.tgz(NetBSD 8.0)
powerpc:duplicity-0.7.17.tgz(NetBSD 8.0)
sparc64:duplicity-0.7.17.tgz(NetBSD 7.1)
sparc64:duplicity-0.7.09nb1.tgz(NetBSD 8.0)
x86_64:duplicity-0.7.09nb1.tgz(NetBSD 6.0)
x86_64:duplicity-0.7.09nb1.tgz(NetBSD 6.1)
x86_64:duplicity-0.7.17.tgz(NetBSD 7.0)
x86_64:duplicity-0.7.09nb1.tgz(NetBSD 7.0)
x86_64:duplicity-0.7.17.tgz(NetBSD 7.0)
x86_64:duplicity-0.7.09nb1.tgz(NetBSD 7.0.1_PATCH)
x86_64:duplicity-0.7.17.tgz(NetBSD 7.1)
x86_64:duplicity-0.7.17.tgz(NetBSD 7.0)
x86_64:duplicity-0.7.09nb1.tgz(NetBSD 7.1)
x86_64:duplicity-0.7.17.tgz(NetBSD 7.1)
x86_64:duplicity-0.7.17.tgz(NetBSD 7.1)
x86_64:duplicity-0.7.17.tgz(NetBSD 8.0)
x86_64:duplicity-0.7.09nb1.tgz(NetBSD 8.0)
x86_64:duplicity-0.7.17.tgz(NetBSD 8.0)
x86_64:duplicity-0.7.17.tgz(NetBSD 8.0)
x86_64:duplicity-0.7.09nb1.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]