Daemon Power

The NetBSD Packages Collection: sysutils/libnotify

Brief description of the package:
Desktop notification framework

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://developer.gnome.org/libnotify/.

Please note that this package has a gnu-lgpl-v2.1 license.

The package is located in the "sysutils/libnotify" directory. The current source version of the package is "libnotify-0.7.6nb6". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for sysutils/libnotify :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: gobject-introspection>=0.9.12 py27-cElementTree-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 cwrappers>=20150314 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 py27-expat-[0-9]* glib2>=2.50.0 perl>=5.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 pcre>=8.30nb1 glib2>=2.4.0 libffi>=3.0.0 glib2>=2.34.0 gobject-introspection>=0.6.14nb1 glib2>=2.26.0 gdk-pixbuf2>=2.22.0 shared-mime-info>=0.15 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 glib2>=2.37.2 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 png>=1.2.4 shared-mime-info>=1.0nb1 tiff>=4.0.3nb5 png>=1.6.0nb1 gobject-introspection>=1.34.0 gdk-pixbuf2>=2.34.0nb1 x11-links>=1.04 osabi-NetBSD-7.0.1 gtk3+>=3.0.0 atk>=2.15.1 glib2>=2.31.2 atk>=1.11.4 glib2>=2.49.4 gdk-pixbuf2>=2.30.0 at-spi2-atk>=2.6.1 atk>=2.15.4 glib2>=2.32.0 at-spi2-core>=2.17.90 dbus>=0.91 xmlto-[0-9]* getopt-[0-9]* docbook-xsl>=1.67.0nb1 docbook-xml>=4.2 bash-[0-9]* libxslt>=1.1.8 libgcrypt>=1.2.0 libgpg-error>=1.13 libgpg-error>=0.6 libgpg-error>=1.10nb1 libxml2>=2.6.27 libgcrypt>=1.6.0 docbook-xml-[0-9]* docbook-xsl-[0-9]* libxslt>=1.1.28nb2 libXtst>=1.0.1 inputproto>=1.4 recordproto>=1.13.99.1 recordproto>=1.13.1 xextproto>=7.0.99.3 xextproto>=7.0 at-spi2-core>=2.3.2 dbus>=1.5 atk>=2.6.0 at-spi2-core>=2.6.0 xcursor>=1.0 Xfixes>=2.0.0 fixesproto>=3.0.0<5 xproto>=7.0.9 Xrender>=0.8 renderproto>=0.9.3nb1 renderproto>=0.9 Xrender>=0.2 Xrender>=0.8.2 Xfixes>=2.0.1nb2 Xrender>=0.9.0nb1 xcursor>=1.1.1 Xft2>=2.1.2nb2 fontconfig>=2.2 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 gperf-[0-9]* fontconfig>=2.10.93 fontconfig>=2.1nb2 Xrender>=0.9.0nb2 fontconfig>=2.10.93nb2 Xft2>=2.1 Xft2>=2.1nb2 Xrandr>=0.99 randrproto>=1.2.0 randrproto>=1.0 Xrandr>=1.0.1 libXcomposite>=0.3.1 compositeproto>=0.4 compositeproto>=0.3.1 pango>=1.37.3 Xft2>=2.1.7nb3 fontconfig>=2.10.91 glib2>=2.33.12 harfbuzz>=0.9.9 icu>=3.4 icu>=58.1 harfbuzz>=0.9.4 cairo>=1.12.10 MesaLib>=3.4.2 libXdamage>=1.0.3 damageproto>=1.1.0 libdrm>=2.4.60 libdrm>=2.4.15 libva>=1.0.6 libvdpau>=0.3 dri2proto>=2.0 libLLVM>=4.0 libLLVM>=4.0.0 libxcb>=1.6 libXdmcp>=0.99 libXau>=1.0 xcb-proto>=1.12 xcb-proto>=1.4 py27-mako-[0-9]* py27-setuptools>=0.8 dri2proto>=2.1 glproto>=1.4.11 glproto>=1.4.6 xf86driproto>=2.0.3 xf86vidmodeproto>=2.3 lzo>=2.01 fontconfig>=2.2.95 freetype2>=2.1.9 pixman>=0.30.0 pixman>=0.25.2 MesaLib>=7.11.2 cairo>=1.0.0nb2 cairo-gobject>=1.10.2 cairo>=1.14.2nb1 glib2>=2.14.0 Xft2>=2.1.7nb6 harfbuzz>=1.4.2nb1 cairo-gobject>=1.14.2nb1 help2man-[0-9]* p5-gettext>=1.01 perl>=5.26.0 perl<5.28.0 pango>=1.6.0 cairo>=1.14.0 libepoxy>=1.2nb2 py27-expat>=0 xorg-util-macros>=1.17 libepoxy>=1.2 hicolor-icon-theme>=0.4 desktop-file-utils>=0.8 xcursor>=1.1.2nb1 Xrandr>=1.0.2nb3 pango>=1.40.3nb2 hicolor-icon-theme>=0.9nb1 desktop-file-utils>=0.10nb1 gdbus-codegen-[0-9]* gobject-introspection>=1.39.0 inputproto>=2.0 gtk3+>=3.22.7nb2 .

This package requires the following package(s) to run: gobject-introspection>=0.9.12 py27-cElementTree-[0-9]* python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 python27>=2.7.1nb2 py27-expat-[0-9]* glib2>=2.50.0 perl>=5.0 libelf>=0.8.5 pcre>=8.31 pcre>=3.4nb1 pcre>=8.30nb1 glib2>=2.4.0 libffi>=3.0.0 glib2>=2.34.0 gobject-introspection>=0.6.14nb1 glib2>=2.26.0 gdk-pixbuf2>=2.22.0 shared-mime-info>=0.15 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 glib2>=2.37.2 tiff>=3.6.1 jbigkit>=2.0 jpeg>=8nb1 jpeg>=9 png>=1.2.4 shared-mime-info>=1.0nb1 tiff>=4.0.3nb5 png>=1.6.0nb1 gobject-introspection>=1.34.0 gdk-pixbuf2>=2.34.0nb1 .

This package supports the following build-time options:

doc
Include the documentation.
introspection
Enable GObject Introspection support.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
arm:libnotify-0.7.6.tgz(NetBSD 6.1_STABLE)
earm:libnotify-0.7.6nb1.tgz(NetBSD 7.0)
earm:libnotify-0.7.6nb2.tgz(NetBSD 7.0)
earm:libnotify-0.7.6nb2.tgz(NetBSD 7.0)
earm:libnotify-0.7.6nb2.tgz(NetBSD 7.0)
earmv6hf:libnotify-0.7.6nb1.tgz(NetBSD 7.0)
earmv6hf:libnotify-0.7.6nb2.tgz(NetBSD 7.0)
earmv6hf:libnotify-0.7.6nb2.tgz(NetBSD 7.0)
earmv7hf:libnotify-0.7.6nb2.tgz(NetBSD 7.0)
earmv7hf:libnotify-0.7.6nb2.tgz(NetBSD 7.0)
earmv7hf:libnotify-0.7.6nb2.tgz(NetBSD 7.99.21)
earmv7hfeb:libnotify-0.7.6nb2.tgz(NetBSD 7.0)
i386:libnotify-0.7.6nb6.tgz(NetBSD 6.0)
i386:libnotify-0.7.6nb3.tgz(NetBSD 6.0)
i386:libnotify-0.7.6nb6.tgz(NetBSD 6.0)
i386:libnotify-0.7.6nb6.tgz(NetBSD 6.1)
i386:libnotify-0.7.6nb3.tgz(NetBSD 6.1)
i386:libnotify-0.7.6nb6.tgz(NetBSD 6.1)
i386:libnotify-0.7.6nb6.tgz(NetBSD 7.0)
i386:libnotify-0.7.6nb3.tgz(NetBSD 7.0)
i386:libnotify-0.7.6nb4.tgz(NetBSD 7.0)
i386:libnotify-0.7.6nb6.tgz(NetBSD 7.0)
i386:libnotify-0.4.5nb6.tgz(QNX 6.5.0)
powerpc:libnotify-0.7.6nb3.tgz(NetBSD 6.0)
powerpc:libnotify-0.7.6nb2.tgz(NetBSD 6.0)
powerpc:libnotify-0.7.6nb6.tgz(NetBSD 6.1)
powerpc:libnotify-0.7.6nb4.tgz(NetBSD 6.1)
powerpc:libnotify-0.7.6nb2.tgz(NetBSD 7.0)
powerpc:libnotify-0.7.6nb2.tgz(NetBSD 7.0)
powerpc:libnotify-0.7.6nb6.tgz(NetBSD 7.1)
powerpc:libnotify-0.7.6nb6.tgz(NetBSD 8.0)
sparc64:libnotify-0.7.6.tgz(NetBSD 6.1_STABLE)
sparc64:libnotify-0.7.6nb2.tgz(NetBSD 7.0)
sparc64:libnotify-0.7.6nb4.tgz(NetBSD 7.1_RC1)
sparc64:libnotify-0.7.6nb2.tgz(NetBSD 7.0)
sparc:libnotify-0.7.6nb3.tgz(NetBSD 7.0)
x86_64:libnotify-0.7.6nb6.tgz(NetBSD 6.0)
x86_64:libnotify-0.7.6nb3.tgz(NetBSD 6.0)
x86_64:libnotify-0.7.6nb6.tgz(NetBSD 6.0)
x86_64:libnotify-0.7.6nb6.tgz(NetBSD 6.1)
x86_64:libnotify-0.7.6nb3.tgz(NetBSD 6.1)
x86_64:libnotify-0.7.6nb6.tgz(NetBSD 6.1)
x86_64:libnotify-0.7.6nb6.tgz(NetBSD 7.0)
x86_64:libnotify-0.7.6nb3.tgz(NetBSD 7.0)
x86_64:libnotify-0.7.6nb4.tgz(NetBSD 7.0)
x86_64:libnotify-0.7.6nb6.tgz(NetBSD 7.0)
x86_64:libnotify-0.7.6nb6.tgz(NetBSD 7.0.1_PATCH)
x86_64:libnotify-0.7.6nb6.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]