Daemon Power

The NetBSD Packages Collection: sysutils/puppet

Brief description of the package:
Configuration management framework written in Ruby

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://www.puppetlabs.com/.

Please note that this package has a apache-2.0 license.

The package is located in the "sysutils/puppet" directory. The current source version of the package is "ruby23-puppet-5.2.0". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for sysutils/puppet :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ruby23-facter>=1.7.0<4 ruby23-base>=2.3.5 libyaml>=0.1.1 cwrappers>=20150314 libyaml>=0.1.4 ruby23-hiera>=1.0.0<4 ruby23-gettext-setup<1 ruby23-fast_gettext>=1.1.0 ruby23-gettext>=3.0.2 ruby23-locale>=2.0.5 ruby23-text>=1.3.0 ruby23-locale>=0 ruby23-locale>=2.1 .

This package requires the following package(s) to run: ruby23-facter>=1.7.0<4 ruby23-base>=2.3.5 libyaml>=0.1.1 libyaml>=0.1.4 ruby23-hiera>=1.0.0<4 ruby23-gettext-setup<1 ruby23-fast_gettext>=1.1.0 ruby23-gettext>=3.0.2 ruby23-locale>=2.0.5 ruby23-text>=1.3.0 ruby23-locale>=0 ruby23-locale>=2.1 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:ruby21-puppet-3.8.6.tgz(NetBSD 7.0)
arm:ruby200-puppet-3.1.1nb1.tgz(NetBSD 6.1_STABLE)
earm:ruby200-puppet-3.8.4.tgz(NetBSD 7.0)
earm:ruby21-puppet-3.8.4.tgz(NetBSD 7.0)
earmv6hf:ruby200-puppet-3.8.4.tgz(NetBSD 7.0)
earmv7hf:ruby200-puppet-3.8.4.tgz(NetBSD 7.0)
earmv7hf:ruby21-puppet-3.8.4.tgz(NetBSD 7.0)
earmv7hf:ruby193-puppet-3.8.2.tgz(NetBSD 7.0)
earmv7hf:ruby200-puppet-3.8.2.tgz(NetBSD 7.0)
earmv7hf:ruby21-puppet-3.8.2.tgz(NetBSD 7.0)
earmv7hf:ruby22-puppet-4.10.4.tgz(NetBSD 8.0_BETA)
earmv7hf:ruby23-puppet-4.10.4.tgz(NetBSD 8.0_BETA)
i386:ruby22-puppet-5.2.0.tgz(NetBSD 6.0)
i386:ruby23-puppet-5.2.0.tgz(NetBSD 6.0)
i386:ruby24-puppet-5.2.0.tgz(NetBSD 6.0)
i386:ruby21-puppet-3.8.7.tgz(NetBSD 6.0)
i386:ruby21-puppet-3.8.7.tgz(NetBSD 6.0)
i386:ruby21-puppet-3.8.7.tgz(NetBSD 6.0)
i386:ruby22-puppet-4.10.4.tgz(NetBSD 6.0)
i386:ruby23-puppet-4.10.4.tgz(NetBSD 6.0)
i386:ruby24-puppet-4.10.4.tgz(NetBSD 6.0)
i386:ruby22-puppet-5.2.0.tgz(NetBSD 6.1)
i386:ruby23-puppet-5.2.0.tgz(NetBSD 6.1)
i386:ruby24-puppet-5.2.0.tgz(NetBSD 6.1)
i386:ruby21-puppet-3.8.7.tgz(NetBSD 6.1)
i386:ruby21-puppet-3.8.7.tgz(NetBSD 6.1)
i386:ruby21-puppet-3.8.7.tgz(NetBSD 6.1)
i386:ruby22-puppet-4.10.4.tgz(NetBSD 6.1)
i386:ruby23-puppet-4.10.4.tgz(NetBSD 6.1)
i386:ruby24-puppet-4.10.4.tgz(NetBSD 6.1)
i386:ruby22-puppet-5.2.0.tgz(NetBSD 7.0)
i386:ruby23-puppet-5.2.0.tgz(NetBSD 7.0)
i386:ruby24-puppet-5.2.0.tgz(NetBSD 7.0)
i386:ruby21-puppet-3.8.7.tgz(NetBSD 7.0)
i386:ruby21-puppet-3.8.7.tgz(NetBSD 7.0)
i386:ruby21-puppet-3.8.7.tgz(NetBSD 7.0)
i386:ruby22-puppet-4.10.4.tgz(NetBSD 7.0)
i386:ruby23-puppet-4.10.4.tgz(NetBSD 7.0)
i386:ruby24-puppet-4.10.4.tgz(NetBSD 7.0)
i386:ruby18-puppet-0.25.5nb1.tgz(QNX 6.5.0)
i386:ruby19-puppet-0.25.5nb1.tgz(QNX 6.5.0)
powerpc:ruby24-puppet-4.10.4.tgz(NetBSD 6.1)
powerpc:ruby22-puppet-4.10.4.tgz(NetBSD 7.1)
powerpc:ruby23-puppet-4.10.4.tgz(NetBSD 7.1)
powerpc:ruby24-puppet-4.10.4.tgz(NetBSD 7.1)
powerpc:ruby22-puppet-5.2.0.tgz(NetBSD 7.1)
powerpc:ruby23-puppet-5.2.0.tgz(NetBSD 7.1)
powerpc:ruby24-puppet-5.2.0.tgz(NetBSD 7.1)
powerpc:ruby22-puppet-4.10.4.tgz(NetBSD 8.0)
powerpc:ruby23-puppet-4.10.4.tgz(NetBSD 8.0)
powerpc:ruby24-puppet-4.10.4.tgz(NetBSD 8.0)
sparc:ruby193-puppet-3.1.1nb1.tgz(NetBSD 5.1)
sparc:ruby193-puppet-3.1.1nb1.tgz(NetBSD 6.0)
sparc:ruby200-puppet-3.1.1nb1.tgz(NetBSD 6.0)
x86_64:ruby22-puppet-5.2.0.tgz(NetBSD 6.0)
x86_64:ruby23-puppet-5.2.0.tgz(NetBSD 6.0)
x86_64:ruby24-puppet-5.2.0.tgz(NetBSD 6.0)
x86_64:ruby21-puppet-3.8.7.tgz(NetBSD 6.0)
x86_64:ruby21-puppet-3.8.7.tgz(NetBSD 6.0)
x86_64:ruby21-puppet-3.8.7.tgz(NetBSD 6.0)
x86_64:ruby22-puppet-4.10.4.tgz(NetBSD 6.0)
x86_64:ruby23-puppet-4.10.4.tgz(NetBSD 6.0)
x86_64:ruby24-puppet-4.10.4.tgz(NetBSD 6.0)
x86_64:ruby22-puppet-5.2.0.tgz(NetBSD 6.1)
x86_64:ruby23-puppet-5.2.0.tgz(NetBSD 6.1)
x86_64:ruby24-puppet-5.2.0.tgz(NetBSD 6.1)
x86_64:ruby21-puppet-3.8.7.tgz(NetBSD 6.1)
x86_64:ruby21-puppet-3.8.7.tgz(NetBSD 6.1)
x86_64:ruby21-puppet-3.8.7.tgz(NetBSD 6.1)
x86_64:ruby22-puppet-4.10.4.tgz(NetBSD 6.1)
x86_64:ruby23-puppet-4.10.4.tgz(NetBSD 6.1)
x86_64:ruby24-puppet-4.10.4.tgz(NetBSD 6.1)
x86_64:ruby22-puppet-5.2.0.tgz(NetBSD 7.0)
x86_64:ruby23-puppet-5.2.0.tgz(NetBSD 7.0)
x86_64:ruby24-puppet-5.2.0.tgz(NetBSD 7.0)
x86_64:ruby21-puppet-3.8.7.tgz(NetBSD 7.0)
x86_64:ruby21-puppet-3.8.7.tgz(NetBSD 7.0)
x86_64:ruby21-puppet-3.8.7.tgz(NetBSD 7.0)
x86_64:ruby22-puppet-4.10.4.tgz(NetBSD 7.0)
x86_64:ruby23-puppet-4.10.4.tgz(NetBSD 7.0)
x86_64:ruby24-puppet-4.10.4.tgz(NetBSD 7.0)
x86_64:ruby22-puppet-4.10.4.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby23-puppet-4.10.4.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby24-puppet-4.10.4.tgz(NetBSD 7.0.1_PATCH)
x86_64:ruby22-puppet-4.10.4.tgz(NetBSD 8.99.1)
x86_64:ruby23-puppet-4.10.4.tgz(NetBSD 8.99.1)
x86_64:ruby24-puppet-4.10.4.tgz(NetBSD 8.99.1)
x86_64:ruby22-puppet-4.10.4.tgz(NetBSD 8.99.1)
x86_64:ruby23-puppet-4.10.4.tgz(NetBSD 8.99.1)
x86_64:ruby24-puppet-4.10.4.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]