Daemon Power

The NetBSD Packages Collection: time/p5-DateTime

Brief description of the package:
Perl module for date/time sets and ranges

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://datetime.perl.org/.

Please note that this package has a artistic-2.0 license.

The package is located in the "time/p5-DateTime" directory. The current source version of the package is "p5-DateTime-1.4800". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for time/p5-DateTime :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: p5-DateTime-Locale>=1.06 p5-Dist-CheckConflicts>=0.02 p5-Module-Runtime-[0-9]* perl>=5.26.0 cwrappers>=20150314 perl<5.28.0 p5-Module-Build>=0.42050 p5-inc-latest-[0-9]* p5-CPAN-Meta>=2.142060 p5-Scalar-List-Utils>=1.33 p5-Sub-Exporter-[0-9]* p5-Data-OptList>=0.100 p5-Params-Util>=0.14 p5-Sub-Install>=0.921 p5-Sub-Install>=0.920 p5-Test-Fatal-[0-9]* p5-Try-Tiny>=0.07 p5-Capture-Tiny>=0.12 p5-File-ShareDir-[0-9]* p5-Class-Inspector>=1.12 p5-Params-ValidationCompiler>=0.13 p5-Eval-Closure-[0-9]* p5-Try-Tiny-[0-9]* p5-Test-Requires-[0-9]* p5-Devel-LexAlias-[0-9]* p5-Devel-Caller>=0.04 p5-PadWalker>0.08 p5-Exception-Class-[0-9]* p5-Class-Data-Inheritable>=0.02 p5-Devel-StackTrace>=1.20 p5-Specio>=0.14 p5-Role-Tiny>=1.003003 p5-Test-Fatal>=0.003 p5-MRO-Compat-[0-9]* p5-Devel-StackTrace-[0-9]* p5-Sub-Quote-[0-9]* p5-Ref-Util-[0-9]* p5-Ref-Util-XS-[0-9]* p5-Test-Needs-[0-9]* p5-Sub-Info-[0-9]* p5-Test-Simple-[0-9]* p5-Importer-[0-9]* p5-Term-Table-[0-9]* p5-Test2-Suite-[0-9]* p5-Module-Pluggable-[0-9]* p5-Test-Simple>=1.302117 p5-Scope-Guard-[0-9]* p5-Test2-Plugin-NoWarnings-[0-9]* p5-Test-Without-Module-[0-9]* p5-Scalar-List-Utils>=1.45 p5-Specio-[0-9]* p5-namespace-autoclean>=0.19 p5-B-Hooks-EndOfScope-[0-9]* p5-Sub-Exporter-Progressive>=0.001006 p5-Variable-Magic>=0.48 p5-Module-Implementation-[0-9]* p5-Module-Runtime>=0.12 p5-Test-Fatal>=0.006 p5-namespace-clean>=0.11 p5-B-Hooks-EndOfScope>=0.12 p5-Package-Stash>=0.23 p5-Module-Implementation>=0.06 p5-Package-Stash-XS>=0.26 p5-Test-Exception-[0-9]* p5-Sub-Uplevel>=0.18 p5-Sub-Identify-[0-9]* p5-Sub-Name-[0-9]* p5-Devel-CheckBin-[0-9]* p5-CPAN-Meta-Check>=0.011 p5-Module-Metadata>=1.00023 p5-Test-Deep-[0-9]* p5-Test-Simple>=1.001010 p5-File-ShareDir-Install>=0.06 p5-Test-Warnings-[0-9]* p5-CPAN-Meta-Check>=0.007 p5-Module-Metadata>=1.000023 p5-Test-File-ShareDir-[0-9]* p5-File-Copy-Recursive-[0-9]* p5-Path-Iter-[0-9]* p5-Path-Tiny-[0-9]* p5-Test-File-[0-9]* p5-Test-utf8>=0 p5-Test-Warn-[0-9]* p5-Sub-Uplevel>=0.12 p5-File-ShareDir>=1.00 p5-Class-Tiny-[0-9]* p5-DateTime-TimeZone>=2.02 p5-Class-Singleton>=1.03 p5-Params-Validate>=0.72 p5-File-Slurp-[0-9]* p5-List-AllUtils>=0 p5-List-SomeUtils>=0.28 p5-List-SomeUtils-XS>=0.50 p5-Test-LeakTrace-[0-9]* p5-List-UtilsBy>=0.10 p5-Scalar-List-Utils>=1.31 p5-Params-ValidationCompiler-[0-9]* p5-Test-Output-[0-9]* p5-Capture-Tiny>=0.17 p5-Test-Taint-[0-9]* p5-namespace-autoclean-[0-9]* p5-Math-Round-[0-9]* p5-Params-ValidationCompiler>=0.11 p5-CPAN-Meta-Check>=0.11 .

This package requires the following package(s) to run: p5-DateTime-Locale>=1.06 p5-Dist-CheckConflicts>=0.02 p5-Module-Runtime-[0-9]* perl>=5.26.0 perl<5.28.0 p5-Sub-Exporter-[0-9]* p5-Data-OptList>=0.100 p5-Params-Util>=0.14 p5-Sub-Install>=0.921 p5-Sub-Install>=0.920 p5-Test-Fatal-[0-9]* p5-Try-Tiny>=0.07 p5-File-ShareDir-[0-9]* p5-Class-Inspector>=1.12 p5-Params-ValidationCompiler>=0.13 p5-Eval-Closure-[0-9]* p5-Try-Tiny-[0-9]* p5-Exception-Class-[0-9]* p5-Class-Data-Inheritable>=0.02 p5-Devel-StackTrace>=1.20 p5-Scalar-List-Utils>=1.45 p5-Specio-[0-9]* p5-Role-Tiny>=1.003003 p5-MRO-Compat-[0-9]* p5-Devel-StackTrace-[0-9]* p5-Sub-Quote-[0-9]* p5-Ref-Util-[0-9]* p5-Ref-Util-XS-[0-9]* p5-namespace-autoclean>=0.19 p5-B-Hooks-EndOfScope-[0-9]* p5-Sub-Exporter-Progressive>=0.001006 p5-Variable-Magic>=0.48 p5-Module-Implementation-[0-9]* p5-Module-Runtime>=0.12 p5-namespace-clean>=0.11 p5-B-Hooks-EndOfScope>=0.12 p5-Package-Stash>=0.23 p5-Module-Implementation>=0.06 p5-Package-Stash-XS>=0.26 p5-Sub-Identify-[0-9]* p5-DateTime-TimeZone>=2.02 p5-Class-Singleton>=1.03 p5-Params-Validate>=0.72 p5-List-AllUtils>=0 p5-List-SomeUtils>=0.28 p5-List-SomeUtils-XS>=0.50 p5-List-UtilsBy>=0.10 p5-Scalar-List-Utils>=1.31 p5-Params-ValidationCompiler-[0-9]* p5-Math-Round-[0-9]* p5-Params-ValidationCompiler>=0.11 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:p5-DateTime-1.4300.tgz(NetBSD 8.0)
earm:p5-DateTime-1.2100.tgz(NetBSD 7.0)
earm:p5-DateTime-1.1800.tgz(NetBSD 7.0)
earm:p5-DateTime-1.1900nb1.tgz(NetBSD 7.0)
earm:p5-DateTime-1.2000.tgz(NetBSD 7.0)
earm:p5-DateTime-1.2100.tgz(NetBSD 7.0)
earmv6hf:p5-DateTime-1.2100.tgz(NetBSD 7.0)
earmv6hf:p5-DateTime-1.4400.tgz(NetBSD 8.0)
earmv7hf:p5-DateTime-1.2100.tgz(NetBSD 7.0)
earmv7hf:p5-DateTime-1.4400.tgz(NetBSD 8.0)
earmv7hf:p5-DateTime-1.4600.tgz(NetBSD 8.0)
earmv7hf:p5-DateTime-1.4300.tgz(NetBSD 8.0_BETA)
earmv7hfeb:p5-DateTime-1.2100.tgz(NetBSD 7.0)
earmv7hfeb:p5-DateTime-1.4400.tgz(NetBSD 8.0)
i386:p5-DateTime-1.0600.tgz(MirBSD 10)
i386:p5-DateTime-1.4600.tgz(NetBSD 6.0)
i386:p5-DateTime-1.3900.tgz(NetBSD 6.0)
i386:p5-DateTime-1.4100.tgz(NetBSD 6.0)
i386:p5-DateTime-1.4200.tgz(NetBSD 6.0)
i386:p5-DateTime-1.4300.tgz(NetBSD 6.0)
i386:p5-DateTime-1.4400.tgz(NetBSD 6.0)
i386:p5-DateTime-1.4400.tgz(NetBSD 6.0)
i386:p5-DateTime-1.4600.tgz(NetBSD 6.1)
i386:p5-DateTime-1.3900.tgz(NetBSD 6.1)
i386:p5-DateTime-1.4100.tgz(NetBSD 6.1)
i386:p5-DateTime-1.4200.tgz(NetBSD 6.1)
i386:p5-DateTime-1.4300.tgz(NetBSD 6.1)
i386:p5-DateTime-1.4400.tgz(NetBSD 6.1)
i386:p5-DateTime-1.4400.tgz(NetBSD 7.0)
i386:p5-DateTime-1.3900.tgz(NetBSD 7.0)
i386:p5-DateTime-1.4100.tgz(NetBSD 7.0)
i386:p5-DateTime-1.4200.tgz(NetBSD 7.0)
i386:p5-DateTime-1.4300.tgz(NetBSD 7.0)
i386:p5-DateTime-1.4400.tgz(NetBSD 7.0)
i386:p5-DateTime-1.4600.tgz(NetBSD 7.0)
i386:p5-DateTime-1.4400.tgz(NetBSD 7.1)
i386:p5-DateTime-1.4600.tgz(NetBSD 7.1)
i386:p5-DateTime-1.4400.tgz(NetBSD 8.0)
i386:p5-DateTime-1.4600.tgz(NetBSD 8.0)
i386:p5-DateTime-0.6600nb1.tgz(QNX 6.5.0)
powerpc:p5-DateTime-1.4400.tgz(NetBSD 6.1)
powerpc:p5-DateTime-1.2100.tgz(NetBSD 7.0)
powerpc:p5-DateTime-1.4400.tgz(NetBSD 7.1)
powerpc:p5-DateTime-1.4400.tgz(NetBSD 7.1)
powerpc:p5-DateTime-1.4600.tgz(NetBSD 7.1)
powerpc:p5-DateTime-1.4400.tgz(NetBSD 8.0)
powerpc:p5-DateTime-1.4400.tgz(NetBSD 8.0)
sparc64:p5-DateTime-1.1800.tgz(NetBSD 7.0)
sparc64:p5-DateTime-1.1900nb1.tgz(NetBSD 7.0)
sparc64:p5-DateTime-1.2100.tgz(NetBSD 7.0)
sparc64:p5-DateTime-1.4100.tgz(NetBSD 7.1_RC1)
sparc64:p5-DateTime-1.4400.tgz(NetBSD 8.0)
sparc:p5-DateTime-1.1900nb1.tgz(NetBSD 5.1)
sparc:p5-DateTime-1.1800.tgz(NetBSD 5.1)
sparc:p5-DateTime-1.1200.tgz(NetBSD 6.0)
x86_64:p5-DateTime-1.4600.tgz(NetBSD 6.0)
x86_64:p5-DateTime-1.4400.tgz(NetBSD 6.0)
x86_64:p5-DateTime-1.4400.tgz(NetBSD 6.0)
x86_64:p5-DateTime-1.4600.tgz(NetBSD 6.1)
x86_64:p5-DateTime-1.4400.tgz(NetBSD 6.1)
x86_64:p5-DateTime-1.4400.tgz(NetBSD 6.1)
x86_64:p5-DateTime-1.4600.tgz(NetBSD 7.0)
x86_64:p5-DateTime-1.4400.tgz(NetBSD 7.0)
x86_64:p5-DateTime-1.4400.tgz(NetBSD 7.0)
x86_64:p5-DateTime-1.4300.tgz(NetBSD 7.0.1_PATCH)
x86_64:p5-DateTime-1.4600.tgz(NetBSD 7.1)
x86_64:p5-DateTime-1.4500.tgz(NetBSD 7.1.1)
x86_64:p5-DateTime-1.4600.tgz(NetBSD 7.1.1)
x86_64:p5-DateTime-1.4400.tgz(NetBSD 7.1)
x86_64:p5-DateTime-1.4600.tgz(NetBSD 8.0)
x86_64:p5-DateTime-1.4300.tgz(NetBSD 8.99.1)
x86_64:p5-DateTime-1.4400.tgz(NetBSD 8.0)
x86_64:p5-DateTime-1.4400.tgz(NetBSD 8.0)
x86_64:p5-DateTime-1.4400.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]