Daemon Power

The NetBSD Packages Collection: wm/echinus

Brief description of the package:
Simple and lightweight tiling window manager

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://plhk.ru/echinus.

Please note that this package has a mit license.

The package is located in the "wm/echinus" directory. The current source version of the package is "echinus-0.4.9". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for wm/echinus :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: Xrandr>=0.99 Xrender>=0.8 x11-links>=1.06 osabi-NetBSD-7.0.1 cwrappers>=20150314 renderproto>=0.9.3nb1 renderproto>=0.9 Xrender>=0.2 Xrender>=0.8.2 Xrender>=0.9.0nb1 randrproto>=1.2.0 randrproto>=1.0 Xrandr>=1.0.1 Xft2>=2.1 fontconfig>=2.2 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 gperf-[0-9]* fontconfig>=2.10.93 fontconfig>=2.1nb2 Xrender>=0.9.0nb2 fontconfig>=2.10.93nb2 Xft2>=2.1nb2 Xrandr>=1.0.2nb3 Xft2>=2.1.7nb6 .

This package requires the following package(s) to run: Xrandr>=0.99 Xrender>=0.8 Xrender>=0.2 Xrender>=0.8.2 Xrender>=0.9.0nb1 Xrandr>=1.0.1 Xft2>=2.1 fontconfig>=2.2 freetype2>=2.4.5 freetype2>=2.1.3 freetype2>=2.4.11 fontconfig>=2.10.93 fontconfig>=2.1nb2 Xrender>=0.9.0nb2 fontconfig>=2.10.93nb2 Xft2>=2.1nb2 Xrandr>=1.0.2nb3 Xft2>=2.1.7nb6 .

This package supports the following build-time options:

xrandr
Enable Xrandr support.

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:echinus-0.4.9.tgz(NetBSD 7.0)
arm:echinus-0.4.3nb4.tgz(NetBSD 6.1_STABLE)
earm:echinus-0.4.9.tgz(NetBSD 7.0)
earm:echinus-0.4.9.tgz(NetBSD 7.0)
earmv6hf:echinus-0.4.9.tgz(NetBSD 7.0)
earmv6hf:echinus-0.4.9.tgz(NetBSD 7.0)
earmv6hf:echinus-0.4.9.tgz(NetBSD 7.0)
earmv7hf:echinus-0.4.9.tgz(NetBSD 7.0)
earmv7hf:echinus-0.4.9.tgz(NetBSD 8.0_BETA)
i386:echinus-0.4.3nb4.tgz(MirBSD 10)
i386:echinus-0.4.9.tgz(NetBSD 6.0)
i386:echinus-0.4.9.tgz(NetBSD 6.0)
i386:echinus-0.4.9.tgz(NetBSD 6.0)
i386:echinus-0.4.9.tgz(NetBSD 6.0)
i386:echinus-0.4.9.tgz(NetBSD 6.1)
i386:echinus-0.4.9.tgz(NetBSD 6.1)
i386:echinus-0.4.9.tgz(NetBSD 6.1)
i386:echinus-0.4.9.tgz(NetBSD 6.1)
i386:echinus-0.4.9.tgz(NetBSD 7.0)
i386:echinus-0.4.9.tgz(NetBSD 7.0)
i386:echinus-0.4.9.tgz(NetBSD 7.0)
i386:echinus-0.4.9.tgz(NetBSD 7.0)
i386:echinus-0.4.3.tgz(QNX 6.5.0)
powerpc:echinus-0.4.9.tgz(NetBSD 6.0)
powerpc:echinus-0.4.9.tgz(NetBSD 6.1)
powerpc:echinus-0.4.9.tgz(NetBSD 7.0)
powerpc:echinus-0.4.9.tgz(NetBSD 7.1)
powerpc:echinus-0.4.9.tgz(NetBSD 8.0)
sparc64:echinus-0.4.9.tgz(NetBSD 7.0)
sparc:echinus-0.4.9.tgz(NetBSD 6.0)
x86_64:echinus-0.4.9.tgz(NetBSD 6.0)
x86_64:echinus-0.4.9.tgz(NetBSD 6.0)
x86_64:echinus-0.4.9.tgz(NetBSD 6.0)
x86_64:echinus-0.4.9.tgz(NetBSD 6.0)
x86_64:echinus-0.4.9.tgz(NetBSD 6.1)
x86_64:echinus-0.4.9.tgz(NetBSD 6.1)
x86_64:echinus-0.4.9.tgz(NetBSD 6.1)
x86_64:echinus-0.4.9.tgz(NetBSD 6.1)
x86_64:echinus-0.4.9.tgz(NetBSD 7.0)
x86_64:echinus-0.4.9.tgz(NetBSD 7.0)
x86_64:echinus-0.4.9.tgz(NetBSD 7.0)
x86_64:echinus-0.4.9.tgz(NetBSD 7.0)
x86_64:echinus-0.4.9.tgz(NetBSD 7.0.1_PATCH)
x86_64:echinus-0.4.9.tgz(NetBSD 8.99.1)
x86_64:echinus-0.4.9.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]