Daemon Power

The NetBSD Packages Collection: www/ap2-passenger

Brief description of the package:
Passenger module for Apache 2.x

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at https://www.phusionpassenger.com/.

Please note that this package has a mit license.

The package is located in the "www/ap2-passenger" directory. The current source version of the package is "ap24-ruby24-passenger-5.3.3nb1". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for www/ap2-passenger :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: ruby24-passenger-5.3.3{,nb*} curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 cwrappers>=20150314 libunistring>=0.9.4 ruby24-base>=2.4.4 libyaml>=0.1.1 libyaml>=0.1.4 curl>=7.61.0nb2 apache>=2.4.7<2.5 apr>=1.5.0 apr-util>=1.5.3 apr-util>=1.2.8 pcre>=3.4nb1 nghttp2>=1.0.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 python27>=2.7.1nb2 libxml2>=2.8.0nb2 apr-util>=1.5.4nb4 pcre>=8.30nb1 nghttp2>=1.32.0nb1 apache>=2.4.34nb2 .

This package requires the following package(s) to run: ruby24-passenger-5.3.3{,nb*} curl>=7.12.3 libidn2>=2.0.0 libunistring>=0.9.3 libunistring>=0.9.4 ruby24-base>=2.4.4 libyaml>=0.1.1 libyaml>=0.1.4 curl>=7.61.0nb2 apache>=2.4.7<2.5 apr>=1.5.0 apr-util>=1.5.3 apr-util>=1.2.8 pcre>=3.4nb1 nghttp2>=1.0.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 python27>=2.7.1nb2 libxml2>=2.8.0nb2 readline>=2.2 apr-util>=1.5.4nb4 pcre>=8.30nb1 nghttp2>=1.32.0nb1 readline>=6.0 apache>=2.4.34nb2 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
earmv7hf:ap24-ruby22-passenger-5.2.1.tgz(NetBSD 8.0)
earmv7hf:ap24-ruby23-passenger-5.2.1.tgz(NetBSD 8.0)
earmv7hf:ap24-ruby24-passenger-5.2.1.tgz(NetBSD 8.0)
earmv7hf:ap24-ruby25-passenger-5.2.1.tgz(NetBSD 8.0)
i386:ap24-ruby22-passenger-5.3.2.tgz(NetBSD 7.0)
i386:ap24-ruby23-passenger-5.3.2.tgz(NetBSD 7.0)
i386:ap24-ruby24-passenger-5.3.2.tgz(NetBSD 7.0)
i386:ap24-ruby25-passenger-5.3.2.tgz(NetBSD 7.0)
i386:ap24-ruby22-passenger-5.2.1.tgz(NetBSD 7.0)
i386:ap24-ruby23-passenger-5.2.1.tgz(NetBSD 7.0)
i386:ap24-ruby24-passenger-5.2.1.tgz(NetBSD 7.0)
i386:ap24-ruby25-passenger-5.2.1.tgz(NetBSD 7.0)
i386:ap24-ruby22-passenger-5.3.2.tgz(NetBSD 7.1)
i386:ap24-ruby23-passenger-5.3.2.tgz(NetBSD 7.1)
i386:ap24-ruby24-passenger-5.3.2.tgz(NetBSD 7.1)
i386:ap24-ruby25-passenger-5.3.2.tgz(NetBSD 7.1)
i386:ap24-ruby22-passenger-5.2.1.tgz(NetBSD 7.1)
i386:ap24-ruby23-passenger-5.2.1.tgz(NetBSD 7.1)
i386:ap24-ruby24-passenger-5.2.1.tgz(NetBSD 7.1)
i386:ap24-ruby25-passenger-5.2.1.tgz(NetBSD 7.1)
i386:ap24-ruby22-passenger-5.3.2.tgz(NetBSD 8.0)
i386:ap24-ruby23-passenger-5.3.2.tgz(NetBSD 8.0)
i386:ap24-ruby24-passenger-5.3.2.tgz(NetBSD 8.0)
i386:ap24-ruby25-passenger-5.3.2.tgz(NetBSD 8.0)
i386:ap24-ruby22-passenger-5.2.1.tgz(NetBSD 8.0)
i386:ap24-ruby23-passenger-5.2.1.tgz(NetBSD 8.0)
i386:ap24-ruby24-passenger-5.2.1.tgz(NetBSD 8.0)
i386:ap24-ruby25-passenger-5.2.1.tgz(NetBSD 8.0)
powerpc:ap24-ruby24-passenger-5.2.1.tgz(NetBSD 6.1)
powerpc:ap24-ruby25-passenger-5.2.1.tgz(NetBSD 6.1)
powerpc:ap24-ruby24-passenger-5.2.1.tgz(NetBSD 6.1)
powerpc:ap24-ruby25-passenger-5.2.1.tgz(NetBSD 6.1)
powerpc:ap24-ruby22-passenger-5.2.1.tgz(NetBSD 8.0)
powerpc:ap24-ruby22-passenger-5.3.2.tgz(NetBSD 8.0)
powerpc:ap24-ruby23-passenger-5.2.1.tgz(NetBSD 8.0)
powerpc:ap24-ruby23-passenger-5.3.2.tgz(NetBSD 8.0)
powerpc:ap24-ruby24-passenger-5.2.1.tgz(NetBSD 8.0)
powerpc:ap24-ruby24-passenger-5.3.2.tgz(NetBSD 8.0)
powerpc:ap24-ruby25-passenger-5.2.1.tgz(NetBSD 8.0)
powerpc:ap24-ruby25-passenger-5.3.2.tgz(NetBSD 8.0)
powerpc:ap24-ruby22-passenger-5.2.1.tgz(NetBSD 8.0)
powerpc:ap24-ruby23-passenger-5.2.1.tgz(NetBSD 8.0)
powerpc:ap24-ruby24-passenger-5.2.1.tgz(NetBSD 8.0)
powerpc:ap24-ruby25-passenger-5.2.1.tgz(NetBSD 8.0)
x86_64:ap24-ruby22-passenger-5.2.1.tgz(NetBSD 6.1)
x86_64:ap24-ruby23-passenger-5.2.1.tgz(NetBSD 6.1)
x86_64:ap24-ruby24-passenger-5.2.1.tgz(NetBSD 6.1)
x86_64:ap24-ruby25-passenger-5.2.1.tgz(NetBSD 6.1)
x86_64:ap24-ruby22-passenger-5.3.2.tgz(NetBSD 7.0)
x86_64:ap24-ruby23-passenger-5.3.2.tgz(NetBSD 7.0)
x86_64:ap24-ruby24-passenger-5.3.2.tgz(NetBSD 7.0)
x86_64:ap24-ruby25-passenger-5.3.2.tgz(NetBSD 7.0)
x86_64:ap24-ruby22-passenger-5.2.1.tgz(NetBSD 7.0)
x86_64:ap24-ruby23-passenger-5.2.1.tgz(NetBSD 7.0)
x86_64:ap24-ruby24-passenger-5.2.1.tgz(NetBSD 7.0)
x86_64:ap24-ruby25-passenger-5.2.1.tgz(NetBSD 7.0)
x86_64:ap24-ruby22-passenger-5.3.2.tgz(NetBSD 7.1)
x86_64:ap24-ruby23-passenger-5.3.2.tgz(NetBSD 7.1)
x86_64:ap24-ruby24-passenger-5.3.2.tgz(NetBSD 7.1)
x86_64:ap24-ruby25-passenger-5.3.2.tgz(NetBSD 7.1)
x86_64:ap24-ruby22-passenger-5.2.1.tgz(NetBSD 7.1)
x86_64:ap24-ruby23-passenger-5.2.1.tgz(NetBSD 7.1)
x86_64:ap24-ruby24-passenger-5.2.1.tgz(NetBSD 7.1)
x86_64:ap24-ruby25-passenger-5.2.1.tgz(NetBSD 7.1)
x86_64:ap24-ruby22-passenger-5.3.2.tgz(NetBSD 8.0)
x86_64:ap24-ruby23-passenger-5.3.2.tgz(NetBSD 8.0)
x86_64:ap24-ruby24-passenger-5.3.2.tgz(NetBSD 8.0)
x86_64:ap24-ruby25-passenger-5.3.2.tgz(NetBSD 8.0)
x86_64:ap24-ruby22-passenger-5.2.1.tgz(NetBSD 8.0)
x86_64:ap24-ruby23-passenger-5.2.1.tgz(NetBSD 8.0)
x86_64:ap24-ruby24-passenger-5.2.1.tgz(NetBSD 8.0)
x86_64:ap24-ruby25-passenger-5.2.1.tgz(NetBSD 8.0)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]