Daemon Power

The NetBSD Packages Collection: www/p5-Apache-Gallery

Brief description of the package:
Perl5/Apache module for handling image directories

Please read the file "DESCR" for a longer description, or browse the package's history.

This package has a home page at http://apachegallery.dk/.

Please note that this package has a artistic license.

The package is located in the "www/p5-Apache-Gallery" directory. The current source version of the package is "p5-Apache-Gallery-0.9.1nb30". For a summary on how to use the package collection, go to the top of the packages tree.

Problem reports, updates or suggestions for this package should be reported with send-pr.

The following security vulnerabilities are known for www/p5-Apache-Gallery :

If you have a vulnerable package installed on any machine, you are advised to remove the package immediately, using the standard package tools. The pkg_admin audit command locates any installed package which has been mentioned in security advisories as being vulnerable.

This package requires the following package(s) to build: p5-CGI>=2.93 p5-HTML-Parser-[0-9]* p5-HTML-Tagset>=3.0 perl>=5.26.0 cwrappers>=20150314 perl<5.28.0 p5-URI-[0-9]* p5-Test-Needs-[0-9]* p5-Test-Deep-[0-9]* p5-Test-Simple>=1.001010 p5-Test-Warn-[0-9]* p5-Sub-Uplevel>=0.12 p5-Test-NoWarnings-[0-9]* p5-URI>=1.23 p5-Image-Imlib2-[0-9]* imlib2>=1.2.0nb2 freetype2>=2.4.5 freetype2>=2.1.3 jpeg>=8nb1 giflib>=5.1.0 png>=1.2.4 tiff>=3.6.1 jbigkit>=2.0 jpeg>=9 freetype2>=2.4.11 png>=1.6.0nb1 tiff>=4.0.3nb5 x11-links>=1.06 osabi-NetBSD-7.0.1 imlib2>=1.1.0nb2 imlib2>=1.4.5nb7 p5-Module-Build>=0.42050 p5-inc-latest-[0-9]* p5-CPAN-Meta>=2.142060 p5-Scalar-List-Utils>=1.33 p5-Image-Info>=1.15 p5-XML-LibXML-[0-9]* p5-XML-SAX>=0.11 p5-XML-NamespaceSupport>=0.03 p5-XML-SAX-Base>=1.08 p5-XML-NamespaceSupport>=1.07 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 p5-Image-Size-[0-9]* p5-Text-Template-[0-9]* p5-ap24-libapreq{,2}-[0-9]* p5-ExtUtils-XSBuilder>=0.23 p5-Parse-RecDescent-[0-9]* p5-Text-Balanced-[0-9]* p5-Tie-IxHash-[0-9]* ap24-perl>=2.0.1 apache>=2.4.7<2.5 apr>=1.5.0 apr-util>=1.5.3 apr-util>=1.2.8 pcre>=3.4nb1 nghttp2>=1.0.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 readline>=2.2 readline>=6.0 python27>=2.7.1nb2 apr-util>=1.5.4nb4 pcre>=8.30nb1 nghttp2>=1.25.0nb1 apache>=2.4.18nb1 ap24-perl>=2.0.3 apache>=2.0.48 .

This package requires the following package(s) to run: p5-CGI>=2.93 p5-HTML-Parser-[0-9]* p5-HTML-Tagset>=3.0 perl>=5.26.0 perl<5.28.0 p5-URI-[0-9]* p5-URI>=1.23 p5-Image-Imlib2-[0-9]* imlib2>=1.2.0nb2 freetype2>=2.4.5 freetype2>=2.1.3 jpeg>=8nb1 giflib>=5.1.0 png>=1.2.4 tiff>=3.6.1 jbigkit>=2.0 jpeg>=9 freetype2>=2.4.11 png>=1.6.0nb1 tiff>=4.0.3nb5 imlib2>=1.1.0nb2 imlib2>=1.4.5nb7 p5-Image-Info>=1.15 p5-XML-LibXML-[0-9]* p5-XML-SAX>=0.11 p5-XML-NamespaceSupport>=0.03 p5-XML-SAX-Base>=1.08 p5-XML-NamespaceSupport>=1.07 libxml2>=2.6.2 xmlcatmgr>=2.0beta1 libxml2>=2.8.0nb2 p5-Image-Size-[0-9]* p5-Text-Template-[0-9]* p5-ap24-libapreq{,2}-[0-9]* p5-ExtUtils-XSBuilder>=0.23 p5-Parse-RecDescent-[0-9]* p5-Text-Balanced-[0-9]* p5-Tie-IxHash-[0-9]* ap24-perl>=2.0.1 apache>=2.4.7<2.5 apr>=1.5.0 apr-util>=1.5.3 apr-util>=1.2.8 pcre>=3.4nb1 nghttp2>=1.0.0 python27>=2.7 mozilla-rootcerts>=1.0.20150804nb1 libffi>=1.20 libffi>=3.0.11 python27>=2.7.1nb2 readline>=2.2 apr-util>=1.5.4nb4 pcre>=8.30nb1 nghttp2>=1.25.0nb1 readline>=6.0 apache>=2.4.18nb1 ap24-perl>=2.0.3 .

This package supports the following build-time options:

(none)

Select one of the links below to download the package in precompiled binary form for installation with pkg_add(1). Available machine architectures and package versions:
alpha:p5-Apache-Gallery-0.9.1nb27.tgz(NetBSD 7.0)
arm:p5-Apache-Gallery-0.9.1nb24.tgz(NetBSD 6.1_STABLE)
earm:p5-Apache-Gallery-0.9.1nb27.tgz(NetBSD 7.0)
earmv6hf:p5-Apache-Gallery-0.9.1nb27.tgz(NetBSD 7.0)
earmv6hf:p5-Apache-Gallery-0.9.1nb27.tgz(NetBSD 7.0)
earmv7hf:p5-Apache-Gallery-0.9.1nb27.tgz(NetBSD 7.0)
earmv7hf:p5-Apache-Gallery-0.9.1nb30.tgz(NetBSD 8.0_BETA)
i386:p5-Apache-Gallery-0.9.1nb24.tgz(MirBSD 10)
i386:p5-Apache-Gallery-0.9.1nb30.tgz(NetBSD 6.0)
i386:p5-Apache-Gallery-0.9.1nb28.tgz(NetBSD 6.0)
i386:p5-Apache-Gallery-0.9.1nb28.tgz(NetBSD 6.0)
i386:p5-Apache-Gallery-0.9.1nb29.tgz(NetBSD 6.0)
i386:p5-Apache-Gallery-0.9.1nb30.tgz(NetBSD 6.0)
i386:p5-Apache-Gallery-0.9.1nb30.tgz(NetBSD 6.1)
i386:p5-Apache-Gallery-0.9.1nb28.tgz(NetBSD 6.1)
i386:p5-Apache-Gallery-0.9.1nb28.tgz(NetBSD 6.1)
i386:p5-Apache-Gallery-0.9.1nb29.tgz(NetBSD 6.1)
i386:p5-Apache-Gallery-0.9.1nb30.tgz(NetBSD 7.0)
i386:p5-Apache-Gallery-0.9.1nb28.tgz(NetBSD 7.0)
i386:p5-Apache-Gallery-0.9.1nb28.tgz(NetBSD 7.0)
i386:p5-Apache-Gallery-0.9.1nb29.tgz(NetBSD 7.0)
i386:p5-Apache-Gallery-0.9.1nb14.tgz(QNX 6.5.0)
powerpc:p5-Apache-Gallery-0.9.1nb28.tgz(NetBSD 6.0)
powerpc:p5-Apache-Gallery-0.9.1nb30.tgz(NetBSD 6.1)
powerpc:p5-Apache-Gallery-0.9.1nb27.tgz(NetBSD 7.0)
powerpc:p5-Apache-Gallery-0.9.1nb30.tgz(NetBSD 7.1)
powerpc:p5-Apache-Gallery-0.9.1nb30.tgz(NetBSD 7.1)
powerpc:p5-Apache-Gallery-0.9.1nb30.tgz(NetBSD 8.0)
x86_64:p5-Apache-Gallery-0.9.1nb30.tgz(NetBSD 6.0)
x86_64:p5-Apache-Gallery-0.9.1nb28.tgz(NetBSD 6.0)
x86_64:p5-Apache-Gallery-0.9.1nb28.tgz(NetBSD 6.0)
x86_64:p5-Apache-Gallery-0.9.1nb29.tgz(NetBSD 6.0)
x86_64:p5-Apache-Gallery-0.9.1nb30.tgz(NetBSD 6.0)
x86_64:p5-Apache-Gallery-0.9.1nb30.tgz(NetBSD 6.1)
x86_64:p5-Apache-Gallery-0.9.1nb28.tgz(NetBSD 6.1)
x86_64:p5-Apache-Gallery-0.9.1nb28.tgz(NetBSD 6.1)
x86_64:p5-Apache-Gallery-0.9.1nb29.tgz(NetBSD 6.1)
x86_64:p5-Apache-Gallery-0.9.1nb30.tgz(NetBSD 6.1)
x86_64:p5-Apache-Gallery-0.9.1nb30.tgz(NetBSD 7.0)
x86_64:p5-Apache-Gallery-0.9.1nb28.tgz(NetBSD 7.0)
x86_64:p5-Apache-Gallery-0.9.1nb28.tgz(NetBSD 7.0)
x86_64:p5-Apache-Gallery-0.9.1nb29.tgz(NetBSD 7.0)
x86_64:p5-Apache-Gallery-0.9.1nb30.tgz(NetBSD 7.0.1_PATCH)
x86_64:p5-Apache-Gallery-0.9.1nb30.tgz(NetBSD 8.99.1)
x86_64:p5-Apache-Gallery-0.9.1nb30.tgz(NetBSD 8.99.1)

The NetBSD packages collection is designed to permit easy installation from source - particularly useful if the latest binary package is not available for your chosen platform.


[ Go up one level | Go to top of packages tree | List all packages ]