x11/gtk3 - The NetBSD Packages Collection

GIMP Toolkit v3 - libraries for building X11 user interfaces

GTK+ is a multi-platform toolkit for creating graphical user
interfaces. Offering a complete set of widgets, GTK+ is suitable for
projects ranging from small one-off tools to complete application
suites.

GTK+ has been designed from the ground up to support a range of
languages, not only C/C++. Using GTK+ from languages such as Perl and
Python (especially in combination with the Glade GUI builder) provides
an effective method of rapid application development.

This package contains GTK+ 3.

Build dependencies

pkgtools/x11-links devel/gobject-introspection devel/gobject-introspection x11/xorgproto x11/xcb-proto pkgtools/cwrappers devel/gobject-introspection devel/gdbus-codegen devel/gettext-tools devel/glib2-tools devel/libtool-base shells/bash devel/gmake lang/perl5 devel/pkgconf devel/gettext-tools

Runtime dependencies

converters/fribidi databases/shared-mime-info devel/atk devel/atk devel/glib2 devel/glib2 graphics/gdk-pixbuf2 graphics/gdk-pixbuf2 print/libcups devel/at-spi2-atk x11/xcursor x11/xcursor x11/libXfixes x11/libXrender fonts/Xft2 fonts/Xft2 fonts/Xft2 fonts/fontconfig fonts/fontconfig graphics/freetype2 graphics/freetype2 x11/liboldXrandr x11/liboldXrandr x11/libXcomposite devel/pango devel/pango graphics/cairo graphics/cairo graphics/cairo-gobject graphics/libepoxy graphics/libepoxy graphics/hicolor-icon-theme sysutils/desktop-file-utils databases/shared-mime-info devel/atk devel/glib2 graphics/gdk-pixbuf2 print/libcups devel/at-spi2-atk x11/xcursor fonts/Xft2 fonts/fontconfig x11/liboldXrandr devel/pango graphics/cairo graphics/cairo-gobject graphics/hicolor-icon-theme sysutils/desktop-file-utils

Binary packages

OSArchitectureVersion
NetBSD 8.0earmv7hfgtk3+-3.24.23.tgz
NetBSD 8.0earmv7hfgtk3+-3.24.22nb2.tgz
NetBSD 8.0earmv7hfgtk3+-3.24.27.tgz
NetBSD 8.0earmv7hfgtk3+-3.24.23.tgz
NetBSD 8.0i386gtk3+-3.24.22nb2.tgz
NetBSD 8.0i386gtk3+-3.24.23.tgz
NetBSD 8.0i386gtk3+-3.24.27.tgz
NetBSD 8.0powerpcgtk3+-3.24.22nb2.tgz
NetBSD 8.0powerpcgtk3+-3.24.23.tgz
NetBSD 8.0powerpcgtk3+-3.24.23.tgz
NetBSD 8.0x86_64gtk3+-3.24.22nb2.tgz
NetBSD 8.0x86_64gtk3+-3.24.23.tgz
NetBSD 9.0aarch64gtk3+-3.24.27.tgz
NetBSD 9.0aarch64gtk3+-3.24.22nb2.tgz
NetBSD 9.0aarch64gtk3+-3.24.23.tgz
NetBSD 9.0alphagtk3+-3.24.27.tgz
NetBSD 9.0alphagtk3+-3.24.22nb2.tgz
NetBSD 9.0alphagtk3+-3.24.23.tgz
NetBSD 9.0earmgtk3+-3.24.22nb2.tgz
NetBSD 9.0earmgtk3+-3.24.27.tgz
NetBSD 9.0earmv6hfgtk3+-3.24.27.tgz
NetBSD 9.0earmv6hfgtk3+-3.24.22nb2.tgz
NetBSD 9.0earmv6hfgtk3+-3.24.23.tgz
NetBSD 9.0earmv6hfgtk3+-3.24.23.tgz
NetBSD 9.0earmv7hfgtk3+-3.24.27.tgz
NetBSD 9.0earmv7hfgtk3+-3.24.22nb2.tgz
NetBSD 9.0earmv7hfgtk3+-3.24.23.tgz
NetBSD 9.0earmv7hfgtk3+-3.24.23.tgz
NetBSD 9.0earmv7hfgtk3+-3.24.23.tgz
NetBSD 9.0i386gtk3+-3.24.22nb2.tgz
NetBSD 9.0i386gtk3+-3.24.23.tgz
NetBSD 9.0m68kgtk3+-3.24.22nb2.tgz
NetBSD 9.0m68kgtk3+-3.24.23.tgz
NetBSD 9.0mips64ebgtk3+-3.24.27.tgz
NetBSD 9.0mips64ebgtk3+-3.24.22nb2.tgz
NetBSD 9.0mips64ebgtk3+-3.24.23.tgz
NetBSD 9.0mipselgtk3+-3.24.27.tgz
NetBSD 9.0powerpcgtk3+-3.24.23.tgz
NetBSD 9.0powerpcgtk3+-3.24.22nb2.tgz
NetBSD 9.0sh3elgtk3+-3.24.23.tgz
NetBSD 9.0sh3elgtk3+-3.24.27.tgz
NetBSD 9.0sparc64gtk3+-3.24.27.tgz
NetBSD 9.0sparc64gtk3+-3.24.20nb1.tgz
NetBSD 9.0sparc64gtk3+-3.24.22nb2.tgz
NetBSD 9.0sparc64gtk3+-3.24.23.tgz
NetBSD 9.0sparcgtk3+-3.24.27.tgz
NetBSD 9.0sparcgtk3+-3.24.22nb2.tgz
NetBSD 9.0sparcgtk3+-3.24.23.tgz
NetBSD 9.0x86_64gtk3+-3.24.23.tgz
NetBSD 9.0x86_64gtk3+-3.24.23.tgz
NetBSD 9.0x86_64gtk3+-3.24.24.tgz
NetBSD 9.0x86_64gtk3+-3.24.22nb2.tgz
NetBSD 9.0x86_64gtk3+-3.24.23.tgz
NetBSD 9.0x86_64gtk3+-3.24.27.tgz

Binary packages can be installed with the high-level tool pkgin (which can be installed with pkg_add) or pkg_add(1) (installed by default). The NetBSD packages collection is also designed to permit easy installation from source.

Available build options

cups
Enable cups (Common UNIX Printing System) support.
debug
Enable debugging facilities in the package.
gtk3-atk-bridge
Enable ATK support.
wayland
Enable support for the Wayland display server protocol.
x11
Enable X11 support.

Known vulnerabilities

The pkg_admin audit command locates any installed package which has been mentioned in security advisories as having vulnerabilities.

Please note the vulnerabilities database might not be fully accurate, and not every bug is exploitable with every configuration.


Problem reports, updates or suggestions for this package should be reported with send-pr.